Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-25-2007, 02:35 PM   #1
summit425
Alpine White
 
Join Date: Apr 2007
Location: Downtown Toronto
Posts: 1,322
Which Wiper Blades do you use?

Few weeks ago I changed mine to bosch



I think this doesn't work well on my car because I hear some vibration between wiper and windshield.

Should I change back to original style wiper blades?




Also I don't know where is my wiper wind deflector... do I need this??

The recent wiper comes with wind deflector but old style wiper doens't.
summit425 is offline   Reply With Quote
Old 11-25-2007, 02:47 PM   #2
enfield
2nd Gear Member
 
enfield's Avatar
 
Join Date: Apr 2007
Location: Ontario
Posts: 113
I am using Bosch Icons too. They are fantastic in my opinion.
enfield is offline   Reply With Quote
Old 11-25-2007, 04:47 PM   #3
SickFinga
Moderator
 
SickFinga's Avatar
 
Join Date: Jan 2002
Location: Location:
Posts: 16,518
Quote:
Originally Posted by summit425 View Post
Few weeks ago I changed mine to bosch



I think this doesn't work well on my car because I hear some vibration between wiper and windshield.

Should I change back to original style wiper blades?




Also I don't know where is my wiper wind deflector... do I need this??

The recent wiper comes with wind deflector but old style wiper doens't.
Wind deflector comes with wipers, driver's side only.
SickFinga is offline   Reply With Quote
Old 11-25-2007, 07:01 PM   #4
Boots R
Boots, not boost
 
Boots R's Avatar
 
Join Date: Jun 2006
Location: Brampton
Posts: 11,032
I hate the icons. They are the worst wiper ever. Same with those "reflex"s they sell at canadian tire.
Boots R is offline   Reply With Quote
Old 11-25-2007, 07:51 PM   #5
Jim .E.
E90 n00b
 
Jim .E.'s Avatar
 
Join Date: Jun 2003
Location: Brampton
Posts: 6,657
Valeo wipers.
__________________
Jim .E. is offline   Reply With Quote
Old 11-25-2007, 07:57 PM   #6
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,083
using the icons, no issues so far. Boots, why don't you like the icons?

I used the first version of the reflex, they were garbage.
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 11-25-2007, 09:06 PM   #7
JUS_CRZN
My other car's a jet.
 
JUS_CRZN's Avatar
 
Join Date: Sep 2004
Location: Milton, Ontario
Posts: 1,074
I like the Bosch micro edge.
__________________
JUS_CRZN
JUS_CRZN is offline   Reply With Quote
Old 11-25-2007, 09:53 PM   #8
M3ti Compact
Fuel Efficient 318 Member
 
M3ti Compact's Avatar
 
Join Date: Mar 2002
Location: Toronto
Posts: 3,465
I use the Michelin frameless wipers from Costco. Can't complain for $12 each.

I find that most frameless wipers ice up to easily in snow and cold weather. For winter, I perfer the old style: heavy frame with rubber boot surrounding it- but any faster than 100km/h and they start flapping like crazy.

Frameless can go up to max speed on the autobahn and still wipe perfect.
__________________
M3ti Compact is offline   Reply With Quote
Old 11-25-2007, 10:03 PM   #9
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,083
icons are only about $20/ea
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 11-25-2007, 10:17 PM   #10
icu
3rd Gear Member
 
icu's Avatar
 
Join Date: May 2005
Location: Toronto
Posts: 351
Ditto on the Bosch Micro edge, great wipe no chatter or lift.
Attached Images
File Type: jpg dsc04677pw1.jpg (36.0 KB, 214 views)
__________________
icu is offline   Reply With Quote
Old 11-25-2007, 10:56 PM   #11
AceOfSpades
♠ ♠ ♠
 
AceOfSpades's Avatar
 
Join Date: Aug 2006
Location: Creston, Iowa
Posts: 4,171
Quote:
Originally Posted by Gamite View Post
icons are only about $20/ea
where? lol
does it look good on your E34?
AceOfSpades is offline   Reply With Quote
Old 11-25-2007, 11:12 PM   #12
slemmer
Driving in the fast lane
 
slemmer's Avatar
 
Join Date: Dec 2002
Location: Missed in 'sauga
Posts: 2,999
Frameless wipers suck. I had them on last year and while scraping off ice from the windshield I contacted one of them and bent it out of shape. Once bent, they cannot be straightened back to normal. They're only good for three season driving IMHO.
slemmer is offline   Reply With Quote
Old 11-25-2007, 11:30 PM   #13
Boots R
Boots, not boost
 
Boots R's Avatar
 
Join Date: Jun 2006
Location: Brampton
Posts: 11,032
Quote:
Originally Posted by Gamite View Post
using the icons, no issues so far. Boots, why don't you like the icons?

I used the first version of the reflex, they were garbage.
My friend had the icons on his car, and in the rain they would always miss spots.

Then again, maybe the pair he bought were defective.
Boots R is offline   Reply With Quote
Old 11-25-2007, 11:43 PM   #14
luker0
2nd Gear Member
 
Join Date: Sep 2007
Location: Nepean, ON, Canada
Posts: 71
Bad experience with the Reflex here on two different cars. On one car the blade is so long that it chatters and lift at the far tips. On the other car they never contacted the passenger side properly and left big streaks on the windshield.

Went back to the cheap CTC metal blades, $6.99 each or so. Replace when worn. Rinse and repeat.
luker0 is offline   Reply With Quote
Old 11-25-2007, 11:57 PM   #15
summit425
Alpine White
 
Join Date: Apr 2007
Location: Downtown Toronto
Posts: 1,322
I am using reflex one right now and passenger side works good but not on driver side. It makes noise like when I am using wiper where no liquid on the surface. sounds like ta ta ta

I might change driver side only back to old style. BTW., Do I really need a wind reflector on the driver side?? Cuz I think I threw OE reflector away..
summit425 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:50 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014