Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-18-2007, 12:19 AM   #1
AlexS
2nd Gear Member
 
AlexS's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 132
Bought an E30 today!

So after a long search I found something that I thought was worthwhile. It's my second car, first BMW. Looking forward to learning more about it. I am a bit ignorant about it. Sorry!

It's an '87 325i 4 door. Zinnoberrot. All stock.

It's got a tan leather sport interior, Power windows and sunroof, and is mostly rust free. It's been repainted. It didn't come with records. I got it on the cheap. Just over 200kms. Unknown mileage on clutch, but it works. Timing belt was apparently done around 185,000km. Body is ok; paint job is there, but I'm sure some of you would describe it as a "10 foot car". It's got a new battery, a few new hoses and a nice new stereo. Rollin' on bottle caps. Heated seats work. AC does not.

Problems so far:

-Slight shimmy at speed. Alignment? Wheel balance?
-Slight shimmy under braking. Pads/rotors look pretty good.
-Engine oil light is on.
-ABS light is on.
-Shifter seems to be leaning to the left. When going into reverse gear, you sort of have to push into the left side of the center console.
-Gas tank leaks, apparently. I have owned it for about 10 hours now, so I haven't had it parked anywhere long enough to notice a leak. GF's dad said it smelled like gas.
-Is there not supposed to be a light on when I enter the car? The ones above the B pillars do not function in the center position. There is a black plastic cover near the OBC display. Should this be a light? Seems odd that there's no light in the front of the cabin.

Some of the issues are me being picky. Others, such as the shimmy(s) are more of a problem.

Obviously I will look into these issues myself, but any input? Gas tank and shimmys are getting first priority right now. Does it sound like there's an unreasonably large amount of problems for a cheap non-rusty 325i?

Attached is a pic; it's the only one I have. Sun went down just as I was finishing washing it.

AlexS is offline   Reply With Quote
Old 10-18-2007, 12:34 AM   #2
markw
.
 
markw's Avatar
 
Join Date: Jan 2006
Location: GTA
Posts: 471
Congrats! I bought a cheap E30 too.... they're a big ****ing headache, but worth it, and a lot of fun too. Don't be afraid to try new shit! Buy some tools!
markw is offline   Reply With Quote
Old 10-18-2007, 12:34 AM   #3
FuryriderX
cra.iX.y
 
FuryriderX's Avatar
 
Join Date: Nov 2006
Location: Stoney Creek
Posts: 1,259
shimmy is more than likely worn out front control arm bushings. not a huge pain to replace. could also be slightly warped rotors.

yeah those are interior lights above the b-pillars. center is off. one or the other extreme is 'on', the other is 'door'. the lights blow out often, pull them apart and check.

abs light is probably a bad wheel speed sensor. i recommend just taking out the warning light. who needs abs anyways

and yes e30s do not have a light in the front of the cabin. it sucks. you can get maplight mirrors for them though. i have one in my car.

getting the a/c working can be a chore, believe me, i know. if you can live without it, i recommend that you do so.

all said and done though, seems like a decent car. welcome to the wonderful world of e30s!
__________________
FuryriderX is offline   Reply With Quote
Old 10-18-2007, 12:41 AM   #4
e30_kid89
The Afro-stig
 
e30_kid89's Avatar
 
Join Date: Nov 2005
Location: TDot West End
Posts: 4,594
Send a message via MSN to e30_kid89
I was going to post the same things but Furyrider answered the Q's. the leaning shifter means your bushings are shot. They will all need to be changed to get the shifter tight again. Also, check the engine oil level. If its okay, blame the sensor.

Come out the E30 meet goin' down this sunday and show off the new ride!
__________________
e30_kid89 is offline   Reply With Quote
Old 10-18-2007, 12:49 AM   #5
Trekz
4th Gear Member
 
Join Date: Oct 2006
Location: Newmarket, Ontario
Posts: 715
leaking gas tank could be bad rubber gasket on the fuelpump, i was leakin gas on my e36 and that was the problem.
Trekz is online now   Reply With Quote
Old 10-18-2007, 01:06 AM   #6
AlexS
2nd Gear Member
 
AlexS's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 132
Thanks for the replies guys.

I thought of another issue- it idles like shit. Was told elsewhere that some fresh plugs and wires would help.

I was told that the shifter bushings were replaced, but it doesn't feel all that tight. Would bushings have straightened it out? Another one of the E30's I drove had a similar left-pointing shifter, and as far as I recall it felt very tight, with minimal play.

I am going to move the car tomorrow morning to look at the ground. We'll see what sort of fluids I find.

Control arm bushings eh? I wonder what that will cost me. What about the braking shimmy? Wobbly rotors are probably the most likely candidate I guess.

I will come on Sunday. Could anyone help me have a look over the car? It would be really helpful.

On the plus side, it goes pretty good! The (stock) 2.8 Z3 I've had on the last two Bimmercruises doesn't feel all that much faster. I can carry more girls in this car too!

Lastly, what sort of differential would this car have? First gear feels fairly short. That is all I know.

Last edited by AlexS; 10-18-2007 at 01:19 AM.
AlexS is offline   Reply With Quote
Old 10-18-2007, 01:22 AM   #7
AlexS
2nd Gear Member
 
AlexS's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 132
Driver's door lock fails to lock/unlock the car as well. Is this an easy fix?
AlexS is offline   Reply With Quote
Old 10-18-2007, 09:08 AM   #8
El Gato Liso
6th Gear Member
 
El Gato Liso's Avatar
 
Join Date: May 2007
Location: Brampton
Posts: 3,111
the shifter you HAVE to push it hard into reverse. it is just a safty lock that prevents you from accidentally putting it into reverse.

my shifter has little play too
but mine is short sifted. i dunno if yours is stock or not

and the vibrating @ high speeds its either your tires have flat spots on them, or u neede some wheel alingnment or u need to fill up ur tires with air
__________________
R.I.P. E30
El Gato Liso is offline   Reply With Quote
Old 10-18-2007, 09:16 AM   #9
Axxe
Over 9 F**KING THOUSAND!!
 
Axxe's Avatar
 
Join Date: May 2004
Location: Oakville
Posts: 9,769
Shimmy = control arm bushings. Especially if it's the same or worse under braking.
__________________

S52|ZF|TRM Coilovers 670/895|Staggered 18" 5's
Axxe is offline   Reply With Quote
Old 10-18-2007, 09:21 AM   #10
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,393
Did you get the car safetied and emission tested already?

Sounds like a fair bit of small problems, shouldn't be too bad thou, jus have patience with it.

The gas leak could probably be the biggest problem, have someone find the leak by lifting it up on a hoist. Hopefully its just the fuel pump gasket or filler neck. If its the tank itself, it can be a costly repair (4-5hr labour)
__________________
T.Dot_E30 is online now   Reply With Quote
Old 10-18-2007, 10:16 AM   #11
AlexS
2nd Gear Member
 
AlexS's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 132
I was told it's the tank. I will get it up on a hoist soon to see.

I'm aware that the shifter requires a hard push to engage reverse. It seems off center in my car though. Once in 5th, the shifter stays in the middle, not on the right where I believe it should be.

Wheels are getting balanced ASAP. I'm hoping this solves the problem. I wonder about the control arm bushings though.
AlexS is offline   Reply With Quote
Old 10-18-2007, 10:34 AM   #12
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,393
Quote:
Originally Posted by AlexS View Post
I'm aware that the shifter requires a hard push to engage reverse. It seems off center in my car though. Once in 5th, the shifter stays in the middle, not on the right where I believe it should be.
In that case have a look at the tranny mounts, and engine mounts, something could be causing the engine / transmission to lean to the left. Which can displace the shifter.
__________________
T.Dot_E30 is online now   Reply With Quote
Old 10-18-2007, 02:09 PM   #13
AWD_Guy
1st Gear Newbie
 
AWD_Guy's Avatar
 
Join Date: Jul 2007
Location: Ottawa
Posts: 43
I had to replace my tank because it was leaking like crazy. Also take a look at the filler neck to your tank, mine was leaking and had to return to the shop to get that fixed to. Heads up: it was very pricey!
AWD_Guy is offline   Reply With Quote
Old 10-18-2007, 02:34 PM   #14
FuryriderX
cra.iX.y
 
FuryriderX's Avatar
 
Join Date: Nov 2006
Location: Stoney Creek
Posts: 1,259
The bad idle is most likely a vacuum leak in the intake. Check for cracks in all the rubber intake hoses. You also might want to clean the idle air control valve with some carb cleaner. That helped a bit on my car.

__________________
FuryriderX is offline   Reply With Quote
Old 10-18-2007, 06:08 PM   #15
sicilianace
E-thirtysexer
 
sicilianace's Avatar
 
Join Date: Apr 2004
Location: Richmond Hill, On
Posts: 345
Send a message via ICQ to sicilianace
Congrats, Alex ,u really meant it about buying an e30......ready to have some fun....happy motoring................see u at autumn e30 meet this sunday

Anthony
__________________
e36 325is
e30 m3
sicilianace is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:43 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.