Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-21-2007, 10:58 AM   #1
Bandi
der mechanik
 
Bandi's Avatar
 
Join Date: Mar 2005
Location: Campbellford, Ontario
Posts: 116
Send a message via MSN to Bandi
'84 318i losing injector pulse

Hey everyone... I'm working on an '84 318i that belongs to my friend, the car *usually* runs great, but now it's not revving past 1200 rpm. (It used to do this intermittently, usually if you hit a bump). Timing is okay, and I tried changing the pickup coil in the distributor.

Anyhow, I've determined that when you try to rev the car higher, it's losing injector pulse. Any suggestions? Where does the car get the injector pulse signal from? (I have a few service manuals... just not here at work.)

Any help would be greatly appreciated.
__________________
-'72 2002
-'72 Super Beetle
-'72 Baja Champion SE Beetle
-'66 Beetle
-'74 Sun Bug
-'75 La Grande Bug
-'65 Fiat 1500 Cabriolet
-'99 New Beetle TDi
-'84 Rabbit Cabriolet SportLine
-'91 Tercel GT-S Twin Cam
Bandi is offline   Reply With Quote
Old 08-21-2007, 11:14 AM   #2
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,283
It gets it from the ECU, it could be either a broken wire somewhere causing a faulty connection which would be a bitch to find, or if your lucky, its the ECU. Do you have a spare you can try swapping?
__________________
T.Dot_E30 is online now   Reply With Quote
Old 08-21-2007, 11:55 AM   #3
Bandi
der mechanik
 
Bandi's Avatar
 
Join Date: Mar 2005
Location: Campbellford, Ontario
Posts: 116
Send a message via MSN to Bandi
Thanks for the response.

Don't have a spare ECU (I'd have about 20 if this was a 6 cylinder car)

Any idea where the ECU gets the rpm reading from? I have a super basic diagram here that's showing the coil negative terminal, but it doesn't show which terminal it gets fed to the ECU thru.

Or, is it using the pickup coil in the distributor for something?
__________________
-'72 2002
-'72 Super Beetle
-'72 Baja Champion SE Beetle
-'66 Beetle
-'74 Sun Bug
-'75 La Grande Bug
-'65 Fiat 1500 Cabriolet
-'99 New Beetle TDi
-'84 Rabbit Cabriolet SportLine
-'91 Tercel GT-S Twin Cam
Bandi is offline   Reply With Quote
Old 08-21-2007, 12:21 PM   #4
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,283
Quote:
Originally Posted by Bandi
Thanks for the response.

Don't have a spare ECU (I'd have about 20 if this was a 6 cylinder car)

Any idea where the ECU gets the rpm reading from? I have a super basic diagram here that's showing the coil negative terminal, but it doesn't show which terminal it gets fed to the ECU thru.

Or, is it using the pickup coil in the distributor for something?

Sorry I don't know M10s enough, I'd have to see a wiring diagram to try and figure it out.
__________________
T.Dot_E30 is online now   Reply With Quote
Old 08-21-2007, 07:52 PM   #5
e30jones
3rd Gear Member
 
Join Date: Mar 2004
Location: Lindsay, ON
Posts: 312
I have two spare 310 L-jet ECU's if you want to try them out...I don't have an 84 anymore, so they are available for sale if you need them too...

Check this site out for Electrical Troubleshooting Manuals, there is the Injection Control Module above the glove box too...might have something to do with this, I think its a smaller green box?

Here--->> http://wedophones.com/BMWManualsLead.htm

Last edited by e30jones; 08-21-2007 at 08:00 PM.
e30jones is offline   Reply With Quote
Old 08-22-2007, 07:13 AM   #6
Bandi
der mechanik
 
Bandi's Avatar
 
Join Date: Mar 2005
Location: Campbellford, Ontario
Posts: 116
Send a message via MSN to Bandi
I think the car was just given to me... so next question... M20 swap?

Thanks for your help guys.
__________________
-'72 2002
-'72 Super Beetle
-'72 Baja Champion SE Beetle
-'66 Beetle
-'74 Sun Bug
-'75 La Grande Bug
-'65 Fiat 1500 Cabriolet
-'99 New Beetle TDi
-'84 Rabbit Cabriolet SportLine
-'91 Tercel GT-S Twin Cam
Bandi is offline   Reply With Quote
Old 08-22-2007, 07:48 AM   #7
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,283
Quote:
Originally Posted by Bandi
I think the car was just given to me... so next question... M20 swap?

Thanks for your help guys.
if the car has no rust, do it.
__________________
T.Dot_E30 is online now   Reply With Quote
Old 08-22-2007, 09:41 PM   #8
Bandi
der mechanik
 
Bandi's Avatar
 
Join Date: Mar 2005
Location: Campbellford, Ontario
Posts: 116
Send a message via MSN to Bandi
It's really solid (And pretty nice looking, the car is sort of a tan colour with dark brown leather) , and I have a wrecked '87 325i in the barn that would make a perfect donor car.
__________________
-'72 2002
-'72 Super Beetle
-'72 Baja Champion SE Beetle
-'66 Beetle
-'74 Sun Bug
-'75 La Grande Bug
-'65 Fiat 1500 Cabriolet
-'99 New Beetle TDi
-'84 Rabbit Cabriolet SportLine
-'91 Tercel GT-S Twin Cam
Bandi is offline   Reply With Quote
Old 08-25-2007, 09:17 PM   #9
LADY_SAUBER
ENTHUSIAST IN TRAINING :)
 
LADY_SAUBER's Avatar
 
Join Date: Aug 2007
Location: JANE+FINCH
Posts: 9
Quote:
Originally Posted by T.Dot_E30
It gets it from the ECU, it could be either a broken wire somewhere causing a faulty connection which would be a bitch to find, or if your lucky, its the ECU. Do you have a spare you can try swapping?
^agreed

it's kinda difficult to diagnose intermittant situations... but maybe u can start by confirming the injector's electrical integrity. perhaps test the resistance of each injector with a noid light? This will prove it's communication with the ECU is in effect. Because remember, resistance will change according to the injector's temperature a.k.a bad ground a.k.a low injector pulse width
LADY_SAUBER is offline   Reply With Quote
Old 08-26-2007, 11:32 PM   #10
Bandi
der mechanik
 
Bandi's Avatar
 
Join Date: Mar 2005
Location: Campbellford, Ontario
Posts: 116
Send a message via MSN to Bandi
Yup, I've checked injector resistance, pulse with a noid light (that's how I determined the injector pulse goes away when the car hits 1500 rpm)

As for broken wire, I've tested the ENTIRE efi harness for continuity/voltage drops/etc... as well as RPM signal everwhere it should be.

The problem usually starts when the car hits a fairly noticeable bump (ie, train tracks)... but I have gone through the entire harness, wiggled it around, bashed every component around with a screwdriver handle/etc (to simulate the shock), and can't get it to act up. (Or, if the car is acting up, I can't get it to correct itself)

Anyhow, I have this M20 sitting here collection dust... so I think that's the answer to my problem at this point... I'm kinda partial to the 6 cyl. E30s anyhow (I sold my 325is this past spring, and have missed it every day since)
__________________
-'72 2002
-'72 Super Beetle
-'72 Baja Champion SE Beetle
-'66 Beetle
-'74 Sun Bug
-'75 La Grande Bug
-'65 Fiat 1500 Cabriolet
-'99 New Beetle TDi
-'84 Rabbit Cabriolet SportLine
-'91 Tercel GT-S Twin Cam
Bandi is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:15 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.