Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-25-2007, 02:59 PM   #1
phildc
2nd Gear Member
 
Join Date: Apr 2006
Location: Markham
Posts: 68
E36 rear defroster not working...HELP !!!

My rear window defroster stopped working, when the button is pressed, the light comes on but doesn't de-frost the rear window. I have a 4 dr E36.

Any ideas how to troubleshoot or fix this ??
phildc is offline   Reply With Quote
Old 06-25-2007, 04:52 PM   #2
Karim@Corner73
5th Gear Member
 
Karim@Corner73's Avatar
 
Join Date: Feb 2005
Location: Montreal
Posts: 913
Happened to me last winter.

Check the fuse.
Karim@Corner73 is offline   Reply With Quote
Old 06-25-2007, 06:14 PM   #3
mirek
6th Gear Member
 
mirek's Avatar
 
Join Date: Nov 2003
Location: Canada
Posts: 5,454
Check the fuse, and if it's fine, use a multimeter and check to see if you're getting any voltage to the windows. You could have a break in connection somewhere on the window. You can fix this with a copper pen.
mirek is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:33 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.