Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-20-2007, 03:28 AM   #1
Luke318is
BMW Fanatic
 
Luke318is's Avatar
 
Join Date: Jan 2004
Location: Victoria
Posts: 683
What can cause an odometer to fail?



I have a feeling the cluster is fine, pardon my ignorance, but other than the cluster, what can cause an odometer to stop?
__________________
1982 528e -Sold.
1991 318is -Written off, parting out currently.
1984 318i -Beater while car shopping.
1990 ///325i -Imported Mtech2 model, purchased May 28
Luke318is is offline   Reply With Quote
Old 06-20-2007, 04:07 AM   #2
Bimmer Heaven
MaXsponsor
 
Bimmer Heaven's Avatar
 
Join Date: Feb 2002
Location: Ontario
Posts: 15,645
In the 10+ years of working on E30's, i only had one case where the odometer was not working (speedo was fine)...If was caused by a broken gear on the odometer.
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E28 E34 E39 E60 E61 E32 E38 E65 E66 X3 X5 M3 M5 Z4 F30 F32


Call 11-8PM 416 821-2578
New inventory daily. 100+ cars now in stock!
Bimmer Heaven is online now   Reply With Quote
Old 06-20-2007, 04:30 AM   #3
Luke318is
BMW Fanatic
 
Luke318is's Avatar
 
Join Date: Jan 2004
Location: Victoria
Posts: 683
I have a feeling it was disabled, for japanese emmision laws possibly, the rest of the car is mint...
__________________
1982 528e -Sold.
1991 318is -Written off, parting out currently.
1984 318i -Beater while car shopping.
1990 ///325i -Imported Mtech2 model, purchased May 28
Luke318is is offline   Reply With Quote
Old 06-20-2007, 08:30 AM   #4
dgmorr
4th Gear Member
 
Join Date: May 2006
Location: Mississauga
Posts: 842
Or for exploi...I mean exportation
dgmorr is offline   Reply With Quote
Old 06-24-2007, 04:24 PM   #5
Luke318is
BMW Fanatic
 
Luke318is's Avatar
 
Join Date: Jan 2004
Location: Victoria
Posts: 683
Well theres nothing wrong with the car, if thats what your getting at.

Regardless, any ideas on how to fix it?
__________________
1982 528e -Sold.
1991 318is -Written off, parting out currently.
1984 318i -Beater while car shopping.
1990 ///325i -Imported Mtech2 model, purchased May 28
Luke318is is offline   Reply With Quote
Old 06-25-2007, 08:17 AM   #6
alex a
2nd generation///
 
Join Date: Jan 2007
Location: toronto
Posts: 99
your si board is dead batterys are gone or speed sensor in the diff needs replacing
alex a is offline   Reply With Quote
Old 06-25-2007, 08:19 AM   #7
alex a
2nd generation///
 
Join Date: Jan 2007
Location: toronto
Posts: 99
i have a used cluster i can sell you it works battery are new i have 2 of them with rebuilt boards from bmw bring the car to my shop i will fix it for you call me alex 647 201 8862
alex a is offline   Reply With Quote
Old 06-25-2007, 02:31 PM   #8
Luke318is
BMW Fanatic
 
Luke318is's Avatar
 
Join Date: Jan 2004
Location: Victoria
Posts: 683
Quote:
Originally Posted by alex a
i have a used cluster i can sell you it works battery are new i have 2 of them with rebuilt boards from bmw bring the car to my shop i will fix it for you call me alex 647 201 8862
Now your makin me jealous, i dont live in toronto, im in BC


If the battery was gone, wouldent everything else stop working as well? the speedo works fine, so could it still be the speed sensor in the diff?
__________________
1982 528e -Sold.
1991 318is -Written off, parting out currently.
1984 318i -Beater while car shopping.
1990 ///325i -Imported Mtech2 model, purchased May 28
Luke318is is offline   Reply With Quote
Old 06-25-2007, 04:19 PM   #9
NickP
Moderator
 
NickP's Avatar
 
Join Date: Jan 2002
Location: Toronto
Posts: 2,132
Quote:
Originally Posted by alex a
your si board is dead batterys are gone or speed sensor in the diff needs replacing
Are you sure about that? The SI board affects temp / gas / rpms etc but I'm pretty sure that it doesn't affect the speedo.
NickP is offline   Reply With Quote
Old 06-25-2007, 04:55 PM   #10
Luke318is
BMW Fanatic
 
Luke318is's Avatar
 
Join Date: Jan 2004
Location: Victoria
Posts: 683
everything works but the odometer and the trip meter.
__________________
1982 528e -Sold.
1991 318is -Written off, parting out currently.
1984 318i -Beater while car shopping.
1990 ///325i -Imported Mtech2 model, purchased May 28
Luke318is is offline   Reply With Quote
Old 06-25-2007, 06:13 PM   #11
mirek
6th Gear Member
 
mirek's Avatar
 
Join Date: Nov 2003
Location: Canada
Posts: 5,422
It's because your rims are not compatible with the odometer. Replace them with something euro.
mirek is offline   Reply With Quote
Old 06-26-2007, 09:29 AM   #12
alex a
2nd generation///
 
Join Date: Jan 2007
Location: toronto
Posts: 99
when the batterys are dying different function stop working like on my car the tach temp and gas gauge stopped then would come on intermitantly.
alex a is offline   Reply With Quote
Old 06-27-2007, 04:11 AM   #13
Luke318is
BMW Fanatic
 
Luke318is's Avatar
 
Join Date: Jan 2004
Location: Victoria
Posts: 683
Quote:
Originally Posted by mirek
It's because your rims are not compatible with the odometer. Replace them with something euro.
Very funny. Like i said, i may plan on changing rims after 5 speed swap. but for now they are fine.
__________________
1982 528e -Sold.
1991 318is -Written off, parting out currently.
1984 318i -Beater while car shopping.
1990 ///325i -Imported Mtech2 model, purchased May 28
Luke318is is offline   Reply With Quote
Old 06-27-2007, 09:13 AM   #14
rgunner61
1st Gear Newbie
 
Join Date: Jun 2007
Location: Bethany Beach DEs
Posts: 4
almost always, odo problems are from broken gears in speedometer.
it is a common fault and replacement gears are available. try a search
if you want to repair it yourself. speedo works so speed sensor is working.
you could also buy a used one of ebay
good luch
Ron
rgunner61 is offline   Reply With Quote
Old 06-27-2007, 04:21 PM   #15
Luke318is
BMW Fanatic
 
Luke318is's Avatar
 
Join Date: Jan 2004
Location: Victoria
Posts: 683
Thanks.

I have a spare cluster with white backgrounds that im swapping in....just need to run back the odometer by about 275k
__________________
1982 528e -Sold.
1991 318is -Written off, parting out currently.
1984 318i -Beater while car shopping.
1990 ///325i -Imported Mtech2 model, purchased May 28
Luke318is is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:24 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018