Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-04-2007, 04:56 PM   #1
markw
.
 
markw's Avatar
 
Join Date: Jan 2006
Location: GTA
Posts: 471
Yet another problem....

I thought it may have been a fuse, but nope.... when I signal, the thing goes like mad! really fast blinking...

Any ideas?
markw is offline   Reply With Quote
Old 05-04-2007, 06:04 PM   #2
FuryriderX
cra.iX.y
 
FuryriderX's Avatar
 
Join Date: Nov 2006
Location: Stoney Creek
Posts: 1,259
youve checked the turn signal bulbs, right? if one of them goes, itll blink fast. otherwise, the flasher relay? i think its on the steering column.
__________________
FuryriderX is offline   Reply With Quote
Old 05-04-2007, 08:11 PM   #3
BmW1819
6th Gear Member
 
Join Date: Feb 2007
Location: Pickering
Posts: 2,767
sent ya a pm
BmW1819 is offline   Reply With Quote
Old 05-05-2007, 10:49 AM   #4
86coupe30
1990 325is
 
86coupe30's Avatar
 
Join Date: Mar 2007
Location: kitchener
Posts: 573
Send a message via MSN to 86coupe30
yea probably a bulb out if its just tickin fast.
86coupe30 is offline   Reply With Quote
Old 05-05-2007, 11:17 AM   #5
Wannabe
Northwood.
 
Wannabe's Avatar
 
Join Date: Apr 2004
Location: Oakville
Posts: 1,969
hey man.. i have this problem... check the connection between the wires and the actual bulb socket thingy..
I had to rewire mine since it was all corroded..
__________________
Current - 2011 Jeep Grand Cherokee Laredo
2010 Jeep Patriot North All-season
2009 Jeep Wrangler Unlimited Sahara
2002 Dodge Durango SXT
1985 BMW 325e
1998 Pontiac Grand Prix GTP
1995 Nissan Altima SE
1994 Mazda MX-6 RS
1984 Buick Riviera
Wannabe is offline   Reply With Quote
Old 05-05-2007, 12:44 PM   #6
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,148
Quote:
Originally Posted by 86coupe30
yea probably a bulb out if its just tickin fast.
Yup. And it's not necessary for the bulb to be out completely. It could be on its way out but it's almost dead and the resistance is high enough to make the system feel a burn out. It's possible that you have a cold solder or a broken wire but that's only typical on very old cars. If you change the bulb and it still doesn't blink (or you've changed both bulbs and it still blinks fast), then it's the circuit somewhere. Get out your tester and tell everyone to leave you alone for a day.

Last edited by BigD; 05-05-2007 at 12:46 PM.
BigD is online now   Reply With Quote
Old 05-05-2007, 04:31 PM   #7
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,247
also happens when you use cheap wrong wattage bulbs.
__________________
T.Dot_E30 is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.