Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-02-2007, 03:56 PM   #1
Manimillion
Photographer
 
Join Date: Apr 2002
Location: Ottawa
Posts: 3,285
E39 M5 Navigation Screen busted?

I turn the car on, Navigation Screen just blinks as in its getting electricty but never shows any image on it...

Is this a common problem?

Is there a way to fix this without changing the screen?


Thanks!
__________________
Manimillion is offline   Reply With Quote
Old 05-02-2007, 04:10 PM   #2
qimis
Mr. Euro E30
 
qimis's Avatar
 
Join Date: Feb 2003
Location: The Bond Facility
Posts: 4,358
Is that the other way of saying that you've bought E39 M5?
__________________
qimis is offline   Reply With Quote
Old 05-02-2007, 04:11 PM   #3
Boots R
Boots, not boost
 
Boots R's Avatar
 
Join Date: Jun 2006
Location: Brampton
Posts: 11,032
Quote:
Originally Posted by qimis
Is that the other way of saying that you've bought E39 M5?
I was just about to say the same thing.
Boots R is offline   Reply With Quote
Old 05-02-2007, 04:20 PM   #4
Manimillion
Photographer
 
Join Date: Apr 2002
Location: Ottawa
Posts: 3,285
Quote:
Originally Posted by qimis
Is that the other way of saying that you've bought E39 M5?
Unfortunately no I have not. It is for a friends car, and the Navi screen just crapped out.
__________________
Manimillion is offline   Reply With Quote
Old 05-02-2007, 09:39 PM   #5
BMW03
2nd Gear Member
 
Join Date: Oct 2006
Location: Kalamazoo
Posts: 286
My friends Lexus did that and he had to take it in, and they charged him a couple hundred to fix it. So hope it isn't something like that.
__________________
BMW03 is offline   Reply With Quote
Old 05-03-2007, 12:14 AM   #6
TheMadChigga
Taiwan Panda Racing Unit.
 
TheMadChigga's Avatar
 
Join Date: Aug 2002
Location: Durty Shwa
Posts: 3,099
Send a message via ICQ to TheMadChigga Send a message via AIM to TheMadChigga Send a message via MSN to TheMadChigga
try to reboot the car, simply unplug battery and see if it does anything, sometimes E39's display would "freeze", I had my cluster/HVCA froze once, and E39s do that every now and then.
__________________
TheMadChigga is offline   Reply With Quote
Old 05-05-2007, 11:29 AM   #7
Manimillion
Photographer
 
Join Date: Apr 2002
Location: Ottawa
Posts: 3,285
I'll try to do that chigga, thanks for the tip, i'll do a follow up on here to future referrence as well.
__________________
Manimillion is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:58 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.