Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-08-2007, 08:18 PM   #1
BritneyBMW
2nd Gear Member
 
BritneyBMW's Avatar
 
Join Date: Feb 2007
Location: Toronto
Posts: 51
Problems with heater

Hey everyone!

I have a 2003 330, my heat doesn't blow hot! Does anyone know what is wrong with it?
BritneyBMW is offline   Reply With Quote
Old 02-08-2007, 11:06 PM   #2
BmW1718
5th Gear Member
 
Join Date: Apr 2005
Location: Toronto . ontario
Posts: 960
Send a message via MSN to BmW1718
check your coolant level do you have your switch to red lol lots of people don't put it to red . and check you coolant level . prob will fix your problem if not give me a pm
__________________
1987 325is Red Summer Car
1992 325I 4 door Winter beater )
BmW1718 is offline   Reply With Quote
Old 02-09-2007, 08:35 AM   #3
StikiGreenZ
6th Gear Member
 
StikiGreenZ's Avatar
 
Join Date: Dec 2002
Location: Milton, ON
Posts: 1,601
Send a message via MSN to StikiGreenZ
Yeah there are two places to look at your heat settings, the digital one that controls ambient cockpit temperature and the analog dial in the center vent that controls the 4 vents near face level. I've always found it a bit tricky getting the car at a comfortable temperature, always a bit too warm or too cold!
__________________
-

BMW 645i - Black on Red
Range Rover Sport - Black on Black
StikiGreenZ is offline   Reply With Quote
Old 02-09-2007, 12:54 PM   #4
BritneyBMW
2nd Gear Member
 
BritneyBMW's Avatar
 
Join Date: Feb 2007
Location: Toronto
Posts: 51
thanxx!
BritneyBMW is offline   Reply With Quote
Old 02-09-2007, 05:08 PM   #5
BmW1718
5th Gear Member
 
Join Date: Apr 2005
Location: Toronto . ontario
Posts: 960
Send a message via MSN to BmW1718
is it fixed???? what did u do ?? switch ??
__________________
1987 325is Red Summer Car
1992 325I 4 door Winter beater )
BmW1718 is offline   Reply With Quote
Old 02-09-2007, 07:57 PM   #6
windsorbmw
Pedal to the metal!
 
windsorbmw's Avatar
 
Join Date: Jan 2005
Location: Somewhere in ONTARIO!
Posts: 608
Mine was like that earlier, check your temp guage, if it is stuck or barely moves then 100% it is your thermostat that needs changing. I took mine to the stealer and got a decent price for the repair. the thermostat came as a whole piece witht he housing and everything installed/coolant top up came to 300 bucks.....now I am nice and warm in the car
windsorbmw is offline   Reply With Quote
Old 02-09-2007, 09:53 PM   #7
windsorbmw
Pedal to the metal!
 
windsorbmw's Avatar
 
Join Date: Jan 2005
Location: Somewhere in ONTARIO!
Posts: 608
so did u check?
windsorbmw is offline   Reply With Quote
Old 02-09-2007, 11:50 PM   #8
BmW1718
5th Gear Member
 
Join Date: Apr 2005
Location: Toronto . ontario
Posts: 960
Send a message via MSN to BmW1718
lol u have to change the housing with those thermostat there a one peice lol it just sounds good it comes with housing lol if you temp gauge stays a 1/4 it's your thermostat by the sounds of it the problem is fixed
__________________
1987 325is Red Summer Car
1992 325I 4 door Winter beater )
BmW1718 is offline   Reply With Quote
Old 02-10-2007, 12:19 PM   #9
windsorbmw
Pedal to the metal!
 
windsorbmw's Avatar
 
Join Date: Jan 2005
Location: Somewhere in ONTARIO!
Posts: 608
Quote:
Originally Posted by BmW1718
lol u have to change the housing with those thermostat there a one peice lol it just sounds good it comes with housing lol if you temp gauge stays a 1/4 it's your thermostat by the sounds of it the problem is fixed

Basically what I stated.....read
windsorbmw is offline   Reply With Quote
Old 02-11-2007, 05:58 PM   #10
BritneyBMW
2nd Gear Member
 
BritneyBMW's Avatar
 
Join Date: Feb 2007
Location: Toronto
Posts: 51
I took it to a mechanic and topped up the coolant and it was fixed. He said something was loose in the engine and it leaked out some coolant.
BritneyBMW is offline   Reply With Quote
Old 02-11-2007, 07:04 PM   #11
windsorbmw
Pedal to the metal!
 
windsorbmw's Avatar
 
Join Date: Jan 2005
Location: Somewhere in ONTARIO!
Posts: 608
gr8....stay warm
windsorbmw is offline   Reply With Quote
Old 02-15-2007, 05:15 AM   #12
Daddy
3rd Gear Member
 
Join Date: Sep 2004
Location: Markham
Posts: 433
Or you could be a dork like me and not know about the dial in the middle vents. They were on the "blue dots" and I was complaining about lack of heat... turned it to the "red dots" and voila heat!

The Dork.
Daddy is offline   Reply With Quote
Old 02-15-2007, 02:50 PM   #13
diezel06turk
4th Gear Member
 
diezel06turk's Avatar
 
Join Date: Oct 2006
Location: sauga
Posts: 689
i just had to replace me t start over the weekend.. costs 120 at da dealer...they charge too much for installation so i just changed it myself...
diezel06turk is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:23 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.