Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-28-2007, 09:17 PM   #1
v_bimmer
Jailbait FTW
 
v_bimmer's Avatar
 
Join Date: Aug 2006
Location: Hong Kong
Posts: 2,065
Is it my battery or alternator??

so ive been driving my car for the past 2 days and noticed my battery light coming on, but i thought it was just my battery going to die, so today ive noticed that my wipers and windows were working really slow, then i parked with my car being on and saw my ABS light comming on, so i revved it and it just stayed on!!

I started to dirve and then stopped at a light and my car just died, and would nto start!! then i boosted my car and started to drive but at low reavs it wanted to die and my idles were jumping all over like crazy!!

so what could it be?? and why did my abs light come on??
__________________
v_bimmer is offline   Reply With Quote
Old 01-28-2007, 09:25 PM   #2
vadim321go
6th Gear Member
 
vadim321go's Avatar
 
Join Date: Jan 2006
Location: Richmond Hill
Posts: 1,581
we have a battery light? i just replaced my battery yesterday, now it doesnt struggle as much when its really cold outside
__________________
Proud owner of a 95 325i
vadim321go is offline   Reply With Quote
Old 01-28-2007, 09:29 PM   #3
v_bimmer
Jailbait FTW
 
v_bimmer's Avatar
 
Join Date: Aug 2006
Location: Hong Kong
Posts: 2,065
yeah its on the left of Oil light!
__________________
v_bimmer is offline   Reply With Quote
Old 01-28-2007, 09:33 PM   #4
mellobudd
jumblebee
 
mellobudd's Avatar
 
Join Date: Aug 2006
Location: Toronto
Posts: 934
Send a message via MSN to mellobudd Send a message via Yahoo to mellobudd
hmm, how long u had ur battery? i assume your interior lights flicker too..
i should say its the alternator..time to go to a shop!
mellobudd is offline   Reply With Quote
Old 01-28-2007, 09:37 PM   #5
NickP
Moderator
 
NickP's Avatar
 
Join Date: Jan 2002
Location: Toronto
Posts: 2,135
Sounds like your alternator. If you're lucky it could just be the brushes on your voltage regulator. Once you remove the cooling fin it should be the white plastic thing held on by 2 phillips screws.
NickP is offline   Reply With Quote
Old 01-28-2007, 10:36 PM   #6
v_bimmer
Jailbait FTW
 
v_bimmer's Avatar
 
Join Date: Aug 2006
Location: Hong Kong
Posts: 2,065
Quote:
Originally Posted by mellobudd
hmm, how long u had ur battery? i assume your interior lights flicker too..
i should say its the alternator..time to go to a shop!
lol, ive got my car back from bimmersport on thursday, i got my clutch done, and flywheel!! now this??? lol, i dont know this give me a thought of selling my car!!!
__________________
v_bimmer is offline   Reply With Quote
Old 01-28-2007, 10:38 PM   #7
v_bimmer
Jailbait FTW
 
v_bimmer's Avatar
 
Join Date: Aug 2006
Location: Hong Kong
Posts: 2,065
Quote:
Originally Posted by NickP
Sounds like your alternator. If you're lucky it could just be the brushes on your voltage regulator. Once you remove the cooling fin it should be the white plastic thing held on by 2 phillips screws.
so you are saying if its my brushes then i can just get that replaced??? how much would an alternator run me?? i would probably get it from luxtek if ill need another one!! but the brushed can be replaced???
__________________
v_bimmer is offline   Reply With Quote
Old 01-29-2007, 12:39 AM   #8
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,434
more than likely its your alt.

You can buy use, but a rebuilt one should be less than $200 for sure.
__________________
T.Dot_E30 is online now   Reply With Quote
Old 01-29-2007, 12:46 AM   #9
harris
Bring My Whimp.....
 
harris's Avatar
 
Join Date: Oct 2006
Location: Mississauga, ON, Canada
Posts: 280
go to the shop get an alternator test done, it will tel you if the alternator is bad or not.... if not the obviously time to buy a new battery..... i had to get my battery changed,,, car didnt start without boosting it... when i used to turn it off the battery just used to die... get the test done youll know specifically if the alternator is bad or not...
harris is offline   Reply With Quote
Old 01-29-2007, 02:07 AM   #10
v_bimmer
Jailbait FTW
 
v_bimmer's Avatar
 
Join Date: Aug 2006
Location: Hong Kong
Posts: 2,065
guys but i dont understand why my abs light and my airbad light came on!!! btw i went outside right now, and the car started and worked fine and the abs light were not on anymore!! is that the sign for my alternator??? or what is it???
__________________
v_bimmer is offline   Reply With Quote
Old 01-29-2007, 04:12 AM   #11
soon2b-e
2nd Gear Member
 
Join Date: Mar 2006
Location: london
Posts: 192
Quote:
Originally Posted by v_bimmer
guys but i dont understand why my abs light and my airbad light came on!!! btw i went outside right now, and the car started and worked fine and the abs light were not on anymore!! is that the sign for my alternator??? or what is it???

dude, do what people are saying, bring it in, get them to check out your charging system, do that before you assume anything else,
so your main concern should be to get your charging system checked out
your next concerns,
ABS- if the ABS system is not getting enough voltage to the computer, the ABS computer will not function properly
Air bag light- same ordeal, all compute related stuff not getting enough power, i would even go as far as saying both your alt. and battery are dieing/dead
btw, a rebuilt alt is around 300 + core
havent checked out what it will cost to get one sent in and rebuilt, but i have a spare one, and i might find out soon..........
soon2b-e is offline   Reply With Quote
Old 01-29-2007, 02:56 PM   #12
superman123
slushbox champion
 
Join Date: Apr 2005
Location: london
Posts: 500
IT needs to be tested!!!!...if u have a multi meter u can do it yourself if not ask someone to test it ...by the looks of things its your alternator...here in london u can get it rebuilt for about 120-150
superman123 is offline   Reply With Quote
Old 01-29-2007, 03:05 PM   #13
INFAMOU$
Automotive Puppeteer
 
INFAMOU$'s Avatar
 
Join Date: Jun 2006
Location: Dubai, UAE
Posts: 1,733
Send a message via MSN to INFAMOU$
simple.. disconnect the negative terminal of the battery when the car is running.. if your alternator is good then your car should keep running just fine.. if it stalls and dies then your battery is f*cked.. sometimes your alternator will still charge just not at 14.4 volts or so.. test it.. or take it in.. canadian tire will even test it out for free..
INFAMOU$ is offline   Reply With Quote
Old 01-29-2007, 05:43 PM   #14
v_bimmer
Jailbait FTW
 
v_bimmer's Avatar
 
Join Date: Aug 2006
Location: Hong Kong
Posts: 2,065
yeah i tested my alternator, and it read 9 volts when the car is running!!! so i think it is my alternator!!! souds like my brushes are gone!!
__________________
v_bimmer is offline   Reply With Quote
Old 01-30-2007, 09:31 AM   #15
mellobudd
jumblebee
 
mellobudd's Avatar
 
Join Date: Aug 2006
Location: Toronto
Posts: 934
Send a message via MSN to mellobudd Send a message via Yahoo to mellobudd
what are you waiting for??? just do it!!!!
mellobudd is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014