Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Classifieds > Private Classifieds Feedback
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-12-2006, 02:07 PM   #1
qimis
Mr. Euro E30
 
qimis's Avatar
 
Join Date: Feb 2003
Location: The Bond Facility
Posts: 4,357
propr'one - HID Kits (Neutral Feedback)

- August 25, 2006: I bought 4 HID kits plus 1 set of D2S bulbs 2 weeks ago.

- August 30, 2006: Among all the 4 kits that arrived, every kit had 1 bad ballast. We ended up putting 2 complete working kits together and still ended up with one of the bulb of each working kits died the next day. The D2S bulbs working fine. Called up Ivan about the situation, new kit was shipped the same night.

- September 5, 2006: 4 new working ballast arrived, tested and works perfectly fine.

pros: super fast shipping, great service, communication, price from Ivan.
cons: out of 4 kits, only 2 worked.
conclusion: make sure they DOUBLE CHECK the kit before it gets shipped out to customers.
feedback: neutral.
__________________
qimis is offline   Reply With Quote
Old 09-12-2006, 03:37 PM   #2
Soldo
6th Gear Member
 
Soldo's Avatar
 
Join Date: Oct 2002
Location: Toronto
Posts: 12,485
I also purchased a kit from Ivan, and i had fast speedy service, and i've been trouble free with my HID kit since i bought them (a few months now!)
__________________
Keven Soldo
Soldo is offline   Reply With Quote
Old 09-12-2006, 04:10 PM   #3
Justin e36
---
 
Justin e36's Avatar
 
Join Date: May 2003
Location: etobicoke
Posts: 12,331
Send a message via ICQ to Justin e36 Send a message via AIM to Justin e36 Send a message via Yahoo to Justin e36
picked up three kits from Ivan last week. Two for a Jetta (8000k), one for my e36 (6000k).

All kits were DHL express shipped. They were opened at customs, but I was not charged any import duties. All kits were complete, and installed without any problems at all.

VERY happy with the service & kits. So much so I'll be purchasing another 5+ kits for my fogs, the e39, motorcycle, and for friends. Price can not be beat.

The parts are bastardized from different vendors. Qimis, who installed these kits? 4 bad ballasts from different kits, and bulbs that died the next day? That really sounds more like a wiring problem than anything else. (since it comes from different vendors) I know on my ballasts for the Jetta the connector (red/black) could go on backwards so the red was negative, and black positive... perhaps something along those lines happened?
Justin e36 is offline   Reply With Quote
Old 09-12-2006, 11:47 PM   #4
morpheus
2nd Gear Member
 
Join Date: Aug 2006
Location: Montreal, Qc
Posts: 95
Hey Justin,

The day we received the kits we decided to install them on all our cars at the same time. I installed my left side bulb+ballast and it worked ok. Installed the right one and it would not work. I then swapped the ballast only from the left side to the right and the right side was now working. Installed the inop ballast on the left just to double check and it would still not turn on. Al tried to install his kit with the same results, one working and the other inop. I took one of the ballasts from Adriano's kit to complete mine and Al tried to take the other from Adrianos kit and it still would not work. He had to take one of the ballasts out of Leonards kit for it to work. So with 4 kits we only had 4 working ballasts. The next day as i was driving, my right side headlight turned off. I only disconnected and reconnected the feed to the ballast and since then i have not experienced any other issues. The lamp turning off the next day was definately a connection issue, as for the 4 ballasts, they were not working from the start.For the connectors going on backwards, it is not possible due to the lock tab, connector only goes in 1 way. I guess we were just unlucky

Last edited by morpheus; 09-12-2006 at 11:53 PM.
morpheus is offline   Reply With Quote
Old 09-13-2006, 06:06 AM   #5
SpoolinS6
6th Gear Member
 
SpoolinS6's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 6,539
hey man its not about luck electrical shit **** up what can you do man right? ivan is a good guy dont get me wrong im ganna get a kit off him soon just waitiing on some stuff for the car to be 100% again ...
__________________
1995 Audi S6
HI BOOST
SpoolinS6 is offline   Reply With Quote
Old 09-13-2006, 09:27 AM   #6
Proliphic
Trying to stay on 4wheels
 
Proliphic's Avatar
 
Join Date: Nov 2005
Location: Bolton
Posts: 995
Send a message via MSN to Proliphic
lol dude u cant give someone neutral/bad feedback for some "moody" electricals.. he didnt make the stuff he just had it shipped..
__________________
1.
Granite Silver '92 325i
Mark D (93) Chip
Motronix CAI
(Magic Fairy Dust )
Strut Brace
APEX Sport Springs
18" M3 CSL look-a-like's
Clear Corners All Around
6000K HID's
Thinline Angel Eyes

2.
Black/Silver 2000 Suzuki Hayabusa GSX1300R
8000K HID's
Clear Signals
(More to come)
Proliphic is offline   Reply With Quote
Old 09-13-2006, 11:04 AM   #7
qimis
Mr. Euro E30
 
qimis's Avatar
 
Join Date: Feb 2003
Location: The Bond Facility
Posts: 4,357
Quote:
Originally Posted by Proliphic
lol dude u cant give someone neutral/bad feedback for some "moody" electricals.. he didnt make the stuff he just had it shipped..
Yup, that's why I gave a clear point that his price, service, communication, shipping is great. It's just a suggestion to his supplier to double check or at least check the kit is working properly before shipping it to customers.
__________________
qimis is offline   Reply With Quote
Old 09-13-2006, 12:40 PM   #8
kurupt_k
www.gotHID.ca
 
kurupt_k's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 311
the ballasts are tricky i think the main point is that he stood by the product and that is all that really matters
kurupt_k is offline   Reply With Quote
Old 09-13-2006, 04:34 PM   #9
qimis
Mr. Euro E30
 
qimis's Avatar
 
Join Date: Feb 2003
Location: The Bond Facility
Posts: 4,357
Quote:
Originally Posted by kurupt_k
the ballasts are tricky i think the main point is that he stood by the product and that is all that really matters
Yup.
__________________
qimis is offline   Reply With Quote
Old 09-13-2006, 09:27 PM   #10
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,596
Send a message via MSN to propr'one
Before a friend of mine puts his reputation on the line by posting this information I will.

The events that Leonard posted are accurate. I'll point out that i sell these kits to you guys at almost my cost, make very little money on them. I also paid to have the 4 kits shipped DHL express, from hong kong, free of charge for leonard and his friends, as i knew they needed them for bimmercruise. (congratulations guys).

However, since i got the "defective kits" back, i decided to test them. So far i've tested 3. All three of them work, two are in a car right now. The connectors do go both ways, and when plugged in the other way, they work just fine. I tried to make this clear to Leonard and Adriano (long distance, on vacation in New Jersey), however, it seems that there was some miscommunication.

This just proves that you really do have to check everything a few times. Its not a huge deal, i'm out a few bucks, but i'll live, and i'm glad everyone now has working HID's.

On another note: HID kits are sometimes defective. In my honest opinion, the Klight brand kits i sell are not more likely to be defective than any other kit i've come across. I encourage people to explore other options with HID's. Kurupt_K sells Ollo brand products, another reputable choice in HID conversion kits. He posted above, and i believe he does take orders over PM's. There are also other kits, made by mcullugh, xtec, and other manufacturers. www.xenonfactory.com sells many of these kits.

Leonard, I thank you for not flaming me for receiving, what i'm sure you honestly believed to be, defective products. I'm sorry for the inconvienence you went through, as i know how it feels to recieve a product that is defective. Its probably my fault that I was not clear enough with the instructions, i'll try to make them more clear to any future customers.


Thanks for the support guys, and if any of you still decide that you do wish to purchase the kits I sell, feel free to PM me. If you decide to go another route, no hard feelings. Like I said, I pretty much sell these kits at my cost, so as long as you're happy, I'm happy.
__________________

Hot: 2001 Estoril M RoadsterZCP 19's, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's supersports, ZHP knob, UUC short shift GROM, OEM 18's w310's,
http://absolutehid.ca hid kit
propr'one is offline   Reply With Quote
Old 09-13-2006, 09:40 PM   #11
e30_kid89
The Afro-stig
 
e30_kid89's Avatar
 
Join Date: Nov 2005
Location: TDot West End
Posts: 4,585
Send a message via MSN to e30_kid89
^^^now thats the good, honest person first, seller second guy i like dealing with. ivan i still want a kit or 2 soon.
__________________
e30_kid89 is offline   Reply With Quote
Old 09-13-2006, 09:51 PM   #12
Justin e36
---
 
Justin e36's Avatar
 
Join Date: May 2003
Location: etobicoke
Posts: 12,331
Send a message via ICQ to Justin e36 Send a message via AIM to Justin e36 Send a message via Yahoo to Justin e36
First I would like everyone to know in advance that we don't have any official actual HID kit sponsor on maxbimmer. So any business you do with these individuals is not endorsed by maxbimmer, and is strictly a one-on-one transaction with the individual OFF the forum.

Quote:
Originally Posted by morpheus
Hey Justin,

The day we received the kits we decided to install them on all our cars at the same time. I installed my left side bulb+ballast and it worked ok. Installed the right one and it would not work. I then swapped the ballast only from the left side to the right and the right side was now working. Installed the inop ballast on the left just to double check and it would still not turn on. Al tried to install his kit with the same results, one working and the other inop. I took one of the ballasts from Adriano's kit to complete mine and Al tried to take the other from Adrianos kit and it still would not work. He had to take one of the ballasts out of Leonards kit for it to work. So with 4 kits we only had 4 working ballasts. The next day as i was driving, my right side headlight turned off. I only disconnected and reconnected the feed to the ballast and since then i have not experienced any other issues. The lamp turning off the next day was definately a connection issue, as for the 4 ballasts, they were not working from the start.For the connectors going on backwards, it is not possible due to the lock tab, connector only goes in 1 way. I guess we were just unlucky
Thanks for clarifying. The connector on the ballast itself CAN actually plug in upside down, there's a small raised + and - on it as to where the red/black wired connector should go. The other plugs for the bulb itself, as you mentioned, can only clip one way---it's not possible to put them in backwards.

The reason I suspected a mistake in the wiring (the plug going in upside down/backwards) is only because I just finished installing the kit in my car last week, and would have faced the same problem if I didn't notice those small raised markings on the plastic.

As for the broken ballasts, as Ivan mentioned.. a few of them so far have tested out perfectly ok---which is why I have them in a car right now.

Now to see if I can score another one of those returned ballasts from him for the motorcycle now.

Quote:
Originally Posted by propr'one
So far i've tested 3. All three of them work, two are in a car right now.
Thanks for that. I'd like to possibly purchase those other returned ballasts from you as well. Let me know via PM on a price for just the bulb + connectors if you can order those separate, or just the bulb (make my own connectors).

Quote:
Originally Posted by kurupt_k
the ballasts are tricky i think the main point is that he stood by the product and that is all that really matters
Just want to mention to everyone that I've met Kurupt the other day as well, and have seen the kits he provides. He had 8000k lows/fogs on his e39 and they look incredible. Although I didn't purchase my HID kit from him, he does seem like a very straight forward and honest guy. Seems very much like the type of person I would do business with.

Justin
Justin e36 is offline   Reply With Quote
Old 09-13-2006, 10:47 PM   #13
kurupt_k
www.gotHID.ca
 
kurupt_k's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 311
i do sell kits aswell and each car is different and somethings work on different cars and one of the main problems i have from customers is the wiring being backwards and the easiest way to correct switching the wires around, the long and short of it is that you purchase from someone who is going to back their product up such as propr'one and myself do.

oh and thanks alot justin for the compliment
kurupt_k is offline   Reply With Quote
Old 09-14-2006, 02:30 AM   #14
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,596
Send a message via MSN to propr'one
just checked, they do all work. Pm me if you need a ballast
__________________

Hot: 2001 Estoril M RoadsterZCP 19's, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's supersports, ZHP knob, UUC short shift GROM, OEM 18's w310's,
http://absolutehid.ca hid kit
propr'one is offline   Reply With Quote
Old 09-14-2006, 09:11 AM   #15
Adriano
Who's your daddy now?
 
Adriano's Avatar
 
Join Date: Apr 2002
Location: The Bond Facility
Posts: 1,087
Send a message via MSN to Adriano
Mr. Proprone

Please do not take any of the below to offence as I found your service to be the best I have dealt with thus far. I am more then grateful that you went out of your way to get us the kits and the replacements before Bimmercruise would definitely purchase future items from you. Again I cannot stress the fact that I am more then happy with your customer service and I do realize that at this price point, you are not out to make a killing but more to support your fellow BMW enthusiasts. That being said, I do have to state the facts:
I have personally checked 3 of the 4 damaged kits and they DID NOT WORK. Considering I am familiar with installing computers and PLC systems in cars, I am more then capable to hook up a red and black wires to a battery to bench test them. This was after 3 other people tried to install them in their cars and bench test with no luck. Keep in mind that at least one kit worked intermittently and if that is the case with one unit then most likely with the others. I can guarantee that all 4 units returned did not function correctly.
__________________


Agent BMW trailer
Adriano is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:41 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.