Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-09-2006, 01:05 PM   #1
BimmerboyPH
5th Gear Member
 
BimmerboyPH's Avatar
 
Join Date: Jun 2006
Location: Smithville
Posts: 981
Oil light problems, any suggestions?

Hey guys,

We have 2004 BMW 325i, and it has been a great car except for one thing. The oil light keeps coming on after you turn off the ignition. Now its not every time you turn off the car that it happens, its just every now and then. This started after about two months of having the car, so we took the car down to Budd's and they changed the oil, gave it a new oil filter, and changed a sensor to. This worked for a while but then it came back and since then we have gone in a few more times, but each time they canít figure out the problem. Now one thing I no for sure is it is not the oil, and my best guess is that there maybe a bug in the computer. I was just wondering then dose anybody have any suggestions, or has anyone else had a similar problem?

Last edited by BimmerboyPH; 07-09-2006 at 01:08 PM.
BimmerboyPH is offline   Reply With Quote
Old 07-09-2006, 01:39 PM   #2
Marky_mark
Detailing Specialist
 
Marky_mark's Avatar
 
Join Date: Oct 2004
Location: Aurora
Posts: 480
Send a message via MSN to Marky_mark
HI BimmerboyPH I had the same problem and chaned the oil level sensor last year on my car and now I am having the same problem as you and the sad thing is its the oil level sensor again the guys at my work tell me that this is commom in bmws for the oil level sensor to act up so the only thing you can do is get Budds to scan yout car to find out if thats the problem and get them to fix it for you
__________________
Marky_mark is offline   Reply With Quote
Old 07-09-2006, 01:44 PM   #3
BimmerboyPH
5th Gear Member
 
BimmerboyPH's Avatar
 
Join Date: Jun 2006
Location: Smithville
Posts: 981
Thanks for the help. Ill get them to check it over, hopefully next weekend!
BimmerboyPH is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:31 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.