Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-08-2006, 05:14 PM   #1
Roninpb
1st Gear Newbie
 
Join Date: Jan 2006
Location: S. Oregon USA
Posts: 23
Apology for Active Autowerke & the Forum

First a recap FYI: Last year I purchased ac AA SC kit for my 05 ZCP M3 thru Autohaus Bayern in Beaverton, OR. We have suffered problems ever since. I remained kind, patient and generous UNTIL an AA employee initiated gross, unjustified insults.

After those incidents I posted my complaints, concerns, experiences, etc, on numerous websites.

For full details please see my threads in re Active Autowerke SC and Project Loud Red.

Phil has been my main contact w/AA for a while now and he has been a pleasure to deal with lately. Facilitating a WARRANTY reflash and other troubleshooting. The car's not running well .... yet .... but there are some improvements (to be posted as an update to "Project: Loud Red" thread asap).

Recently Phil of AA asked me for an apology and a retraction. But he did NOT elaborate. Nor reply to my PM in that regard. So I dismissed his vague request and forgot about it.

So much for ancient history let's move on to the present .... onward.

I feel that it's my duty to be open and honest at all times; even when it's not in my best interests. WTS, since I have learned that the installer of my Active Autowerke Supercharger for late model SMG M3s deceived me on at least three separate occasions, it's incumbent upon me to set things right. Please keep in mind that they told me, in no uncertain terms, that excepting the skid plate (not installed w/my approval after the fact) they had performed the AA SC kit install EXACTLY as per AA's instructions. EXACTLY!!!

Well, that's not even close to the truth.

The fact is (as some of you and AA have learned) the oil cooler was installed upside down. Although there's no reason to believe that the probs we're troubleshooting were related to the oil cooler, the fact remains that AA are within their rights to DENY warranty service until they've had a personal look at the vehicle and determined that the rest of the install was performed as specified by AA.

I have been placed in an untenable position and am now at AA's mercy. Unless I decide to ship my car to AA at a cost of at least $5K (not to mention the many risks involved).

What did AA do when they learned the install was NOT performed EXACTLY as they required .... AA reflashed my ECU and continued to offer phone tech support!

THAT ALONE SHOWS THEIR GOOD WILL AND DEMANDS THAT I RECOGNIZE THEM AND OFFER THEM .... AND YOU .... AN APOLOGY!!!

Please accept my abject apologies for unintentionally misleading you; recognizing that I did NOT know that I was spreading misinformation in re the improperly installed oil cooler.

Peace, Love & Truth,

Richard Allen.
AKA: Ronin.
Roninpb is offline   Reply With Quote
Old 04-08-2006, 11:26 PM   #2
BMWags
6th Gear Member
 
BMWags's Avatar
 
Join Date: Mar 2005
Location: Niagara Falls, ON
Posts: 2,559
ok this is what i got



================================================== =========

cliffs notes:

It was the INSTALLERS fault....NOT Active Autowerke's that messed up the car.

Apologies for bad-talking Active Autowerke
================================================== ==========





props to this admitting a mistake and giving credit where credit is due, even though it means sacrificing a little pride.

rep point for you
BMWags is offline   Reply With Quote
Old 04-08-2006, 11:58 PM   #3
Miguel
...Delt Smash
 
Miguel's Avatar
 
Join Date: Oct 2002
Location: Dudebridge
Posts: 10,882
wussy.
__________________
Miguel is offline   Reply With Quote
Old 04-09-2006, 02:45 AM   #4
Roninpb
1st Gear Newbie
 
Join Date: Jan 2006
Location: S. Oregon USA
Posts: 23
Quote:
Originally Posted by BMWags
ok this is what i got[snip]
I'm sorry that you got it wrong. I'm not sure how to reply except to ask you to read my post again. TIA.
Quote:
Originally Posted by BMWags
It was the INSTALLERS fault.
There could be install issues. IOW: What else did they do that does nto conform to AA's detailed install instructions?

Quote:
Originally Posted by BMWags
NOT Active Autowerke's that messed up the car.
I will NOT allow ths thread to turn into another anti-AA thread. WTS: I did not say nor imply that AA "messed up the car."

But it is a fact that AA made some errors.

So did I by believing that my installers were being open and honest w/me.

The LATTER is what this thread's about.

Quote:
Originally Posted by BMWags
Apologies for bad-talking Active Autowerke[snip]
WRONG AGAIN!

Quote:
Originally Posted by BMWags
props to this admitting a mistake and giving credit where credit is due, even though it means sacrificing a little pride.
Thx! But at the risk of sounding ungrateful .... I must point out again that you misunderstood my meaning and intent.

Peace, Love & Truth,

Richard Allen (the artist formerly known as Ronin [chuckle]).
Roninpb is offline   Reply With Quote
Old 04-09-2006, 02:57 AM   #5
Furious
BMW again.
 
Furious's Avatar
 
Join Date: Feb 2002
Location: Toronto
Posts: 6,088
AA does make mistakes ive read a few over the years, but they have , like most of the major companies have tried to make things right.. i too have purchased a SC new from AA and i got the best treatment and continue to get it still (even after they have my money).

i dont think the installers can get the install wrong considering that AA's install instructions are very very vauge.
Furious is offline   Reply With Quote
Old 04-09-2006, 04:20 AM   #6
BMWags
6th Gear Member
 
BMWags's Avatar
 
Join Date: Mar 2005
Location: Niagara Falls, ON
Posts: 2,559
comments deleted

take it away miguel

Last edited by BMWags; 04-09-2006 at 04:41 AM.
BMWags is offline   Reply With Quote
Old 04-09-2006, 03:38 PM   #7
Roninpb
1st Gear Newbie
 
Join Date: Jan 2006
Location: S. Oregon USA
Posts: 23
Quote:
Originally Posted by Furious
[snip]i dont think the installers can get the install wrong considering that AA's install instructions are very very vauge.
[lol] "Shirley .... you jest." I think I detect a note of sarcasm here, right? ;-)

Seriously, the install docs I have are comprehensive and AA bent over backwards during the install and subsequent troubleshooting (at first, as I reported in detail on other threads over the months).

Unfortunately, i'm stuck between a rock and a hard place now. But it's just a car.

Peace, Love & Truth,

Richard Allen.
Roninpb is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:45 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014