Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-02-2006, 08:56 AM   #1
sammyt
1st Gear Newbie
 
Join Date: Jan 2006
Location: toronto
Posts: 32
Gauge lights stay on kills battery.

Hey, ok my gauge is messed up, the collant metre doesnt work and the engine speed thingy doesnt move, but the gas works and the indicator lights work, now the lights never worked since i bought the car, now i was banging on the scrren a bit and one of the lights came on and wont go away, it killed my battery by staying on, how do I make the light stay off? PLZ help lol
sammyt is offline   Reply With Quote
Old 02-02-2006, 09:44 AM   #2
e30_kid89
The Afro-stig
 
e30_kid89's Avatar
 
Join Date: Nov 2005
Location: TDot West End
Posts: 4,589
Send a message via MSN to e30_kid89
i dunno about the whole banging think that killed ur battery, but if the tach and temp gauge aint workin try checkin the fuse.
__________________
e30_kid89 is offline   Reply With Quote
Old 02-02-2006, 09:50 AM   #3
PelicanGolf2
Stuck in traffic
 
PelicanGolf2's Avatar
 
Join Date: Dec 2004
Location: Burlington
Posts: 367
Quote:
Originally Posted by e30_kid89
i dunno about the whole banging think that killed ur battery, but if the tach and temp gauge aint workin try checkin the fuse.

You need to Change the SI batteries in the cluster, I did and now everything works. It's like a frickin miracle.
PelicanGolf2 is offline   Reply With Quote
Old 02-02-2006, 09:54 AM   #4
Striker
Turbo Ready
 
Striker's Avatar
 
Join Date: Nov 2004
Location: Ottawa, Canada
Posts: 1,651
Quote:
Originally Posted by sammyt
Hey, ok my gauge is messed up, the collant metre doesnt work and the engine speed thingy doesnt move, but the gas works and the indicator lights work, now the lights never worked since i bought the car, now i was banging on the scrren a bit and one of the lights came on and wont go away, it killed my battery by staying on, how do I make the light stay off? PLZ help lol

More tha likely your gauge cluster circuit board (SI board) battery is dead. You did someting to the panel by hitting it and probaby causing something to ground or breaking a circuit trace. No warning lights should remain on with the ignition off and key out.

BTW "Coolant metre" is called Temperature Gauge

Please stop banging things on your BMW, it does not work. If something is not working on the car, something needs fixing.
__________________


SPEED AND POWER IS NOTHING WITHOUT CONTROL,
THANK HITLER, BMW HAS ALL THREE
Striker is offline   Reply With Quote
Old 02-02-2006, 12:37 PM   #5
sammyt
1st Gear Newbie
 
Join Date: Jan 2006
Location: toronto
Posts: 32
haha ya, im new what do u expect lol, thanks guys im gonna switch the battery.
sammyt is offline   Reply With Quote
Old 02-02-2006, 12:39 PM   #6
Striker
Turbo Ready
 
Striker's Avatar
 
Join Date: Nov 2004
Location: Ottawa, Canada
Posts: 1,651
Quote:
Originally Posted by sammyt
haha ya, im new what do u expect lol, thanks guys im gonna switch the battery.
We forgive you this time
__________________


SPEED AND POWER IS NOTHING WITHOUT CONTROL,
THANK HITLER, BMW HAS ALL THREE
Striker is offline   Reply With Quote
Old 02-02-2006, 01:56 PM   #7
sammyt
1st Gear Newbie
 
Join Date: Jan 2006
Location: toronto
Posts: 32
OK 1 more STUPID question, do I need different fuses for the car, cuz i looked at the store and they were different colors for the numbers.
sammyt is offline   Reply With Quote
Old 02-02-2006, 04:28 PM   #8
Striker
Turbo Ready
 
Striker's Avatar
 
Join Date: Nov 2004
Location: Ottawa, Canada
Posts: 1,651
Quote:
Originally Posted by sammyt
OK 1 more STUPID question, do I need different fuses for the car, cuz i looked at the store and they were different colors for the numbers.
Fuses are rated in AMPS (A), you have to replace the fuse with the same amperage as that of the blown fuse. The fuse will have markings like 5A,10A, 15A 20A etc. So if the blown one is a 20A replace it with a 20A fuse.

You do need different fuses (different amps) for your car. Each electrical circuit uses different amounts of current so different fuses are used accordingly.

BTW, I don't think they are stupid questions, but banging a BMW to get it to work is stupid If you don't know thats OK, reason why we help.
__________________


SPEED AND POWER IS NOTHING WITHOUT CONTROL,
THANK HITLER, BMW HAS ALL THREE

Last edited by Striker; 02-02-2006 at 04:59 PM.
Striker is offline   Reply With Quote
Old 02-02-2006, 05:16 PM   #9
sammyt
1st Gear Newbie
 
Join Date: Jan 2006
Location: toronto
Posts: 32
ha ya u guys r good, this is just the start for me man, the car isnt even on the road haha.
sammyt is offline   Reply With Quote
Old 02-02-2006, 05:29 PM   #10
Striker
Turbo Ready
 
Striker's Avatar
 
Join Date: Nov 2004
Location: Ottawa, Canada
Posts: 1,651
Quote:
Originally Posted by sammyt
ha ya u guys r good, this is just the start for me man, the car isnt even on the road haha.
Sh!t, if the car is parked and you have so much trouble and questions, when it gets on the road we may have to get a special SammtT Hotline just for you

If you don't mind getting your paws dirty and can afford some cash, you should invest in a Bentley http://www.bentleypublishers.com/product.htm?code=B390

Saves you lots of time and money, and will help you to quit banging. Sorry have to rub it in so you won't do it again. just kiddin ya.
__________________


SPEED AND POWER IS NOTHING WITHOUT CONTROL,
THANK HITLER, BMW HAS ALL THREE
Striker is offline   Reply With Quote
Old 02-02-2006, 06:19 PM   #11
sammyt
1st Gear Newbie
 
Join Date: Jan 2006
Location: toronto
Posts: 32
I just ordered one off bavauto.com lol
sammyt is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:35 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.