Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-19-2005, 11:42 PM   #1
Darkness95m3
6th Gear Member
 
Darkness95m3's Avatar
 
Join Date: Jan 2005
Location: Ontario
Posts: 2,677
Alignment issues pretty sad. Long story



I have a story to post of poor BMW dealer performance. This story is kind of long, however anyone have any ideas please feel free to give me any suggestions.

My policy is that when you buy a used car always do the following maintenance procedures. 1) Change all fluids 2) 4 wheel alignment.

That’s just what I did to my 95M3 a few years back. Here goes my story.
I had a 4 wheel alignment done through a BMW dealership, to me the price was kind of high, however they should know the car, at least that’s what I thought.
I received the call from the dealer explaining that the vehicle was ready for pick up.
During my drive home everything seemed fine; however I started to notice the steering wheel being to go of centre. It started at the 9-3 position and now it’s at the 10-4 position. After a 40Km trip and finally pulling into my driveway the steering wheel now situated in the 11-5 position.
Next day I called the dealership and explained to them my dilemma. “Strange” they thought. “Bring it in” they explained. After waiting for 2 hours they brought my car on the alignment machine and told me that my rear right tire is out of alignment. Their explanation was “Mechanic did not torque the bolt down properly”. After the service I drove the car home with the same result. Being a Friday and the dealership closed I decided to see if I can find the problem my self.
Once I jacked the car up and going underneath I noticed a rear bushing that was sticking out by an inch or two. With my crow bar I pried the bushing back and upon checking the steering wheel I noticed that it was back to its original alignment. WTF?

On Monday I drove the car to the dealership and explained to them my finding. By end of the morning they called me and explained that it is a worn out bushing and it needs to be replaced. With my approval the car was ready for pick up by end of the day. The bill was high however my dilemma was over and the car in perfect alignment. So I thought.
During the next 3 weeks I had no problems with my alignment everything looked fine. Until one day, as I was walking to the car from the back and looking at the vehicle when something caught my eye. I was at Rona and their parking lot had lots of white powder on it from the construction going on. What I noticed that both of my rear tires had only 1 or 2 visible outside tire treads. Upon a closer inspection I found my tires to be completely bald and wires showing on the inside of each tire.

I immediately called the dealership who told me to bring the car by tomorrow, which would be a Friday. By end of Friday I called to see what the status of my vehicle is. They informed me that they can’t do anything until Monday. With the tires showing wires they recommended that I leave my car behind.

Monday mid morning I call the dealership who told me that this was not their problem, it was mine. They explained to me that I hit something that threw my alignment out.
Now I know that’s bull. I would have had to hit something so hard that it would have bent or broken a suspension component.

I decided to take my car to another BMW dealership. During the inspection they told me that my car was bent. I was alarmed from what I heard. The mechanic explained to me that he has cranked the alignment as far as he could and the car still would not align. I asked him if he noticed that the car was lowered. ‘That would explain everything” he said. After an hour he came out with a smile and told me everything was fine and that there were no bent suspension components. Basically he explained that the other mechanic never compensated for the lowered suspension. After replacing my rear tires and driving for 3 weeks I found that my rear tires were wearing evenly.

During all this time I kept the General Manager informed of what was going on. After a month and all of the facts he refunded me my alignment money. However he gave me every excuse under the sun why he should not.

I thought it was all over. It is for the M3 however for the 540I it’s just the beginning.

After driving my 540 all year I decided to buy new rims and install the Michelin Blizak 17” winter tires. The tires are pretty expensive and I had never had an alignment done. I thought its best if I do it now so that I don’t ruin them after all to replace them would cost me well over $2000.

With a serious thought I thought taking the car back to the dealer who did my M3 would be fine, after all they can’t make the same mistake twice. I picked up the car and drove it for the next 2 to 3 weeks with out any problems. “So I thought”.
I decided last Friday to take of my summer tires and put on my winters. To my surprise the right rear tire (passenger side) was past the wear bars, however just the middle part of the tire was showing wear the outside edges were fine. My first though was that I over inflated my rear tire. Checking the pressure it showed 35PSi so that was not the problem. Removing the drivers rear tire I found it in worse shape then the other one this tire was almost completely bald in the middle. However if I ran my hand from the outside of the tire to the inside it felt smooth. Running my hand in reverse it felt very rough. This is an alignment problem. My alignment is gone again.
I called the dealership who told me that was a over inflation problem and not alignment.
I explained to the General Manager that I have taken the 2 rear tires to a couple of dealerships who told me the same thing “over inflated tires”, however when they ran their hands over the tires they told me that it was a problem with the alignment.
Now I have 4 brand new tires that are not road safe. I’m taking the car to the other dealership on Friday for inspection. The General Manager whose shop originally did the alignment told me we will take this one step at a time. I explained to him I just want 4 brand new tires and my money refunded.

It just goes to show that just because you have a BMW name does not mean you are a reputable repair center. I will keep all informed of what happens.
Darkness95m3 is offline   Reply With Quote
Old 10-19-2005, 11:56 PM   #2
paul christians
87325is///MR.EVIL
 
Join Date: Feb 2004
Location: ajax
Posts: 7,751
Man there is alot of shity mechanics out there........
__________________
87is325///2.7L..EVIL.....
03 beige GRAND AM and 94 white (slamed) PROTEGE
paul christians is offline   Reply With Quote
Old 10-20-2005, 02:13 AM   #3
erikIS
bigcock
 
erikIS's Avatar
 
Join Date: Nov 2004
Location: stoney creek
Posts: 893
why i will never own a bmw without a warranty
__________________
06 WW Mitsubishi EVO IX 365awhp.
06 STI - SOLD
02 JB M3 -SOLD
erikIS is offline   Reply With Quote
Old 10-20-2005, 02:51 AM   #4
Antz_Marchin
4th Gear Member
 
Antz_Marchin's Avatar
 
Join Date: Apr 2004
Location: St.Catharines
Posts: 881
^^ so they dont mess up your tires?? All the warranty would do it get you free alignment.....tires still screwed at your cost. Could happen with any car at any mechaninc. Not cause its a BMW
Antz_Marchin is offline   Reply With Quote
Old 10-20-2005, 04:18 PM   #5
ambasah
2nd Gear Member
 
Join Date: Apr 2002
Location: Toronto
Posts: 213
may I ask which dealership you went to ?
ambasah is offline   Reply With Quote
Old 10-20-2005, 04:44 PM   #6
Darkness95m3
6th Gear Member
 
Darkness95m3's Avatar
 
Join Date: Jan 2005
Location: Ontario
Posts: 2,677
Quote:
Originally Posted by ambasah
may I ask which dealership you went to ?
Depending on the outcome.
Darkness95m3 is offline   Reply With Quote
Old 10-20-2005, 06:28 PM   #7
abc12
4th Gear Member
 
Join Date: Sep 2003
Location: Toronto
Posts: 811
yeah which dealership, let us know, who knows, maybe others on here have experienced problems there as well.
abc12 is offline   Reply With Quote
Old 10-20-2005, 11:06 PM   #8
Mystikal
Moderator/Event-Coordinator
 
Join Date: Feb 2002
Location: Stance
Posts: 12,903
With the lowered M3 part, I don't really see the fault in the dealer. Aftermarket components really can't be expected, unless you explicitly inform them about it. You didn't mention it in the story, but did you do that?
__________________

@stancejay
Mystikal is online now   Reply With Quote
Old 10-20-2005, 11:15 PM   #9
Darkness95m3
6th Gear Member
 
Darkness95m3's Avatar
 
Join Date: Jan 2005
Location: Ontario
Posts: 2,677
Quote:
Originally Posted by Mystikal
With the lowered M3 part, I don't really see the fault in the dealer. Aftermarket components really can't be expected, unless you explicitly inform them about it. You didn't mention it in the story, but did you do that?
I did not mention that to them. However a BMW dealership would have noticed that the car was lowered.
However the problem with the M3 from the beginning was a worn out suspension component. Their job includes checking the suspension before they start the alignment process. In my case they never checked.
In this case yes it was poor service from the 1st dealer.
Darkness95m3 is offline   Reply With Quote
Old 10-20-2005, 11:27 PM   #10
RevShoT
6th Gear Member
 
RevShoT's Avatar
 
Join Date: Jul 2004
Location: Niagara Falls
Posts: 4,822
Send a message via MSN to RevShoT
i hate st catharines bmw.....there all pricks there
RevShoT is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:53 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015