Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-20-2004, 12:10 AM   #1
nseverin
2nd Gear Member
 
nseverin's Avatar
 
Join Date: Jul 2003
Location: Scarborough
Posts: 240
Heated Seats

My passenger seat heat doesn't work anymore.
when you push the button. both LED's just flicker.
Any quick fixes out there?
nseverin is offline   Reply With Quote
Old 09-20-2004, 01:59 AM   #2
E36er
West Coast Contact!
 
E36er's Avatar
 
Join Date: Sep 2004
Location: Kelowna
Posts: 1,358
well mine stopped working..and it just ended up being the switch...i got a new switch and it worked perfect...try switching the Drivers seat switch with the passengers...thats my trouble shoot...could be more complex though
__________________
E36er is offline   Reply With Quote
Old 09-20-2004, 04:48 AM   #3
Justin e36
---
 
Justin e36's Avatar
 
Join Date: May 2003
Location: etobicoke
Posts: 12,331
Send a message via ICQ to Justin e36 Send a message via AIM to Justin e36 Send a message via Yahoo to Justin e36
try e36ers advice first. if it still doesn't work, let us know.
Justin e36 is offline   Reply With Quote
Old 09-21-2004, 12:47 PM   #4
OILERS
2nd Gear Member
 
Join Date: Jul 2002
Location: Mississauga
Posts: 287
nseverin, don't mean to steal your thread. but my drivers seat heat doesn't work either. when i hit the switch, it lights up on low and high, just no heat. the passenger side works fine. i know it could be a bunch of things, any ideas, or maybe quick fixes.
OILERS is offline   Reply With Quote
Old 09-21-2004, 12:48 PM   #5
Justin e36
---
 
Justin e36's Avatar
 
Join Date: May 2003
Location: etobicoke
Posts: 12,331
Send a message via ICQ to Justin e36 Send a message via AIM to Justin e36 Send a message via Yahoo to Justin e36
Quote:
Originally Posted by OILERS
nseverin, don't mean to steal your thread. but my drivers seat heat doesn't work either. when i hit the switch, it lights up on low and high, just no heat. the passenger side works fine. i know it could be a bunch of things, any ideas, or maybe quick fixes.
if you don't feel heat on your back AND bottom then it's probably a loose wire, or the plug for the heating elements came out.
Justin e36 is offline   Reply With Quote
Old 09-21-2004, 04:45 PM   #6
nseverin
2nd Gear Member
 
nseverin's Avatar
 
Join Date: Jul 2003
Location: Scarborough
Posts: 240
lucky you. both led's flash!
check your heat fuse. I forget which one it is. I believe its in the 50's
nseverin is offline   Reply With Quote
Old 09-21-2004, 08:53 PM   #7
OILERS
2nd Gear Member
 
Join Date: Jul 2002
Location: Mississauga
Posts: 287
thanks justine36 and nseverin, i'll check it out.
OILERS is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:29 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.