Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-25-2005, 12:24 PM   #1
new_e46
3rd Gear Member
 
Join Date: Dec 2004
Location: TO
Posts: 316
Need Help!

This morning, when I start the car, the engine sounded rough, after a few seconds, the engine started to shake and then the 'check engine' light came on. I immediately let turn off the car and restart again. The same thing occurred.
I've done a search on the forum and the only post that is similar to my problem is a cracked iginiation coil and some post on a bad tank of gas.

What do you guys think the problem is? The car is a 2003 325i automatic.
Do you think it's drivable or should I have it tow to the dealership?

Thanks!
new_e46 is offline   Reply With Quote
Old 04-26-2005, 08:32 AM   #2
JS328
2nd Gear Member
 
Join Date: Jan 2004
Location: Brooklin, Ont.
Posts: 135
Quote:
Originally Posted by new_e46
This morning, when I start the car, the engine sounded rough, after a few seconds, the engine started to shake and then the 'check engine' light came on. I immediately let turn off the car and restart again. The same thing occurred.
I've done a search on the forum and the only post that is similar to my problem is a cracked iginiation coil and some post on a bad tank of gas.

What do you guys think the problem is? The car is a 2003 325i automatic.
Do you think it's drivable or should I have it tow to the dealership?

Thanks!
Same thing happened to me last spring in the Touring. It was the ignition coils. I "limped" it to the dealer which is less the 10km away. I'd call the dealer, explain the situation and check if they think you can drive it in. When it happened to me the Service Manager told me to drive it in, instead of waiting 4 hours for a tow.

From talking to the Service Advisor, it looks like its a fairly common problem with the 2003 325s..

Good Luck!
__________________
1997 BMW 332i
2003 BMW 325iT
JS328 is offline   Reply With Quote
Old 04-26-2005, 10:32 AM   #3
new_e46
3rd Gear Member
 
Join Date: Dec 2004
Location: TO
Posts: 316
Yap, it a common problems for our cars. I eventually got a flatbed tow truck and tow the car in b/c I didn't want to take the risk of damaging the engine.
Just spoke to the service advisor, he told me that they replaced all 6 of the ignitation coils.
new_e46 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014