Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-07-2002, 08:47 PM   #1
oktay
1st Gear Newbie
 
Join Date: May 2002
Location: Toronto
Posts: 37
e30 timing belt broke at 100K and done a valve job

The oil light is on and the inspection light is on red(very last one)
What kind of problems should I expect from this vehicle?

TIA
__________________
What is mod?
oktay is offline   Reply With Quote
Old 06-08-2002, 01:45 AM   #2
Dave 325i
4th Gear Member
 
Join Date: May 2002
Location: .
Posts: 888
not sure i understand clearly . . .

Is this a car you're looking to buy?

By valve job, do you mean like performance regrind / reseating etc. or just adjusting the valves?

When a timing belt breaks on an E30, the valves don't move in sync with the pistons, which means the pistons will smash into the valves. Valves will be bent, holes in pistons, etc. Car won't run.

Maybe the previous owner had the valve job after the belt break as a repair?

The oil and inspection lights are just reminders to change the oil and have an inspection done on the car. They can be reset. I guess it means the the previous owner was too cheap to do the maintenance, or did it and did not reset the lights.
Dave 325i is offline   Reply With Quote
Old 06-08-2002, 12:59 PM   #3
BMW BMXer
Wants a 350 Blazer.
 
BMW BMXer's Avatar
 
Join Date: Mar 2002
Location: Mississauga
Posts: 7,761
Send a message via ICQ to BMW BMXer Send a message via AIM to BMW BMXer Send a message via MSN to BMW BMXer Send a message via Yahoo to BMW BMXer
I reset my insepction lights they where off for a day then came back...
__________________

Stanceiseverything.com
BMW BMXer is offline   Reply With Quote
Old 06-09-2002, 04:59 PM   #4
swisherchico
2nd Gear Member
 
Join Date: Jun 2002
Location: Chico, CA
Posts: 181
SI Batteries dead

Quote:
Originally posted by BMW BMXer
I reset my insepction lights they where off for a day then came back...
If you reset your service indicator lights and they come back to the red and yellow, that means your SI (service indicator) batteries are dead, you need to take out the gauge cluster to have them replaced. www.bmwe30.net has some step by step instructions on how to complete this process.
swisherchico is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:30 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.