Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-20-2004, 03:17 AM   #1
christian
2nd Gear Member
 
Join Date: Jan 2004
Location: arizona
Posts: 201
Send a message via AIM to christian
Unhappy Dead fuel pump

hey guys sunday i went out to start my 318i and it started fine but wouldn't idle worth shit, it would sputter around 600rpm, shacking really bad so i would shut it off then tried again same thing! i think its my fuel pump cuz its been making a loud buzzing noise latley and i dont think there was enough fuel flowing to idle right, any suggestions? they are much appretiated, thanx in advanced (sniff sniff)
__________________


Extrude honed intake
95 Mustang 5.0 15lbs fuel injectors
Platnum 4 spark plugs
Blaster 2 Coil
racing Ceramic brake pads

*not much to it, but not stock either*
christian is offline   Reply With Quote
Old 04-20-2004, 04:03 AM   #2
snd84318i
3rd Gear Member
 
snd84318i's Avatar
 
Join Date: Oct 2003
Location: nyc
Posts: 378
try warming it up if it does it still check your ide control unit . if the fuel pump didnt work it wouldnt start .
__________________
snd84318i is offline   Reply With Quote
Old 04-20-2004, 05:34 AM   #3
felixthecat
Was touched by Micheal
 
felixthecat's Avatar
 
Join Date: Feb 2004
Location: Barrie
Posts: 2,334
Send a message via MSN to felixthecat
Re: Dead fuel pump

Quote:
Originally posted by christian
hey guys sunday i went out to start my 318i and it started fine but wouldn't idle worth shit, it would sputter around 600rpm, shacking really bad so i would shut it off then tried again same thing! i think its my fuel pump cuz its been making a loud buzzing noise latley and i dont think there was enough fuel flowing to idle right, any suggestions? they are much appretiated, thanx in advanced (sniff sniff)
change the fuel filter...sounds like the pump is working against the gunk caught in it..,its not the idle air control..when those go it idles wayyyyyy too high...also pull down the cover above your glove box and check that single wire plug to the left hand side of the fuel computer,see if its loose(this is what made my car run awful awile back)..if youve done all that and still no luck...change the pump.
felixthecat is offline   Reply With Quote
Old 04-20-2004, 02:29 PM   #4
SebSter
6th Gear Member
 
SebSter's Avatar
 
Join Date: Mar 2003
Location: Toronto
Posts: 3,414
change it asap, before you know it youre gonna get a million other problems turning up..trust me
__________________

Old car 1990 325ix. Current car 2000 540i.
SebSter is offline   Reply With Quote
Old 04-21-2004, 12:23 AM   #5
christian
2nd Gear Member
 
Join Date: Jan 2004
Location: arizona
Posts: 201
Send a message via AIM to christian
hey guys thanx i will try what u said today and see if it helps,by the way felix ur car looks sic!! in your sig what color is that?
__________________


Extrude honed intake
95 Mustang 5.0 15lbs fuel injectors
Platnum 4 spark plugs
Blaster 2 Coil
racing Ceramic brake pads

*not much to it, but not stock either*
christian is offline   Reply With Quote
Old 04-21-2004, 01:14 AM   #6
felixthecat
Was touched by Micheal
 
felixthecat's Avatar
 
Join Date: Feb 2004
Location: Barrie
Posts: 2,334
Send a message via MSN to felixthecat
Quote:
Originally posted by christian
hey guys thanx i will try what u said today and see if it helps,by the way felix ur car looks sic!! in your sig what color is that?
photoshop blue
felixthecat is offline   Reply With Quote
Old 04-21-2004, 04:07 PM   #7
chromius
6th Gear Member
 
chromius's Avatar
 
Join Date: Dec 2002
Location: Ottawa
Posts: 4,006
get a fuel pressure guage, then check the pressure. That will tell you if the pump is bad, or if your FP regulator is bad.
__________________
Photobucket
chromius is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:36 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014