Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-20-2004, 02:28 AM   #16
325iSBimmer
///MMMM VIDA
 
325iSBimmer's Avatar
 
Join Date: Feb 2003
Location: Aurora/London
Posts: 1,399
Send a message via MSN to 325iSBimmer
ahhhaaa!...its true......nothing comes up


hmmm
__________________
UNDER CONSTRUCTION
325iSBimmer is offline   Reply With Quote
Old 02-20-2004, 02:32 AM   #17
crazyvadim
6th Gear Member
 
crazyvadim's Avatar
 
Join Date: Nov 2003
Location: New York
Posts: 2,178
Send a message via AIM to crazyvadim
Some weird shit....why would bmw do this??
crazyvadim is offline   Reply With Quote
Old 02-20-2004, 02:38 AM   #18
-=[[f|L@pJ@cK=]
4th Gear Member
 
Join Date: Nov 2002
Location: Mississauga
Posts: 856
ok i found a thread on this topic at bimmerforums. here's the link,

http://forums.bimmerforums.com/forum...threadid=99432
-=[[f|L@pJ@cK=] is offline   Reply With Quote
Old 02-20-2004, 02:40 AM   #19
mkgino
6th Gear Member
 
mkgino's Avatar
 
Join Date: Apr 2002
Location: Toronto
Posts: 7,684
believe it or not, this is a repost
__________________
mkgino is offline   Reply With Quote
Old 02-20-2004, 03:37 AM   #20
beamerboycsl
3rd Gear Member
 
Join Date: Dec 2003
Location: Mass
Posts: 326
Send a message via AIM to beamerboycsl
thanks -=[[f|L@pJ@cK=]
thats where i found it. i email and she replied but ill let u know exactly what happens or gets fixed or done.
beamerboycsl is offline   Reply With Quote
Old 02-20-2004, 03:43 AM   #21
Fern
2nd Gear Member
 
Fern's Avatar
 
Join Date: Feb 2003
Location: wouldn't you like to know!
Posts: 215
random pixels in instrument cluster

This is a known problem that effects the e38 and e39 bmws.

BMWNA has commited to fixing the problem (on an individual basis). Most clusters get replaced by: you pay labour (2hours) BMWNA supplies part.

The hitch is here,

I have sent a letter to BMWCA and they very politely told me to go f--ck myself.

Seams like BMWCA and BMWNA don't agree how this should be resolved.

So for us Canucks were SOL for now anyway.

//Fern
__________________
Exmodeldater :-)

'99 BMW 540i6 (black on black)
'99 Lexus Rx300
Fern is offline   Reply With Quote
Old 02-20-2004, 03:47 AM   #22
Fern
2nd Gear Member
 
Fern's Avatar
 
Join Date: Feb 2003
Location: wouldn't you like to know!
Posts: 215
Quote:
Originally posted by crazyvadim
Some weird shit....why would bmw do this??
Cause:

Bad contacts at the soldered points of internals of the cluster itself. I suspect that BMWNA had gotten the part manufacturer to accept liability for the defect and owners are paying their own labour,

Therefore,

even though BMWNA is looking like the niceguy doing you a favour, it actually does not cost them a cent..

Just food for thought,

Cheers,

Fern
__________________
Exmodeldater :-)

'99 BMW 540i6 (black on black)
'99 Lexus Rx300
Fern is offline   Reply With Quote
Old 02-20-2004, 03:55 AM   #23
beamerboycsl
3rd Gear Member
 
Join Date: Dec 2003
Location: Mass
Posts: 326
Send a message via AIM to beamerboycsl
haha true but i dont mind paying about 72 bucks instead of 200= for a new radio or climate control cluster.
beamerboycsl is offline   Reply With Quote
Old 02-20-2004, 04:34 AM   #24
SebSter
6th Gear Member
 
SebSter's Avatar
 
Join Date: Mar 2003
Location: Toronto
Posts: 3,414
Quote:
Originally posted by mkgino
believe it or not, this is a repost
ditto, i remember seeing this too, a while ago
__________________

Old car 1990 325ix. Current car 2000 540i.
SebSter is offline   Reply With Quote
Old 02-20-2004, 12:40 PM   #25
sonic07
6th Gear Member
 
sonic07's Avatar
 
Join Date: Feb 2003
Location: Street - Ville
Posts: 1,260
Quote:
Originally posted by mkgino
believe it or not, this is a repost
LOL ... MK you're spoiling it for those who haven't seen it b4.

I wonder how old bmw would they go back to fix the problem...
__________________

Pedal To The Metal
sonic07 is offline   Reply With Quote
Old 02-22-2004, 04:35 AM   #26
beamerboycsl
3rd Gear Member
 
Join Date: Dec 2003
Location: Mass
Posts: 326
Send a message via AIM to beamerboycsl
idk man email they might?
beamerboycsl is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:21 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.