Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-24-2004, 02:04 PM   #1
bmw325ix
2nd Gear Member
 
Join Date: Aug 2003
Location: chicago
Posts: 81
Send a message via AIM to bmw325ix
e30 gas gauge problem

ive had a problem that seems unsolveable, the gas gauge in my e30 ix is nuts it does whatever it wants the only thing that works is the low gas warning light. if anyone has any info please help thanks
bmw325ix is offline   Reply With Quote
Old 01-24-2004, 02:35 PM   #2
Slowered318
Powered by Budgies
 
Slowered318's Avatar
 
Join Date: Jan 2002
Location: Toronto
Posts: 5,960
I've heard of E30 guage clusters going for a $hit and needing replacement.. but you could always check the sending unit first in the gas tank.. maybe it's not reading a stedy voltage and needs to be replaced.. can't really help you but i've seen this on the coolant Temp guage many times
__________________
The major difference between my 318is and an e30 M3 is that the noises come from the engine and not the passengers
Slowered318 is offline   Reply With Quote
Old 01-24-2004, 04:57 PM   #3
BMW BMXer
Wants a 350 Blazer.
 
BMW BMXer's Avatar
 
Join Date: Mar 2002
Location: Mississauga
Posts: 7,761
Send a message via ICQ to BMW BMXer Send a message via AIM to BMW BMXer Send a message via MSN to BMW BMXer Send a message via Yahoo to BMW BMXer
Clean the grounds on the back of the cluster
__________________

Stanceiseverything.com
BMW BMXer is offline   Reply With Quote
Old 01-26-2004, 02:49 AM   #4
BladeRunner
4th Gear Member
 
BladeRunner's Avatar
 
Join Date: Mar 2003
Location: some terrestrial planet
Posts: 662
What cleaning accessories needed? Air gun, soft brisseled brush...
__________________
Mad E30 lover
BladeRunner is offline   Reply With Quote
Old 01-26-2004, 03:04 AM   #5
BMW BMXer
Wants a 350 Blazer.
 
BMW BMXer's Avatar
 
Join Date: Mar 2002
Location: Mississauga
Posts: 7,761
Send a message via ICQ to BMW BMXer Send a message via AIM to BMW BMXer Send a message via MSN to BMW BMXer Send a message via Yahoo to BMW BMXer
I think you just take the cluster out and clean the corsion off with sand paper or something. It works for the temp gauge anyway.
__________________

Stanceiseverything.com
BMW BMXer is offline   Reply With Quote
Old 01-26-2004, 06:23 AM   #6
nzer
4th Gear Member
 
nzer's Avatar
 
Join Date: Jan 2003
Location: Auckland, New Zealand
Posts: 674
check the SI board is working OK. The old batts may have leaked and farked all the traces on the board up.
__________________
BMWs Downunder
http://www.bimmersport.co.nz
nzer is offline   Reply With Quote
Old 01-27-2004, 03:31 AM   #7
BladeRunner
4th Gear Member
 
BladeRunner's Avatar
 
Join Date: Mar 2003
Location: some terrestrial planet
Posts: 662
Quote:
Originally posted by BMW BMXer
I think you just take the cluster out and clean the corsion off with sand paper or something. It works for the temp gauge anyway.
Sand paper ; that doesn't sound good for flow of electricity if you hand slips nad scrapes a critical point.
BladeRunner is offline   Reply With Quote
Old 01-27-2004, 05:24 AM   #8
SebSter
6th Gear Member
 
SebSter's Avatar
 
Join Date: Mar 2003
Location: Toronto
Posts: 3,414
you know what happened to me just last week, kinda related... my computer shows whack consumption readings, the gas gauge works fine and the consumption needle under the tach works fine but my computer shows like 5.9 l/100 and a distance of 999+ on a full tank .. stupid thing
__________________

Old car 1990 325ix. Current car 2000 540i.
SebSter is offline   Reply With Quote
Old 01-27-2004, 06:33 PM   #9
chromius
6th Gear Member
 
chromius's Avatar
 
Join Date: Dec 2002
Location: Ottawa
Posts: 4,006
I've got the same problem on mine, and I know of several others that have had the same problem...I think it must be common...I've just been relying on KM's to know how much gas I have, and since the low fuel warning still works, I don't worry about it too much. But I wouldn't mind knowing why it messed up, I figure I will fix it some day.
chromius is offline   Reply With Quote
Old 01-29-2004, 11:38 AM   #10
SebSter
6th Gear Member
 
SebSter's Avatar
 
Join Date: Mar 2003
Location: Toronto
Posts: 3,414
my computer fixed itself...a couple of nights ago it just reset itself, liek the time/date and everything reset...and since then it shows the right readings .. weird , but i aint complainin
__________________

Old car 1990 325ix. Current car 2000 540i.
SebSter is offline   Reply With Quote
Old 01-29-2004, 04:24 PM   #11
tuNED318
///M Testing Engineer
 
tuNED318's Avatar
 
Join Date: Jul 2003
Location: Montréal, QC
Posts: 603
Same thing here, my gas gauge doesn't work and the low gas light is always on.... but every other gauge seems to work fine

Although, I miss a gasket near the filling hole maybe it has something to do with it?
__________________
tuNED318 is offline   Reply With Quote
Old 01-30-2004, 11:38 AM   #12
magnus
6th Gear Member
 
magnus's Avatar
 
Join Date: Jan 2003
Location: Reykjavik
Posts: 3,471
just get a new gauge if the gauge is faulty! used ones are peanuts! i got a cluster with everything for about $30. As for the OBC (if thats what you re refering to as a computer unplug it and check the connector is ok and make sure its plugged in correctly and tight ! I am pretty sure though that both the fuel and temp gauge faults will only be solved for good if you replace them. Had the same problem too!
__________________
http://pics.livejournal.com/blblblblx/pic/000r554e.gif

"Lo there do I see my father.
Lo there do I see my mother.
Lo there do I see my brothers and my sisters.
Lo there do I see the line of my people back to the beginning.
Lo they do call to me
they bid me take my place among them in the Halls of Valhalla,
where the brave may live forever"
magnus is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:26 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.