Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-06-2003, 12:56 AM   #1
SebSter
6th Gear Member
 
SebSter's Avatar
 
Join Date: Mar 2003
Location: Toronto
Posts: 3,414
engine (?) problem?

theres a little problem, sometimes when im at low rpm (starting, or already moving) the engine will kick a bit (and the check engine light will flicker) as if its about to stall but it doesnt... now its not at really low rpm its around 1500-2000 that it does it.. i have a feeling it might be the sparkplugs (even though they have been changed fairly recently i want to put in the best available) but im not sure, anyonw know what the problem could be?

also, which sparkplugs would you reccomend for an e30 325?
SebSter is offline   Reply With Quote
Old 11-06-2003, 01:06 AM   #2
SpudBoy
Couped up
 
SpudBoy's Avatar
 
Join Date: Aug 2002
Location: Durham Region Ontario
Posts: 2,344
Send a message via ICQ to SpudBoy
I'm no specialist but...

get that puppy checked out on the double, could be a bad plug/wire or coil-pack.
__________________

SpudBoy
'99 M Coupe - Imola/Imola
Signature Pictures by Alezone

original BMW parts

To mod or not to mod? That is the question
SpudBoy is offline   Reply With Quote
Old 11-06-2003, 01:09 AM   #3
SebSter
6th Gear Member
 
SebSter's Avatar
 
Join Date: Mar 2003
Location: Toronto
Posts: 3,414
see the weird thing is that its very rare... maybe happens once to twice a day, and im out driving for at least 1-2 hours a day ... so its not like it happens non-stop but its definately something i wanna get checked out.. im gonna try changing the plugs first since i wanted to get that done anyways...so can you tell me which would be best to pick up? i hear bosch r the best for bmws...which model should i get?
__________________

Old car 1990 325ix. Current car 2000 540i.
SebSter is offline   Reply With Quote
Old 11-06-2003, 02:05 AM   #4
bmwm5lover
is BMW crazy
 
bmwm5lover's Avatar
 
Join Date: Sep 2002
Location: Thornhill
Posts: 15,368
according to charlie( i asked him cuz i need to change mine), the best ones for our engines are the OEM Bosch from the dealer. He told me not to buy the Bosch +2,+4 from CT, since they cause problems on our engines
__________________
www.enthusiastauto.caNeed a car???

His--'00 BMW ///M5 .:Jet BLK/BLK:. Individual-1 of 1 - Style 65 Wheels; 9.5" Square Set up;275 Tires;10mm/3mm Spacers; Black Kidneys;Muffler Delete; 3.5" Dual Tips; Beast Power; "Dinan" Ducts; E60 SSK; BC Coils
Hers--'00 BMW ///M5 .:Avus Blue/Grey/Black:. 1 of 8
Toys
'88 BMW 635CSi Blue/Tan Sport
'81 MB 500 SEC Euro Koenig
bmwm5lover is offline   Reply With Quote
Old 11-06-2003, 10:46 PM   #5
snd84318i
3rd Gear Member
 
snd84318i's Avatar
 
Join Date: Oct 2003
Location: nyc
Posts: 378
what problems do the plugs give i just put in P+2's today . there from bosch too . how much different can they be. also i noticed that when i changed them . plugs 1+2 (starting from the back ) were wet with oil . now i forgot to remove the tops on my plugs and didnt know i had to untill i walked to three auto stores to find wires thinking that the old ones were no good and at the last store there i asked and he told me that i had to.
i never had a bmw so all this is knew to me . my maxima i had P+4 in the mnever nsrewed tops . anyway does this mean i have tomuch oil in motor and would this hurt my motor. car was sitting for two years before i bought it . i plan on changing it next week.thanks
snd84318i is offline   Reply With Quote
Old 11-10-2003, 03:19 AM   #6
SebSter
6th Gear Member
 
SebSter's Avatar
 
Join Date: Mar 2003
Location: Toronto
Posts: 3,414
well i changed the spark plugs with the ones i got from the dealer and igotta say i do notice an improvement... it might just be one of those things thats all in my head but i really doubt it... the engine kicking hasnt happened (yet *cross fingers*) and the idle is a lot smoother .. come to think of it everything is smoother ... for things like this its best to go oem (bmw knows best)
__________________

Old car 1990 325ix. Current car 2000 540i.
SebSter is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:21 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.