Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-22-2003, 01:01 AM   #1
Shamis
6th Gear Member
 
Join Date: Feb 2003
Location: Canada
Posts: 1,383
Thumbs down Need a good bmw shop in guelph my car just exploded

ok
I have a thread about how my fan broke today. Well i went to the corner store and back with my car watching to make sure it wouldnt over heat and to get gas so i wouldnt run out trying to fix it and on the way back the battery light came on, then i lost power steering, then the car started to overheat,


it got to 3/4 of heat and then i turned the engine off

opened the hood and it was smoking like a bitch. Under the car was a puddle of what i believe to be coolant not oil. So I do not think the engine blew, i think my rad blew. But i will have to wait till light to see what that puddle of stuff came from.

from what i can see know the belt came off. and there was a puddle of oil, and i dont have a fan.


Are there any shops here in guelph? I also do not want to fix this i would like to sell my car as is/ anyone interested??
Shamis is offline   Reply With Quote
Old 09-22-2003, 01:09 AM   #2
chitown
4th Gear Member
 
Join Date: Jul 2003
Location: Georgetown
Posts: 831
I don't know of any BMW shops in Guelph as I'm new here myself but on Gordon road where all the construction is there's a shop on the corner with a shitload of Volvo's. You can try there maybe...
chitown is offline   Reply With Quote
Old 09-22-2003, 01:10 AM   #3
Shamis
6th Gear Member
 
Join Date: Feb 2003
Location: Canada
Posts: 1,383
the thing is i got no car to drive around and find a shop!
Shamis is offline   Reply With Quote
Old 09-22-2003, 01:22 AM   #4
chitown
4th Gear Member
 
Join Date: Jul 2003
Location: Georgetown
Posts: 831
Just checked google, doesn't seem to be any BMW shops around here, sorry bud..
chitown is offline   Reply With Quote
Old 09-22-2003, 01:27 AM   #5
chitown
4th Gear Member
 
Join Date: Jul 2003
Location: Georgetown
Posts: 831
One in Waterloo called B-K Motors:

From Guelph:

Leave Guelph on Hwy. 7 (Woodlawn Road). As you enter Kitchener, this becomes Victoria Street. Proceed along Victoria Street to Bruce Street and turn left Proceed 0.1km and turn right onto Hwy. 86 North Waterloo Proceed 6.5km to King Street Exit Veer right on ramp to follow King Street North Proceed 0.5km, turn left into B-K Motors and you have arrived.
chitown is offline   Reply With Quote
Old 09-22-2003, 01:44 AM   #6
Mr seville
6th Gear Member
 
Mr seville's Avatar
 
Join Date: Jan 2002
Location: places
Posts: 4,851
look in the front of your engione closest to the windshield. right in the middle of the towers there should be a three pointed thing. check if one of the hoses fell off. it might have broken because of all the years of wear and tear. it's a bitch to put back together in the middle of an ice storm trust me
Mr seville is offline   Reply With Quote
Old 09-22-2003, 02:00 AM   #7
Shamis
6th Gear Member
 
Join Date: Feb 2003
Location: Canada
Posts: 1,383
All the problems are from infront of the engine, not close to the windshield
Shamis is offline   Reply With Quote
Old 09-22-2003, 03:21 AM   #8
Harry
4th Gear Member
 
Join Date: Mar 2002
Location: Kitchener
Posts: 852
A couple places in Guelph.

Guelph Import Service Phone: (519)836-6032
Peter is the owner
42 Essex Street, Guelph, ON N1H 3K8

Autosparks Phone: (519)823-8588
2-121 Malcolm Road, Guelph, ON N1K 1A8

Essex St is downtown near harveys and Malcolm Rd is by the Auto mall on hwy 7/Woodlawn Rd.
Harry is offline   Reply With Quote
Old 09-22-2003, 03:48 AM   #9
Shamis
6th Gear Member
 
Join Date: Feb 2003
Location: Canada
Posts: 1,383
Good Shops??
Shamis is offline   Reply With Quote
Old 09-22-2003, 03:48 AM   #10
Shamis
6th Gear Member
 
Join Date: Feb 2003
Location: Canada
Posts: 1,383
Good Shops??
Shamis is offline   Reply With Quote
Old 09-22-2003, 04:24 AM   #11
Harry
4th Gear Member
 
Join Date: Mar 2002
Location: Kitchener
Posts: 852
Yeah, I've used both. I prefer Import Services over Autosparks.
Harry is offline   Reply With Quote
Old 09-22-2003, 04:52 AM   #12
blkm3
3rd Gear Member
 
Join Date: Jun 2003
Location: TO
Posts: 516
ok . i did post in your other post that it was your water pump while others think it was the fan clutch.
1st you said your fan was wobbly . I suspected that it was the bearing in your water pump that was going .
2nd you have water in the front . i really really doubt it is your rad. your water pump finally went (bearings) so now the pump is sitting in an angle so that all the coolant comes out.
3rd your belt is off now that is an even better indication that water pump went as that belt should fall off and make all those "dummy" lights come on as it is not running the alternator .
you check it out and let me know if my wild guess is right dont let the shop screw you on anything else that you dont need changing.
blkm3 is offline   Reply With Quote
Old 09-22-2003, 05:06 AM   #13
Shamis
6th Gear Member
 
Join Date: Feb 2003
Location: Canada
Posts: 1,383
but the fan broke last night
i have no blades at all on my fan
Shamis is offline   Reply With Quote
Old 09-22-2003, 05:15 AM   #14
Mitch555
Retired MaXmember!
 
Mitch555's Avatar
 
Join Date: May 2003
Location: Mississauga
Posts: 3,989
Two words.... MAINTAIN IT!!!!
__________________


MY ENGINE SWAP: HERE!

Life Is A Tough Teacher, It Gives You The Test Then The Lesson.

Quote:
Originally Posted by Mystikal
just do it once, do it right.
Mitch555 is offline   Reply With Quote
Old 09-22-2003, 05:22 AM   #15
Shamis
6th Gear Member
 
Join Date: Feb 2003
Location: Canada
Posts: 1,383
I do maintain my ****ing car, I just hit a speed bump and it ****ec everything up
Shamis is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014