Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-26-2003, 04:04 AM   #1
futureV10
1st Gear Newbie
 
Join Date: Aug 2003
Location: Elgin, Illinois
Posts: 1
Unhappy engine won't go past 3500 while driving!

I have a 1989 325i and any time the tach gets to about 3500-4000 RPM, the needle just bounces off, like it's hitting a rev limiter. I just replaced the fuel filter, and it worked fine for about 20 minutes, but went back to the same problem.

Please, HELP!!
futureV10 is offline   Reply With Quote
Old 08-26-2003, 08:44 AM   #2
Slowered318
Stuck in the 90's
 
Slowered318's Avatar
 
Join Date: Jan 2002
Location: Toronto
Posts: 6,027
I'm not shure if the 325's have a crank sensor, but if they do that was the problem I had. A stone got jammed between the sensor and the crank, it ripped the top of the $275 sensor apart. If it's a distributor system then that could be the problem too, contacts wear out and the fireing order gets all gimped up

Best of luck
Slowered318 is offline   Reply With Quote
Old 08-26-2003, 12:30 PM   #3
EMPOWERD
Senior Moderator/Event-Coordinator
 
EMPOWERD's Avatar
 
Join Date: Dec 2001
Location: Mrs. Sauga
Posts: 10,146
engine RPM limit at 3500rpm means your ECU is currently running in limp mode. Something you did caused this. To fix it temporarily locate the computer (in the glove box, screwed to the top) and disconnect it. It's very easy to do and required a phillips screwdriver to remove the plastic and a 8mm or 10mm (can't remember) socket to drop the computer.. they carefully remove the large wiring harness plug and reconnect. wah-lah!
__________________

My YouTube video
-- RANDY SPARRE --
EMPOWERD is offline   Reply With Quote
Old 08-26-2003, 11:58 PM   #4
nzer
4th Gear Member
 
nzer's Avatar
 
Join Date: Jan 2003
Location: Auckland, New Zealand
Posts: 674
valve bouncing? .. or perhaps the cam belt is installed incorrectly, and the timing can't be adjusted so you seem limited to 4000 ish.

Randy: I didn't know the e30s had "limp mode". What causes it?
nzer is offline   Reply With Quote
Old 08-27-2003, 05:07 AM   #5
ZiMMie
6th Gear Member
 
Join Date: Oct 2002
Location: T-Dot
Posts: 9,946
Send a message via ICQ to ZiMMie Send a message via MSN to ZiMMie
chk ur spark plugs..
__________________
#E36-S54 #CSLWannabe
ZiMMie is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:02 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014