Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-28-2013, 08:30 PM   #1
fitter527
hates chrome
 
fitter527's Avatar
 
Join Date: May 2009
Location: london ontario
Posts: 542
my car is allergic to the beer store

Culprit-01 330i
About a month ago I went to the store, went in got what I needed, went to start the car and it wouldnt start.all the lights, dash lights, locks all worked fine.just wouldnt start.got it towed home to try and figure out the problem.the next day I checked a few things out, battery, fuses, clutch relay, ect.I couldnt figure out the problem so I got it towed to my indy shop.he called and told me that the starter was toast so I told him to replace it.
My wife picked up the car because I was out of the province til the following week.I get home and the next day I get in the car and drive to the beer store.I open the trunk, put the beer in, get back in and go to start the car and nothing.all the same symptoms as before.I call the mechanic and he asks me to bring the car back to have a look.I dont hear from him for a couple of days so I stop in to see if he looked at the car.he tells me he cant figure out the problem but he will get his electrical guy to have a look the next day.
He calls me the following day and says the car is ready, that it was some wiring problem? So I go pick up the car and he gave me a diagram of what the tech did.he tried to explain it to me but I can barely screw in a lightbulb.
Fast forward to this afternoon.I got to the beer store again.I open the trunk, put beer in, get in car and guess what same prob as before.
I dont know what is goin on but I suspect its something to do with the trunk, not the beer store as I origanally thought.lol.
Any ideas? Im tryin to find the wiring diagram and will post it when I find it.
fitter527 is offline   Reply With Quote
Old 10-28-2013, 08:40 PM   #2
TSI
Reverse Gear Member
 
Join Date: Aug 2011
Location: Oakville
Posts: 846
No, you got it wrong. It just wants more beer!
TSI is offline   Reply With Quote
Old 10-28-2013, 08:43 PM   #3
fitter527
hates chrome
 
fitter527's Avatar
 
Join Date: May 2009
Location: london ontario
Posts: 542
No thats me.lol
fitter527 is offline   Reply With Quote
Old 10-28-2013, 09:15 PM   #4
Jonny
1st Gear Newbie
 
Join Date: Mar 2013
Location: toronto
Posts: 8
For the price of one I would replace your ignition SWITCH. You may have a high resistance on the contacts for the starter circuit. This is a simple check for a mechanic good with electrical but you have to test it when it is acting up. If you break open the switch you will see a slight discolouration on the copper contacts, however the switch is destroyed at that point.
Jonny is offline   Reply With Quote
Old 10-28-2013, 09:40 PM   #5
gec
2nd Gear Member
 
gec's Avatar
 
Join Date: Oct 2013
Location: HAZARD ZONE
Posts: 126
lmfao...might be cheaper to get the beer delivered...or it could be the ignition switch?
gec is offline   Reply With Quote
Old 10-28-2013, 10:21 PM   #6
dbworld4k
Addict
 
dbworld4k's Avatar
 
Join Date: Aug 2006
Location: YYZ / ORD
Posts: 7,270
Have you checked the battery terminal contacts in the trunk and under the hood?

I had similar issues with my 330Ci, turned out to be corrosion/chalky buildup on a terminal. I cut off the affected portion of the cable and it never gave me an issue again.
__________________


'02 ///M5 Imola Red / Imola Red '09 335i Alpine White / Coral Red

Past:
'04 E55 AMG Brilliant Silver / Anthracite
'96 318i Alpine White / Black
'01 330Ci Titanium Silver / Coral Red
'96 328i Jet Black / Black
dbworld4k is offline   Reply With Quote
Old 10-28-2013, 10:30 PM   #7
fitter527
hates chrome
 
fitter527's Avatar
 
Join Date: May 2009
Location: london ontario
Posts: 542
I havent checked anything.im hoping someone steals the f'in thing.called a cab and left the car there.there was beer to be drank.lol
fitter527 is offline   Reply With Quote
Old 10-28-2013, 10:38 PM   #8
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,413
You need a new mechanic.
__________________
T.Dot_E30 is offline   Reply With Quote
Old 10-28-2013, 10:47 PM   #9
fitter527
hates chrome
 
fitter527's Avatar
 
Join Date: May 2009
Location: london ontario
Posts: 542
Mechanical I do myself.electrical, not so much.
fitter527 is offline   Reply With Quote
Old 10-29-2013, 12:30 AM   #10
fitter527
hates chrome
 
fitter527's Avatar
 
Join Date: May 2009
Location: london ontario
Posts: 542
From what I've read, doesnt sound like ignition switch.ill check battery connections tmrw but last I checked they were fine.
fitter527 is offline   Reply With Quote
Old 10-29-2013, 02:31 AM   #11
jabela
4th Gear Member
 
Join Date: Apr 2007
Location: Toronto, ON, Canada
Posts: 779
Have you driven it anywhere other than the beer store? Or do you only drive to/from the beer store? lol
__________________

2002 E46 325ci // 5spd // ISC N1 Coilovers
www.modernapothecary.ca
jabela is online now   Reply With Quote
Old 10-29-2013, 08:58 AM   #12
fitter527
hates chrome
 
fitter527's Avatar
 
Join Date: May 2009
Location: london ontario
Posts: 542
Its been fine for the last couple of weeks, I think yesterday was the first time I opened the trunk.
fitter527 is offline   Reply With Quote
Old 10-29-2013, 04:04 PM   #13
Jon@Bimmersport
MaXsponsor
 
Jon@Bimmersport's Avatar
 
Join Date: Apr 2002
Location: Mississauga
Posts: 13,783
Check the battery terminal in the engine bay where you boost it from. It is wired directly to the starter and alternator I beleive, and corrodes there just like how dbworld2k said.
__________________

Authorized Ontario dealer for Active Autowerke|VF-Engineering|[/color]ESS TuningAFE|Bilstein Suspension|H&R Suspension|KW suspension|Brembo Brake Systems| Stoptech| - Call us for the best pricing please DO NOT PM in regards to pricing

Maintenance|Performance|Tuning & Forced Induction
Jon@Bimmersport is offline   Reply With Quote
Old 10-29-2013, 04:05 PM   #14
dbworld4k
Addict
 
dbworld4k's Avatar
 
Join Date: Aug 2006
Location: YYZ / ORD
Posts: 7,270
my car is allergic to the beer store

4k, damnit.

4k!!!!!!!!!
__________________


'02 ///M5 Imola Red / Imola Red '09 335i Alpine White / Coral Red

Past:
'04 E55 AMG Brilliant Silver / Anthracite
'96 318i Alpine White / Black
'01 330Ci Titanium Silver / Coral Red
'96 328i Jet Black / Black
dbworld4k is offline   Reply With Quote
Old 10-29-2013, 04:54 PM   #15
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,731
Send a message via MSN to propr'one
Quote:
Originally Posted by t.dot_e30 View Post
you need a new mechanic.
q.f.t.
__________________
I run a canadian HID kit company, if you have any questions about hid kits in canada or would like to check out our products please contact me here: http://absolutehid.ca

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
propr'one is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:59 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014