Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-19-2013, 07:02 PM   #1
aviator
3rd Gear Member
 
Join Date: Aug 2013
Location: Toronto
Posts: 430
Radio issue

Ok so I tried a search with no joy

the issue is the radio will not turn on... fuse appears to be good as best I can tell [I did'nt have my meter with me]. The radio antenna is missing so IK the tuner won't work but AFAIK it should still turn on and be able to play tapes...
yes it is the factory AM/FM/Cassette. Anybody got any ideas?
aviator is offline   Reply With Quote
Old 10-19-2013, 09:42 PM   #2
TSI
Reverse Gear Member
 
Join Date: Aug 2011
Location: Oakville
Posts: 747
What model? When you say not turning on--is it even getting power? Did you check that all connections are good? Fuse 21 ok too?
TSI is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.