Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-30-2013, 12:00 AM   #1
nickpetra535
2nd Gear Member
 
Join Date: Apr 2013
Location: Ottawa, Ontario
Posts: 76
E34 535i signal light stuck on

Ok so, I've had my 535i for a few months now and i recently had to replace the front signal light bulbs. After changing the bulbs my passenger side signal lights stay solid all the time (do not flash) if the day time lights or low beams are on. If my light switch is all the way down (off) it doesn't do this and all signals work fine. Its weird and annoying because now i don't want to drive it at night because i cant signal.. If anyone knows what this might be then please any help would be appreciated.
nickpetra535 is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:06 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.