Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-08-2013, 06:32 PM   #1
BMe30
all by chance...
 
BMe30's Avatar
 
Join Date: Mar 2008
Location: mississauga
Posts: 819
Tre fuel pump install...



Making the opening bigger...




More to come....
__________________

Gone but not forgotten
BMe30 is offline   Reply With Quote
Old 03-08-2013, 07:55 PM   #2
BMe30
all by chance...
 
BMe30's Avatar
 
Join Date: Mar 2008
Location: mississauga
Posts: 819


So thats how much i had to open it up to fit the new pump.

No more pics after this bc i just wanted it in and running lol

And it does run... And holy super rich!

I started lowering my values on idle started at 11afr to 14.7afr
Did the same for low load..
Need a little more time on high load..

But here is my issue.. At WOT im showing 10afr steady throughout the rpm. I dropped the values through the rev range from 190-255 to 90 through the rev range to see for a good starting point. Still during WOT 10afr

Any ideas?
__________________

Gone but not forgotten
BMe30 is offline   Reply With Quote
Old 03-08-2013, 07:56 PM   #3
BMe30
all by chance...
 
BMe30's Avatar
 
Join Date: Mar 2008
Location: mississauga
Posts: 819
Fyi.. Itb's with s52 injectors, tuning with tunerpro
__________________

Gone but not forgotten
BMe30 is offline   Reply With Quote
Old 03-08-2013, 08:14 PM   #4
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,168
The fuel pump shouldn't affect your mixture. If it is, you need a better pressure regulator, fixing it with tuning is a bandaid and will never be right.
__________________
BigD is offline   Reply With Quote
Old 03-08-2013, 08:37 PM   #5
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,607
Nice pump. An aftermarket FPR that's adjustable may help your situation and tuning options
__________________

cormier is online now   Reply With Quote
Old 03-09-2013, 12:05 PM   #6
BMe30
all by chance...
 
BMe30's Avatar
 
Join Date: Mar 2008
Location: mississauga
Posts: 819
Im going to put the stock injectors back in and go from there. If im getting the same issue then ill look into replacing the fpr
__________________

Gone but not forgotten
BMe30 is offline   Reply With Quote
Old 03-12-2013, 06:47 PM   #7
BMe30
all by chance...
 
BMe30's Avatar
 
Join Date: Mar 2008
Location: mississauga
Posts: 819
i installed the new wideband sensor. took it for a boot and to my suprise the "stock" bin file was showing 12s afr at wot. i copied some of the timing maps from my previous tunes. i need to smooth out some of the low and high load maps.

all in all it looked like all i needed was a new fuel pump. TRE 240 same as the walbro 255L/hr pump.

just a quick thanks to Rocco from RMP for suggesting to put the stock injectors in to solve the high fuel issue.
__________________

Gone but not forgotten
BMe30 is offline   Reply With Quote
Old 03-15-2013, 09:05 AM   #8
The Twin
3rd Gear Member
 
The Twin's Avatar
 
Join Date: Feb 2011
Location: ontario
Posts: 559
is that a french mustache tatoo on the index finger of your right hand?

if so, incredible.
The Twin is online now   Reply With Quote
Old 03-15-2013, 10:13 AM   #9
BMe30
all by chance...
 
BMe30's Avatar
 
Join Date: Mar 2008
Location: mississauga
Posts: 819
Quote:
Originally Posted by The Twin View Post
is that a french mustache tatoo on the index finger of your right hand?

if so, incredible.
Lol its on my buddy's hand. Like me he likes getting his hands dirty. Also we were doing this in his machine shop so i guess he felt it was his job to shave the metal lol
__________________

Gone but not forgotten
BMe30 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:50 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014