Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-04-2012, 09:56 PM   #1
asl
1st Gear Newbie
 
Join Date: May 2012
Location: gta
Posts: 7
Intermitant noise from under passenger side

Need help with this one. (1995 bmw 325is manual)
Install new blistien sport all round with springs, new rotars and pads all around and also ebrake line and pads,front m3 bushing.
I sometimes hear a knocking , ratteling then Knocking noise from under the front passenger side,it also sounds like something is loose and noise sometimes move under the gearbox(might be due to vibration ). feels like something got broken when i drove over a dump in my driveway.
the noise is off and on not consistant.
asl is offline   Reply With Quote
Old 12-30-2012, 07:05 PM   #2
JBB
1st Gear Newbie
 
Join Date: Dec 2012
Location: Toronto
Posts: 29
Did u ever find out what it was?
JBB is offline   Reply With Quote
Old 12-30-2012, 08:22 PM   #3
asl
1st Gear Newbie
 
Join Date: May 2012
Location: gta
Posts: 7
Yes. The ebrake pin on the passanger rear side rim was lose.
asl is offline   Reply With Quote
Old 12-30-2012, 08:57 PM   #4
JBB
1st Gear Newbie
 
Join Date: Dec 2012
Location: Toronto
Posts: 29
Hmm.
I was curious 'cause I have a similar situation w/ my X3 (e83). Mechanical rattle from rear pass. side wheel when going over speed bumps. Had it looked at twice, can't find anything ...
JBB is offline   Reply With Quote
Old 12-30-2012, 09:51 PM   #5
asl
1st Gear Newbie
 
Join Date: May 2012
Location: gta
Posts: 7
Investigate your ebrake cable line . This was also my problem
Hope this helps you.
asl is offline   Reply With Quote
Old 12-30-2012, 11:24 PM   #6
JBB
1st Gear Newbie
 
Join Date: Dec 2012
Location: Toronto
Posts: 29
Thx asl, I'll look into that.
JBB is offline   Reply With Quote
Old 01-18-2013, 09:55 PM   #7
BmW1819
6th Gear Member
 
Join Date: Feb 2007
Location: Pickering
Posts: 2,832
Coil spring broken??
BmW1819 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:49 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014