Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-06-2012, 12:15 PM   #1
syedali
2nd Gear Member
 
Join Date: May 2010
Location: Toronto
Posts: 54
Exclamation Urgent - Need mechanic today - Mon Aug 06 - Any recommendations?

Two weeks ago, my car (2004 325i) won't start on my way back from grocery shopping. Stuck in middle of grocery parking, I had it towed to the nearest mechanic, who said he specializes in Audi, BMW, and Mercedes. He said its the starter, kept the car for a day and replaced that.

It ran for a week and then exact same thing happened to me where it wont crank.

I pushed the car a little, popped the clutch, and drove immediately to the same mechanic as I believe he owed me for the crappy work he had done.

This time he said its the fuel pump and had me change that.

Lo and behold 1 week after replacing my fuel pump I am stuck again with same problem !!

Is there anyone reliable open today that I can take the car to. I have already taken too much time off work to deal with the car issue and cant really afford to take more days off.

Last edited by syedali; 08-06-2012 at 01:53 PM.
syedali is offline   Reply With Quote
Old 08-06-2012, 12:28 PM   #2
dbworld4k
Addict
 
dbworld4k's Avatar
 
Join Date: Aug 2006
Location: YYZ / ORD
Posts: 7,195
I doubt anyone is open today. What shop did you take it to twice? Check the positive terminal inthe engine bay. I had a similar issue once on my car and it was a badly corroded power terminal preventing the start up.
__________________


'02 ///M5 Imola Red / Imola Red '09 335i Alpine White / Coral Red

Past:
'04 E55 AMG Brilliant Silver / Anthracite
'96 318i Alpine White / Black
'01 330Ci Titanium Silver / Coral Red
'96 328i Jet Black / Black
dbworld4k is offline   Reply With Quote
Old 08-06-2012, 01:12 PM   #3
syedali
2nd Gear Member
 
Join Date: May 2010
Location: Toronto
Posts: 54
Quote:
Originally Posted by dbworld4k View Post
I doubt anyone is open today. What shop did you take it to twice? Check the positive terminal inthe engine bay. I had a similar issue once on my car and it was a badly corroded power terminal preventing the start up.
Checked everything I can think off Maybe I can just tow it to Rocco at RMP, and hope he can work on it first thing tomorrow. Wish I can get in touch with him some how - his shop is closed today.
syedali is offline   Reply With Quote
Old 08-06-2012, 01:45 PM   #4
noid
5th Gear Member
 
noid's Avatar
 
Join Date: Dec 2007
Location: Burlington Ontario
Posts: 950
If you can bump start it, my guess would be that it is electrical. Specifically it could be the ground that the starter uses. I had a similar problem with my E30 a few years back.

http://www.rtsauto.com/ground-cable-...-preventative/

Use jumper cables to recreate an alternative ground and see if it fixes your problem.
noid is offline   Reply With Quote
Old 08-06-2012, 01:54 PM   #5
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,877
Ground cable between right side engine mount and frame rail!
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E34 E39 E60 E32 E38 E65 E66 X5 M3 M5


Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is online now   Reply With Quote
Old 08-06-2012, 01:58 PM   #6
syedali
2nd Gear Member
 
Join Date: May 2010
Location: Toronto
Posts: 54
Quote:
Originally Posted by noid View Post
If you can bump start it, my guess would be that it is electrical. Specifically it could be the ground that the starter uses. I had a similar problem with my E30 a few years back.

http://www.rtsauto.com/ground-cable-...-preventative/

Use jumper cables to recreate an alternative ground and see if it fixes your problem.
Quote:
Originally Posted by Eurostyle View Post
Ground cable between right side engine mount and frame rail!
Ah...any pics / diy anywhere :S Is this under the car or can i access it under the hood ?
syedali is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:52 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.