Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Z series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-20-2012, 04:04 PM   #1
preet006
2nd Gear Member
 
Join Date: Jun 2008
Location: TORONTO
Posts: 250
Z4 roof issue

HI all,

my z4 roof seems stuck and wont open, can anyone help me out?

where can i get it fixed and how much will it cost me?

thanks.
preet006 is offline   Reply With Quote
Old 07-20-2012, 04:06 PM   #2
Deep 3.2TL
6th Gear Member
 
Deep 3.2TL's Avatar
 
Join Date: May 2004
Location: Milton
Posts: 3,224
I have a manual roof, so can't help you much, but visit zpost.com - a lot more guys there with Z's that can help.

BTW: It's a common problem. Water gets into the motor causing it to crap out a lot... I think last I read about it, it was in the neighbourhood of $800, but I could be totally wrong... check zpost.
__________________

2007 Z4 3.0si
Deep 3.2TL is offline   Reply With Quote
Old 07-20-2012, 06:13 PM   #3
preet006
2nd Gear Member
 
Join Date: Jun 2008
Location: TORONTO
Posts: 250
This a real stupid question, but is there anyway to just convert it to a manual roof?
preet006 is offline   Reply With Quote
Old 07-20-2012, 11:37 PM   #4
Deep 3.2TL
6th Gear Member
 
Deep 3.2TL's Avatar
 
Join Date: May 2004
Location: Milton
Posts: 3,224
I believe there is a release in the trunk that should allow you to turn into manual. You still need the system to unlock, but once unlocked, you can move it manually.
__________________

2007 Z4 3.0si
Deep 3.2TL is offline   Reply With Quote
Old 07-25-2012, 04:32 PM   #5
preet006
2nd Gear Member
 
Join Date: Jun 2008
Location: TORONTO
Posts: 250
Anyone know where I can get this fixed that wont charge me an arm and leg?
preet006 is offline   Reply With Quote
Old 07-25-2012, 04:33 PM   #6
Deep 3.2TL
6th Gear Member
 
Deep 3.2TL's Avatar
 
Join Date: May 2004
Location: Milton
Posts: 3,224
tried checking with any of the sponsors? RMP, etc, etc...
__________________

2007 Z4 3.0si
Deep 3.2TL is offline   Reply With Quote
Old 07-25-2012, 05:48 PM   #7
azn_oo1
2nd Gear Member
 
Join Date: May 2007
Location: mississauga
Posts: 145
you got 2 motors for the z4 top. one that is for latching and one that opens and closes the top. if its the latching one its easy to access and you would probably fix it yourself. The opening and closing motor on the other hand is a big pain in the ass from the DIY guides.
azn_oo1 is online now   Reply With Quote
Old 07-27-2012, 11:25 AM   #8
preet006
2nd Gear Member
 
Join Date: Jun 2008
Location: TORONTO
Posts: 250
I had someone check it out, they told me it was the hydraulic pump.
preet006 is offline   Reply With Quote
Old 07-27-2012, 11:36 AM   #9
Deep 3.2TL
6th Gear Member
 
Deep 3.2TL's Avatar
 
Join Date: May 2004
Location: Milton
Posts: 3,224
yea - pretty common issue...

There's a Z4 cruise tomorrow if you are interested... I can't make it, but there's a bunch of guys from zpost meeting and taking a 150-200 km drive, stopping at creemore springs for a tour, etc...
__________________

2007 Z4 3.0si
Deep 3.2TL is offline   Reply With Quote
Old 07-28-2012, 07:30 PM   #10
Sim_Sima
The Sims
 
Sim_Sima's Avatar
 
Join Date: May 2002
Location: Hamilton
Posts: 191
Hey I plan on doing a whole DIY soon on this issue. I found lots of links and have friends that work at a local Dealership. I will post a great link but I plan on doing a more extensive guide on the roof repair.

http://www.zpost.com/forums/showthread.php?t=333198

and one more for all BMW owners

http://tis.spaghetticoder.org/

the last one is a great troubleshooter!
Sim_Sima is offline   Reply With Quote
Old 08-08-2012, 12:52 PM   #11
mike519
1st Gear Newbie
 
Join Date: Jun 2012
Location: Waterloo, Ontario
Posts: 16
I am about to replace mine. Picked up the pump and components in the US for $500. They are around $1000 just for the parts here. Installation at a dealer is $800...you maybe get away with half that at an independent.

Do a search for shipkiller'a dIY on replacing it yourself. Very well done.
mike519 is offline   Reply With Quote
Old 08-09-2012, 12:52 PM   #12
preet006
2nd Gear Member
 
Join Date: Jun 2008
Location: TORONTO
Posts: 250
Awesome! Thank you all!!
preet006 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:40 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.