Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-04-2012, 03:10 PM   #1
Noxas
2nd Gear Member
 
Join Date: Jun 2011
Location: Toronto
Posts: 50
Signal problem!

Hey guys last night my signals seemed to have died. Both my left and right turn signals as well as hazards don't come on. On the occasion I can hear the red and left signal turn on but it's only the clicking from the dash... And then it shuts off not to long after( maybe after like a few clicks)?. I havnt been able to see how ever if when it's clicking the lights are actually linking to due the short time.


Any suggestions??
Noxas is offline   Reply With Quote
Old 07-04-2012, 03:27 PM   #2
E30M42cab
Parts Hoarding Specialist
 
E30M42cab's Avatar
 
Join Date: Apr 2006
Location: Milton
Posts: 2,333
I'm guessing your relay is shot.
__________________

Quote:
Originally Posted by richie_s999 View Post
Grow up and move on.
E30M42cab is offline   Reply With Quote
Old 07-04-2012, 03:38 PM   #3
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,361
I'd 2nd that...replace the relay.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is offline   Reply With Quote
Old 07-04-2012, 05:18 PM   #4
Noxas
2nd Gear Member
 
Join Date: Jun 2011
Location: Toronto
Posts: 50
Sorry I should have stated. This is a 325e 1986. I've looke at diagrams for the relays but can't find out which relay its for. Could anyone point me to it?

Fuses are also all good.

Could bad bulbs/ blown bulbs also cause this?
Noxas is offline   Reply With Quote
Old 07-04-2012, 06:24 PM   #5
Noxas
2nd Gear Member
 
Join Date: Jun 2011
Location: Toronto
Posts: 50
Nvm thanks guys. I took the wheel off to chicken the switch and as I was doing so found the relay. Just seems it was loose so everything works swell now. Thanks for the I put
Noxas is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:13 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.