Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-13-2012, 02:12 PM   #1
Redbeard
1st Gear Newbie
 
Join Date: May 2012
Location: Erin
Posts: 3
E46 M3 Hiccups

Driving at steady speed with a neutral throttle, the car momentarily “hiccups” or “bucks”. It is most notable between 80-100kph in 5th or 6th gear (2000-3000 rpm range) but it can be noticed as slow as 60kph in 4th. It doesn’t happen while accelerating or decelerating so the car can be driven around town in traffic without it happening. When out in the country, you can also avoid the problem by keeping the throttle moving – that is, accelerate a bit then decelerate a bit then accelerate again. Totally smooth under hard acceleration.

I have owned the car for a year and this “hiccupping” was always present but quite subtle. It also had an irregular idle from time to time. During the last service, the MAF was cleaned and the bucking became much more pronounced. Start up also became more rough and several times the check engine light has come on during start up (code was always P0102 MAF low input). Once running, the idle was much smoother than before. However, on a few occasions, the engine stalled when coming to a stop and pushing in the clutch.

I cleaned the MAF with no change in behavior then put a new one in and again, no significant change in behavior. Start up isn’t as rough but it still threw a P0102 code.

No other codes except the P0102 code have shown up and the check engine lamp doesn’t come on when the car is bucking. It doesn't feel like a single cylinder misfire - more like "bubbles in the fuel line".

Current thoughts are a fuel pump or fuel pressure regulator on the way out but curious why it works fine under any acceleration, including WOT.

Any ideas?
Redbeard is offline   Reply With Quote
Old 06-14-2012, 10:47 AM   #2
jabela
4th Gear Member
 
Join Date: Apr 2007
Location: Toronto, ON, Canada
Posts: 710
Maybe you have a small vacuum leak? Lots of little tubes in these cars often crack with age.
__________________

2002 E46 325ci // 5spd // ISC N1 Coilovers
www.modernapothecary.ca
jabela is offline   Reply With Quote
Old 06-19-2012, 04:27 AM   #3
honeydew
Don't laugh,it's paid for
 
honeydew's Avatar
 
Join Date: Jun 2012
Location: Brampton, Ontario
Posts: 30
It's definitely your intake at some point. I wouldn't say fuel. Something is disrupting air flow, Is this car completely stock?
honeydew is offline   Reply With Quote
Old 06-20-2012, 11:21 PM   #4
toy4to
1st Gear Newbie
 
Join Date: Oct 2007
Location: Toronto
Posts: 44
I've experienced this before, about 3 yrs ago. I first went through the following:

- replaced all ignition coils
- replaced and gapped all spark plugs
- cleaned MAF with CRC MAF cleaner
- replaced fuel filter
- cleaned all TPS sensors
- replaced fuel pump

I did notice that after the ignition coils were replaced, I no longer had the 2-3k stumbling. How old are your ignition coils on your car?

It is NOT a vacuum leak.
toy4to is online now   Reply With Quote
Old 06-21-2012, 11:48 AM   #5
Ramps
2nd Gear Member
 
Join Date: Apr 2010
Location: Toronto
Posts: 65
It's likely a bad coil.

It's not a vacuum leak or it would start up and idle very rough and uneven.

An intake issue would not cause a "miss" type feeling it would be a consistent power loss.

Last edited by Ramps; 06-21-2012 at 11:51 AM.
Ramps is offline   Reply With Quote
Old 06-21-2012, 02:56 PM   #6
honeydew
Don't laugh,it's paid for
 
honeydew's Avatar
 
Join Date: Jun 2012
Location: Brampton, Ontario
Posts: 30
Quote:
Originally Posted by Ramps View Post
It's not a vacuum leak or it would start up and idle very rough and uneven.
Sorry, I thought he had mentioned it surged at idle. Must have stuck in my head from another thread, apologies.
honeydew is offline   Reply With Quote
Old 06-21-2012, 06:38 PM   #7
Redbeard
1st Gear Newbie
 
Join Date: May 2012
Location: Erin
Posts: 3
Some updates.

M3 Forum guys suggested replacing the throttle position sensor. There are two - one at the end of the throttle shaft (easy to get to) and the other is on the end of the throttle actuator buried under the intake manifold.

I bought a TPS and changed the easy to get to one. No effect. I then dug into it and put the new one on the actuator (replacing the original TPS back to its original spot). About a 2 hour job the first time.

Issue is 99% solved. I've put about 250km on it so far without any jerking. I felt a couple of small hiccups over that time but nothing to be concerned about.

The start up issue is still there and yes, it can hunt at idle but not always. My guess for that is the idle air valve needs cleaning. Of course, I was right there when I had the intake off but didn't have any spare hose clamps. All the hoses looked OK. Will research that a bit more before doing that.
Redbeard is offline   Reply With Quote
Old 06-25-2012, 03:52 PM   #8
King Luis
The King.
 
King Luis's Avatar
 
Join Date: May 2003
Location: Milton
Posts: 7,380
Send a message via MSN to King Luis
i'd go with coil packs first if they haven't been replaced.

i don't listen to the m3f e46 section anymore.
__________________
Current:2013 Candy White VW Golf TDI
Mods: TBD.

Sold:2004 Silver Gray M3
Mods: Dice Unit, EAS Angel Eyes, Painted Reflectors, CSL Diffuser, Smoked Corners, PSS10s, 15mm Front and 10mm Rear Spacers.

Gone:1990 Brilliantrot 325is
Mods: Alpine speakers and HU, Euro Projectors, Magnaflow Muffler, Euro Smoked Tails and GC Coilovers.
King Luis is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:42 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.