Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-11-2012, 12:37 AM   #1
rider-.
3rd Gear Member
 
Join Date: Jun 2008
Location: mississauga
Posts: 499
Gas mileage!!! WTF HELLPPP

Hey guys,

So let me start by giving a brief description of my issue.

My mileage is getting kinda high now, in the upper end of the 100k's and I have been getting horrible gas mileage for a while now. I have been avging about 13L/100km in my 04 320i, I dont know if the car thinks its an m3 or something, but that mileage aint right! I used to avg around 8/9 but now its getting ridiculous.

So now trying to figure out whats wrong, I've begun replacing things in order of ease and price.

I've changed:
MAF
Fuel Filter
Spark Plugs
Injectors

What else is left?!

My engine is not burning a drop of oil, so im assuming its not blown. The car throws absolutely no codes related to the fuel mix (only throws code for 2 post cat o2 sensors which have been deleted for ebay headers, but i have now switched back to OEM Headers.)

Am I missing something?????

I've searched around to see if anyone has had similar issues, the only thing left on the list is Vanos really, I have not serviced it as of yet. Does Vanos affect fuel mileage that much? I'm guessing my Vanos has gone bad, seeing other threads saying after 70k Vanos is undoubtedly in need of service.

What is the site for those aftermarket vanos service kits that are supposed to be better than oem?

Thanks guys
__________________
rider-. is offline   Reply With Quote
Old 04-11-2012, 01:15 AM   #2
KIRASIR
Your Nightmare
 
KIRASIR's Avatar
 
Join Date: Dec 2001
Location: TO
Posts: 1,753
Get lighter shoes!

all jokes aside

Tire pressure
O2 sensors
air filter
CCV
look for vacuum leaks

If Vanos unit isn't making any noise I wouldn't worry too much about it.
__________________

KIRASIR is offline   Reply With Quote
Old 04-11-2012, 01:23 AM   #3
EuroSpec_92
MPOWER
 
EuroSpec_92's Avatar
 
Join Date: Apr 2010
Location: Mississauga
Posts: 348
try measuring how far your actually getting to a tank and not the computers avg mpg, then start questioning
__________________

99 Estoril M3
EuroSpec_92 is offline   Reply With Quote
Old 04-11-2012, 08:03 AM   #4
andrew.k
Top Gear Professional
 
andrew.k's Avatar
 
Join Date: Oct 2010
Location: Pickering
Posts: 166
To answer your question, a faulty vanos will lead to less power & worse fuel economy.

I would start off with addressing that if you haven't dealt with it yet.

Go here to order your parts. - The explanation is all there. Take a second to read.

http://www.beisansystems.com/
__________________
330i | M Technik | BBS 197 | 3D Studie | H&R
andrew.k is offline   Reply With Quote
Old 04-13-2012, 08:09 AM   #5
Renboy
3rd Gear Member
 
Join Date: Sep 2010
Location: Guelph, Ont.
Posts: 318
Cold weather and short trips definitely take their toll also. Have you changed driving habits? I went from 8 to 10.5L/100kms just because I went to very short trips in city and 0 highway kms.

If you're getting 13L/100kms on the highway...in a 320...then there's something very, very wrong. BUT, don't just throw money at the problem hoping it will resolve it. If your thermostat isn't closing, that will kill fuel economy, so will a 300lbs sub/amp in the trunk. Find out what the problem is first.
Renboy is offline   Reply With Quote
Old 04-13-2012, 08:14 AM   #6
slemmer
Driving in the fast lane
 
slemmer's Avatar
 
Join Date: Dec 2002
Location: Missed in 'sauga
Posts: 2,978
Yeah, my 4.4 is getting about 9.4 l/100 and that's cruising at a steady 125 kmh. I'd ignore the computer and do a test with a full tank run it the refill tank and check the odometer to get another opinon. You're not smelling any gas around the engine or tank are you? Just trying to rule out a possible fuel leak.
__________________

'04 645cic
'05 GMC Sierra SLT Z71 CCSB 4x4
'02 Regal LS
'00 740i Sport
slemmer is offline   Reply With Quote
Old 04-13-2012, 11:38 AM   #7
jabela
4th Gear Member
 
Join Date: Apr 2007
Location: Toronto, ON, Canada
Posts: 709
My 2002 325ci 5sd gets 7L/100km at 100kph, in the city, I get around 9-10L/100km depending on how I drive.
Some things to ponder...
What oil are you using? Hopefully BMW Castrol or Mobil 1 0w40.
Do you have an automatic or manual gearbox?
What tires do you have? wider, softer tires = lower mpg.
Have you checked each wheel to make sure it spins freely when spun? You could have a sticky caliper.
What fuel are you using? Non-premium fuel will reduce your fuel efficiency. So will using gas with ethanol in it. For best efficiency, use Shell 91. I think it's the only fuel in Ontario without ethanol. Ethanol has about 34% less energy than gasoline, so a 10% ethanol fuel will give you around 3% less efficiency.
Have you changed your oil recently?
Have you changed your engine air filter recently?
Has your car had its inspection II recently?
What is your tire pressure set at?
What's your mix of highway to city driving?
Have you checked for vacuum air leaks, especially in the intake boot/elbows? If you have never changed them, then you can pretty much guarantee that the intake is leaking. The dead giveaway is a whistling sound, but it doesn't always show up.
Here's some info to help you out.
Part #6 is the main culprit, though many of the smaller hoses can also deteriorate.
http://www.realoem.com/bmw/showparts...05&hg=13&fg=15
http://www.e46toronto.ca/forums/show...-intake-wistle!

Here's what mine looked like
__________________

2002 E46 325ci // 5spd // ISC N1 Coilovers
www.modernapothecary.ca
jabela is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:44 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.