Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-10-2012, 12:37 PM   #1
jmack
2nd Gear Member
 
Join Date: Mar 2009
Location: Trent Hills
Posts: 191
540 catalytic converters failing?

Hey guys,

Wondering if anyone has replaced the cats in their 540 and why... A couple weeks ago the car died on me after a half-hour trip, it would start, then die right away. Seemed to be getting fuel, spark, etc, but would just crap out at idle. I could keep it 'going' with foot on the gas, but that didn't really get me anywhere.

After getting it towed home I can start it and it will run, albeit somewhat weakly with a lower than normal idle, would dip to 400-300 and sometimes less. I haven't been driving it at all as I am fearing getting stuck again.

Listening at the rear exhaust you can hear a pronounced vibration that comes and goes, comes and goes.

Does this sound like a clogged or otherwise toasted cat(s)?
jmack is offline   Reply With Quote
Old 04-10-2012, 12:37 PM   #2
jmack
2nd Gear Member
 
Join Date: Mar 2009
Location: Trent Hills
Posts: 191
Also no codes.
jmack is offline   Reply With Quote
Old 04-10-2012, 12:55 PM   #3
Quack
Wheelman
 
Quack's Avatar
 
Join Date: Jul 2002
Location: Toronto
Posts: 12,058
Send a message via MSN to Quack
sounds like it, I had a 98 540, when I bought it the cats were clogged, couldn't do hard acceleration, and would stall out sometimes after driving for 30 mins, also eating lots of fuel, was only getting 300-400km per tank, I had them cut out & replaced with hi-flow cats, car was fine after they were replaced.
__________________

Maxbimmer Drama, You Gotta Love It
Quack is online now   Reply With Quote
Old 04-10-2012, 02:00 PM   #4
jmack
2nd Gear Member
 
Join Date: Mar 2009
Location: Trent Hills
Posts: 191
Thanks, what cats did you go with? And I am correct that there are 4 that need to be dealt with or did you only replace the rear 2?
jmack is offline   Reply With Quote
Old 04-10-2012, 03:09 PM   #5
Quack
Wheelman
 
Quack's Avatar
 
Join Date: Jul 2002
Location: Toronto
Posts: 12,058
Send a message via MSN to Quack
well my car is a 98, I think there were only 2 cats, I believe yours has 4, I've replaced them with Brullen hi-flow cats, but the company went belly up many years ago.
__________________

Maxbimmer Drama, You Gotta Love It
Quack is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:50 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.