Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-04-2012, 12:55 PM   #1
jasonbaek
2nd Gear Member
 
Join Date: Jul 2011
Location: Toronto, Ontario
Posts: 175
HELP! No start, no crank.

I just tried to start my car but it wouldn't crank or click whatsoever, nothing happened, and electronics didn't work as well(euro clock kinda works, but it's slow, and I feel no brake boost when I push the pedal) I tried to push start the car so I pushed it a bit, then I got a momentary electric power with battery warning light, then it died right away. Push start didn't work (maybe I didn't push far enough to get it going).. would there be any other issue other than battery?
jasonbaek is offline   Reply With Quote
Old 04-04-2012, 01:07 PM   #2
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,261
Try boosting it first. Sounds like a weak battery. Perhaps you left the lights on? Sometimes the damn trunk light stays on if not properly lined up.
__________________
Woofer is online now   Reply With Quote
Old 04-04-2012, 01:46 PM   #3
lost
2nd Gear Member
 
lost's Avatar
 
Join Date: Feb 2005
Location: Windsor Area
Posts: 285
Quote:
Originally Posted by Woofer View Post
Try boosting it first. Sounds like a weak battery. Perhaps you left the lights on? Sometimes the damn trunk light stays on if not properly lined up.
I agree, sounds like a drained/dead battery.
lost is offline   Reply With Quote
Old 04-04-2012, 02:53 PM   #4
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,605
Jump it and see if it resolves

Or find a bigger hill to push-start :p
__________________

cormier is online now   Reply With Quote
Old 04-04-2012, 06:46 PM   #5
jasonbaek
2nd Gear Member
 
Join Date: Jul 2011
Location: Toronto, Ontario
Posts: 175
Yeah I took battery terminals and gave them a good clean, and re-tightened them..and everything came back to life! But now I need to find out what 4 digit radio code is...I guess I gotta go to the dealership and ask them. Thank you guys!
jasonbaek is offline   Reply With Quote
Old 04-09-2012, 12:48 AM   #6
E30M42cab
Parts Hoarding Specialist
 
E30M42cab's Avatar
 
Join Date: Apr 2006
Location: Milton
Posts: 2,333
Flip through every booklet in your glove box. There's a good chance someone wrote the code down in your owners manual... and it's 5 digits.
__________________

Quote:
Originally Posted by richie_s999 View Post
Grow up and move on.
E30M42cab is offline   Reply With Quote
Old 04-09-2012, 06:22 AM   #7
e30tOny
k-man
 
e30tOny's Avatar
 
Join Date: Oct 2011
Location: joliette
Posts: 226
Quote:
Originally Posted by E30M42cab View Post
Flip through every booklet in your glove box. There's a good chance someone wrote the code down in your owners manual... and it's 5 digits.
.....hmmmm,.....how was the vacation?
__________________
...........................
e30tOny is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:02 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.