Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-01-2012, 12:44 PM   #1
Pediatrick
1st Gear Newbie
 
Join Date: Jan 2012
Location: Calgary
Posts: 14
No interior lights

I just got into my first e30. I have fixed many issues already but I don't know where to start with the interior lights. Anybody have experience troubleshooting these?


---
I am here: http://maps.google.com/maps?ll=50.969381,-113.959429
Pediatrick is offline   Reply With Quote
Old 02-01-2012, 12:59 PM   #2
egye30
3rd Gear Member
 
egye30's Avatar
 
Join Date: May 2011
Location: Hamilton, ON
Posts: 509
Send a message via MSN to egye30
care to elaborate? no light comes on at all? sounds like you may have a blown fuse or something, have you checked your fuses?
__________________

1990 325i Sterling Silver Metallic/Black leather.
M52B28 OBD-I W/ S52 Cams, M50 Manifold, SS Headers, Short ram intake, Stage 2 clutch w/ 14lb flywheel, Mark D chip tune.
Bilstein Sports with Eibach Pro springs + E90 drop hats, F+R Strut bars, '04 330ci Steering rack (3.0 Lock to lock, 13:1)
Custom Built BBS RS's 16x8 square.
egye30 is offline   Reply With Quote
Old 02-01-2012, 01:06 PM   #3
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,744
Check the switch that's on the actual dome light to start. There's 3 positions, off, always on, and on when doors are open. Check both lights. If neither work, check the bulbs. If bulbs are good then check fuses. If fuses are good then check the switch on the dome light . 12v should be coming to one of the wires (for always on option).
__________________
Bullet Ride is offline   Reply With Quote
Old 02-01-2012, 01:12 PM   #4
Pediatrick
1st Gear Newbie
 
Join Date: Jan 2012
Location: Calgary
Posts: 14
No light comes on at all. I tested for power and no power. Which fuse should I look for. Thank you for your prompt responses
Pediatrick is offline   Reply With Quote
Old 02-01-2012, 01:23 PM   #5
karmatose
164.3ci Of Fury
 
karmatose's Avatar
 
Join Date: Jun 2011
Location: London
Posts: 389
Fuse #27 (30A). Also check 6(7.5A), 19(7.5A) and 21(7.5A).

Last edited by karmatose; 02-01-2012 at 01:27 PM. Reason: Added fuse values.
karmatose is offline   Reply With Quote
Old 02-01-2012, 01:31 PM   #6
Pediatrick
1st Gear Newbie
 
Join Date: Jan 2012
Location: Calgary
Posts: 14
You got it. I'll post back after lunch
Pediatrick is offline   Reply With Quote
Old 02-01-2012, 03:19 PM   #7
Pediatrick
1st Gear Newbie
 
Join Date: Jan 2012
Location: Calgary
Posts: 14
All fuses good still no power to lights


---
I am here: http://maps.google.com/maps?ll=50.969203,-113.959629
Pediatrick is offline   Reply With Quote
Old 02-01-2012, 03:29 PM   #8
voluted
2nd Gear Member
 
voluted's Avatar
 
Join Date: May 2009
Location: Richmond Hill, Ontario
Posts: 230
All that's left is to check the wiring then. I had a split wire for my passenger dome light near the bottom of the B pillar which seemed like a weird spot for that wire to fatigue.
voluted is offline   Reply With Quote
Old 02-01-2012, 03:30 PM   #9
Carib
1st Gear Newbie
 
Join Date: Sep 2011
Location: Vancouver, BC
Posts: 12
Could be the bulbs are burnt out. The lights on my instrument cluster and HVAC panel were all burnt out. Replaced all of them and everything was okay. This was more than a year ago and the bulbs are still going. I guess the previous owner(s) didn't bother to replace any of them.
Carib is offline   Reply With Quote
Old 02-01-2012, 03:33 PM   #10
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,744
This should help
Attached Images
File Type: jpg dome lights.jpg (279.5 KB, 100 views)
__________________
Bullet Ride is offline   Reply With Quote
Old 02-01-2012, 04:17 PM   #11
Pediatrick
1st Gear Newbie
 
Join Date: Jan 2012
Location: Calgary
Posts: 14
I'll have a look at the wiring tonight. Thanks for all your help
Pediatrick is offline   Reply With Quote
Old 02-01-2012, 05:34 PM   #12
Pediatrick
1st Gear Newbie
 
Join Date: Jan 2012
Location: Calgary
Posts: 14
could this wire be there source of my problem? Found it on the a pillar door wiring.


---
I am here: http://maps.google.com/maps?ll=50.969346,-113.960373
Pediatrick is offline   Reply With Quote
Old 02-02-2012, 04:04 PM   #13
Pediatrick
1st Gear Newbie
 
Join Date: Jan 2012
Location: Calgary
Posts: 14
Anybody? Been looking through the Internet but still have not found any solutions. I will be working on it tonight but don't know where to start.
Pediatrick is offline   Reply With Quote
Old 02-02-2012, 04:36 PM   #14
E30M42cab
Parts Hoarding Specialist
 
E30M42cab's Avatar
 
Join Date: Apr 2006
Location: Milton
Posts: 2,333
What lights are out exactly?

Just dome? Just console/cluster?

If you're talking about the gauge and console lights, it could be the headlight switch. There is a dimmer on it (turn headlight knob side to side), and if the dimmer quits, so do all the interior lights that run off that dimmer (dome lights are usually not affected) will not turn on at all. Does your radio work? If you think you want to try different headlight switches, there are at least three different designs that BMW used over the years. Remove yours and take it with you when hunting down a replacement.

If you're talking about the dome lights, the switch on the door jamb is usually the culprit... shitty rusted ground or sticky switch.
__________________

Quote:
Originally Posted by richie_s999 View Post
Grow up and move on.
E30M42cab is offline   Reply With Quote
Old 02-02-2012, 04:49 PM   #15
Pediatrick
1st Gear Newbie
 
Join Date: Jan 2012
Location: Calgary
Posts: 14
Thanks for the reply. I was referring to the dome lights. I'll pull it off and check it out ASAP. Do you think that broken wire has anything to do with it?
Pediatrick is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:28 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014