Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E90/E91/E92/E93
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-04-2012, 11:30 AM   #1
duaux
1st Gear Newbie on a BMW
 
Join Date: Jul 2010
Location: .
Posts: 87
Question Check Engine Light + Check OK

I got an "Engine Light Symbol" yesterday, shortly (1km) after I started up my car to head home from work. The car "seems" to be driving fine as I don't notice anything different. e.g., no loss in performance, etc.

A) I am assuming this is a check engine light? (Fixed Dash Symbol)
B) But, I am also confused as the diagnostic check comes up as "CHECK OK" (Variable Dash Section)

The light is still on the dash this morning when I started the car. I drove the car to work anyways...

Any suggestions and/or experience?
Should I be taking my E90 to an mechanic to scan ASAP?

Thanks.
duaux is online now   Reply With Quote
Old 01-04-2012, 11:37 AM   #2
Dinanstu
3rd Gear Member
 
Join Date: Dec 2011
Location: Toronto, Canada
Posts: 317
You need to get the codes from an OBD II scanner (mechanic or friend)
No loss of performance could be just an emissions issue (oxygen sensor)
...but get the code...
Dinanstu is offline   Reply With Quote
Old 01-04-2012, 12:11 PM   #3
duaux
1st Gear Newbie on a BMW
 
Join Date: Jul 2010
Location: .
Posts: 87
Can any OBDII scanner work or do I need one that is specialized for BMW and/or more specifically the E90?
duaux is online now   Reply With Quote
Old 01-04-2012, 01:29 PM   #4
Dinanstu
3rd Gear Member
 
Join Date: Dec 2011
Location: Toronto, Canada
Posts: 317
Any OBD II scanner.
You will have to search the error code, or post it here to get a reply. The scanner can reset it too.
Dinanstu is offline   Reply With Quote
Old 01-04-2012, 02:42 PM   #5
duaux
1st Gear Newbie on a BMW
 
Join Date: Jul 2010
Location: .
Posts: 87
Hey Dinatsu

Thanks for replying. I will update this thread once I get it sorted out.

FYI: I also tried tightening the gas cap (as someone suggested).
Regardless, if I buy a scan-tool, or bring it to an indie I will update.

I am looking at the PEAKE tool right now... I will most likely buy the tool regardless for any future errors/etc.
duaux is online now   Reply With Quote
Old 01-04-2012, 09:21 PM   #6
SamE30e
6th Gear Member
 
SamE30e's Avatar
 
Join Date: Jul 2007
Location: Milton
Posts: 2,870
Quote:
Originally Posted by duaux View Post
I got an "Engine Light Symbol" yesterday, shortly (1km) after I started up my car to head home from work. The car "seems" to be driving fine as I don't notice anything different. e.g., no loss in performance, etc.

A) I am assuming this is a check engine light? (Fixed Dash Symbol)
B) But, I am also confused as the diagnostic check comes up as "CHECK OK" (Variable Dash Section)

The light is still on the dash this morning when I started the car. I drove the car to work anyways...

Any suggestions and/or experience?
Should I be taking my E90 to an mechanic to scan ASAP?

Thanks.
The Check Engine light is for diagnostics of the powertrain in the vehicle. The Check control system checks lights, and maintenance items. Two different systems, with two different functions. I would take the car to a dealership to be properly diagnosed.
__________________
91 318is - M50NV (gone)
02 WRB Subaru WRX EJ207 forged, 320 AWHP stock turbo.
85 - 325
02 325i Sedan
SamE30e is offline   Reply With Quote
Old 01-05-2012, 12:47 AM   #7
sexxxybimmer
3rd Gear Member
 
Join Date: May 2003
Location: Toronto
Posts: 364
Quote:
Originally Posted by duaux View Post
I got an "Engine Light Symbol" yesterday, shortly (1km) after I started up my car to head home from work. The car "seems" to be driving fine as I don't notice anything different. e.g., no loss in performance, etc.

A) I am assuming this is a check engine light? (Fixed Dash Symbol)
B) But, I am also confused as the diagnostic check comes up as "CHECK OK" (Variable Dash Section)

The light is still on the dash this morning when I started the car. I drove the car to work anyways...

Any suggestions and/or experience?
Should I be taking my E90 to an mechanic to scan ASAP?

Thanks.
Same thing happend to me last week, Engine light was on + System check ok, i went to the Bmw Dealer but there were close so i drove it like that, after two days the engine light wasnt there but i still toke it the dealer, he said there is miss fire and he had to change the something i forgot lol sorry some wire shit if u still need to know let me know i check the paper. i hope this help
Kevin
sexxxybimmer is offline   Reply With Quote
Old 01-05-2012, 06:36 AM   #8
Dinanstu
3rd Gear Member
 
Join Date: Dec 2011
Location: Toronto, Canada
Posts: 317
If it's the gas cap or some other small technical glitch that has since resolved itself, it takes a few restarts without the error to clear the yellow indicator. I don't see any reason to rush to the dealer on the first yellow "go to dealer light".
Using the scanner can help you get some idea of what the car is doing and help you understand about it when it has to be fixed.
If you find the car is running poorly, take it to your mechanic/dealer - but keep track of what is being fixed so you can learn from it.
Dinanstu is offline   Reply With Quote
Old 01-05-2012, 08:38 AM   #9
duaux
1st Gear Newbie on a BMW
 
Join Date: Jul 2010
Location: .
Posts: 87
Hey guys, thanks for being active.

Update:
Since tightening my gas cap yesterday... I drove home with the check engine light still on for the whole commute (approx 50 KM). This morning, my car started up without the engine light and it remained off for my ride into work.
Fingers crossed, I am hoping that it was only a "loose" cap issue.

I am still planning to buy the scan tool just so that I will know what error at the minimum for the future.

@Sexxybimmer
No rush, but if you can post a scan of your dealer bill (edit out your personal info) or just provide additional details that would be great for the community. e.g., allow others to search/see, details of the repair, costs, etc.
duaux is online now   Reply With Quote
Old 01-05-2012, 09:53 AM   #10
Dinanstu
3rd Gear Member
 
Join Date: Dec 2011
Location: Toronto, Canada
Posts: 317
I'm glad it worked out for you.
Dinanstu is offline   Reply With Quote
Old 01-05-2012, 10:59 AM   #11
duaux
1st Gear Newbie on a BMW
 
Join Date: Jul 2010
Location: .
Posts: 87
I'm not too excited yet... if I drive home tonight without it, I will be more relieved then...
duaux is online now   Reply With Quote
Old 01-05-2012, 06:16 PM   #12
sexxxybimmer
3rd Gear Member
 
Join Date: May 2003
Location: Toronto
Posts: 364
Quote:
Originally Posted by duaux View Post
Hey guys, thanks for being active.

Update:
Since tightening my gas cap yesterday... I drove home with the check engine light still on for the whole commute (approx 50 KM). This morning, my car started up without the engine light and it remained off for my ride into work.
Fingers crossed, I am hoping that it was only a "loose" cap issue.

I am still planning to buy the scan tool just so that I will know what error at the minimum for the future.

@Sexxybimmer
No rush, but if you can post a scan of your dealer bill (edit out your personal info) or just provide additional details that would be great for the community. e.g., allow others to search/see, details of the repair, costs, etc.
It cost me $50+tax bc i have extended warranty , but i asked them if i didnt have the warranty how much would be ? he said around $400 to $450
sexxxybimmer is offline   Reply With Quote
Old 01-05-2012, 09:45 PM   #13
duaux
1st Gear Newbie on a BMW
 
Join Date: Jul 2010
Location: .
Posts: 87
Update:
Bad news... the light came back on.

My Research:
1. Drove into Partsource and had them run a OBD-II scan. (FYI - it is free)
2. Checked the code: P1553
3. BMW FC Code: 2A99 [Engine Position System 'B' Performance (Bank1)]
4. Searched the internet... seems to be related to the following...
a) Camshaft Sensors (2x in total for E90, intake and exhaust)
b) VANOS Solenoids (2x in total for E90, intake and exhaust)

Now, from what I am reading, "dirty" VANOS Solenoids can cause fault codes for the Camshaft Sensors. It was noted from BMW bulletin that it should be clean using "air hose" and then reinstall. Other users on the internet seem to be confirming similar treatment when they brought it into the dealer.

My Approach:
1. Take the cheap route first... I will try and clean the solenoids this Saturday. Hopefully that would fix it.
2. ???

Good news is... the parts are not too expensive and it looks like a DIY'er.

I will update for those interested.
duaux is online now   Reply With Quote
Old 01-05-2012, 11:33 PM   #14
razor_ro
1st Gear Newbie
 
Join Date: Feb 2011
Location: Ontario, Canada
Posts: 14
this exact same thing happend to me,... it was my "VANOS Solenoid" sensor... it only cost me $50 to fix due to my extended warranty or else just the part alone was almost ~$500...
razor_ro is offline   Reply With Quote
Old 01-06-2012, 08:41 AM   #15
duaux
1st Gear Newbie on a BMW
 
Join Date: Jul 2010
Location: .
Posts: 87
Sounds expensive... thanks for adding value as it helps others confirm the approximate costs if we were to take it to the dealer.
duaux is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:04 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.