Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-02-2011, 02:36 PM   #1
Bimmerized
In BMW We Trust!
 
Bimmerized's Avatar
 
Join Date: May 2006
Location: London, Ontario
Posts: 225
Send a message via MSN to Bimmerized
Weird electrical problem? Please advise

93 318is

I was driving the other day, and the cluster just went crazy, all the lights came on, the dials were going all the way to the end (similar to the calibration that you can do while holding the reset km button), and went back to normal.

Again today it did the same thing, first it went off, I was doing about 90 and it dropped to zero, all turned off, and then it did the calibrating thing again and went back to normal. This does not affect the drive, doesn't shut off the car, or anything, it looks like just the cluster.

What the hell is going on!?
Bimmerized is offline   Reply With Quote
Old 10-02-2011, 10:08 PM   #2
Daneee
be cool
 
Daneee's Avatar
 
Join Date: Feb 2009
Location: Hamilton
Posts: 350
Send a message via MSN to Daneee
Quote:
Originally Posted by Bimmerized View Post
93 318is

I was driving the other day, and the cluster just went crazy, all the lights came on, the dials were going all the way to the end (similar to the calibration that you can do while holding the reset km button), and went back to normal.

Again today it did the same thing, first it went off, I was doing about 90 and it dropped to zero, all turned off, and then it did the calibrating thing again and went back to normal. This does not affect the drive, doesn't shut off the car, or anything, it looks like just the cluster.

What the hell is going on!?
check the plug behind the cluster
but
this is common problem with the E36
best way is...try an another cluster
__________________
suck the fish
Daneee is offline   Reply With Quote
Old 10-03-2011, 05:25 PM   #3
5style
Hatters gon Hatt
 
5style's Avatar
 
Join Date: Feb 2004
Location: Toronot
Posts: 5,099
Alternator is on its way out, either voltage regulator or diodes, my cluster did the same thing I thought i.was seeing things. The guages would drop to zero and then go to normal without me touching anything. Next the alternator diodes completely died an that was that. I got a rebuild and installed a new regulator I bought, and it stopped
__________________
Cayenne hunting!
5style is offline   Reply With Quote
Old 10-10-2011, 12:34 AM   #4
bmdbley'sBro
wouldu like some tinfoil?
 
bmdbley'sBro's Avatar
 
Join Date: Apr 2005
Location: in your attic!
Posts: 4,643
Quote:
Originally Posted by 5style View Post
Alternator is on its way out, either voltage regulator or diodes, my cluster did the same thing I thought i.was seeing things. The guages would drop to zero and then go to normal without me touching anything. Next the alternator diodes completely died an that was that. I got a rebuild and installed a new regulator I bought, and it stopped


interesting.. that happened to me over the summer..cluster dying for a sec then coming back on..

and i had some belt chirp back then too.. now i hear a belt or pulley chirp for like half a second on 1st cold startup..
__________________
bmdbley'sBro is online now   Reply With Quote
Old 10-10-2011, 10:04 AM   #5
jeffrie
Addict
 
jeffrie's Avatar
 
Join Date: Jun 2004
Location: Buckingham
Posts: 2,251
Belt chirp your talking about is likly the belt tensioner dieing on you.
Common for us 4 pots at the 200K + mark, not hard to change either.
__________________
"They say ignorance is bliss..... I don't know what the Fu*k that means but I'm pretty happy". Ricky Trailer Park Boys.


Current Mods....X-Brace, Stromung Cat Back Exhaust, 17/225/45 M3 Replicas, HotBits Adjustable Coil Overs, 40% LSD 3:91 Diff, E30 Gearbox, Boosted.
jeffrie is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:09 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.