Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-17-2012, 03:39 PM   #76
adam325i
3rd Gear Member
 
adam325i's Avatar
 
Join Date: Feb 2009
Location: Hamilton
Posts: 359
Wow, those lights look awesome man! If you don't mind me asking where did you get them from?

Do you have any pictures of the BC Racing coilovers?

Im looking at getting them, just can't decide on spring rates yet.
__________________
90 325i 4dr Winter fun
90 325i 2dr Summer/track car
87 325i 4dr Parts
adam325i is offline   Reply With Quote
Old 05-18-2012, 01:02 PM   #77
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,239
Quote:
Originally Posted by nonlocal View Post
Interesting, do you have any photos of the installation? How do they look in daylight? Hard to tell from photos but those almost look *too* bright!

My e34 city lights are way too dim though so I am definitely interested in something like this.
I'll take some pics later today.

They are not blinding, at least from what I can tell, but I would much rather them in amber. I have the business card at home. I'll post the guys info. Very nice guy to deal with and very knowledgable.
__________________
Woofer is online now   Reply With Quote
Old 05-18-2012, 01:13 PM   #78
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,239
Quote:
Originally Posted by adam325i View Post
Wow, those lights look awesome man! If you don't mind me asking where did you get them from?

Do you have any pictures of the BC Racing coilovers?

Im looking at getting them, just can't decide on spring rates yet.
Thanks man. The info for the lights will be up later on.

I have 8K front 12K rear (448lb/in and 672lb/in). I don't have pics of the kit uninstalled but check out this guys write up.
http://www.e30tech.com/forum/showthread.php?t=91779

I can take a few pics of the camber plates If you want. I won't be taking the rims off till next weekend when I do the rotors and brakes. I can snap a few shots for you then.

I've only put on about 700-800 kms on the BCs so far. It's still all set to the softest settings. I love it so far, especially on/off highway ramps lol. You won't be disappointed.
__________________
Woofer is online now   Reply With Quote
Old 05-24-2012, 04:31 PM   #79
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,239
Here is the info on the shop that I got the peanut bulbs from.

MTR Lighting & performance
1110 Finch Ave West
Toronto, Ontario
416 548 5707
416 875 4404 cell
Ask for Rad.
__________________
Woofer is online now   Reply With Quote
Old 09-13-2012, 02:10 PM   #80
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,239
Yay or Nay?

Sup guys! My friend has a set of Porsche rims off a 944 for sale. He's trying to sell them to me but I'm on the fence regarding the way they look. Also to fit nice and flush it will need HUGE adapters. I can't remember the rear offset but the front were et65. The rims come with 4x100 to 5x130 20 mm adapters. When I put them on the car the fronts obviously didn't work. I had to use an additional 15mm spacer in the front to clear the struts. It also didn't help that they were mounted on 205/40/16 tires. I wasn't even able to lower the car anymore because I would have no ground clearance. For these to work they would need 205/45/16 tires with a 50-55mm adapter :S lol.

Anyways he convinced me to rock them to the Berlin klassik show last sunday. To see if it would change my mind, but I didn't lol. It was a 60-40 love/hate ratios. Even a few haters sayin,"who puts Porsche rims on a Bimmer?" lol.

Anyways here's a few shots. Let me know what you think. The rims are still for sale if anyone is interested, with 20mm adapters.

Thanks
Alan








Personally, I think these would look sweet on an E30.



Enjoy!
__________________
Woofer is online now   Reply With Quote
Old 09-13-2012, 02:28 PM   #81
frankie591
3rd Gear Member
 
Join Date: Jun 2011
Location: Waterloo
Posts: 440
Car looked great, I didn't really dig the wheels personally.
frankie591 is online now   Reply With Quote
Old 09-13-2012, 04:50 PM   #82
nonlocal
Last of the Late-Brakers
 
nonlocal's Avatar
 
Join Date: Dec 2009
Location: Not here...
Posts: 660
I don't love having all that extra hardware between the wheels and the hub but aesthetically I love this...
__________________
nonlocal is offline   Reply With Quote
Old 09-13-2012, 06:18 PM   #83
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
I saw your car at Berlin Klassik and had to do a double take before I realized it was yours.

I like the look and I think they suit your car. At least they will when they're spaced properly.
defaultName is offline   Reply With Quote
Old 09-13-2012, 09:23 PM   #84
Giormelo
2nd Gear Member
 
Join Date: May 2011
Location: Aurora, ON
Posts: 132
Hey woofer! Ahah I was trying to find your car the whole time on the forum after the bimmer cruise, I have to say I love your car! Keep it up
Giormelo is offline   Reply With Quote
Old 04-10-2013, 04:04 PM   #85
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,239
I haven't updated in awhile because I was going to upload all the work that I had done on the off season.

Unfortunately, my motor decided it was time to go!

I always planned on doing a swap someday but the m20 always ran so well that it felt like a crime to pull it out lol.

Anyways, here's what happened.

So I've always had a really dirty engine bay and I wanted to spruce things up.
Attachment 115770
Attachment 115771
Attachment 115772

We gave it a nice power wash, but I was still not happy.
Attachment 115773
Attachment 115774

So I starting taking some parts off to clean and paint. While I was in there I figured to do the injectors since they were probably the originals from factory.
Instead of opting for stock ones, I slapped in 17lbs m50/s50 injectors( green tops). Got them online soniccleaned and flow tested. They even came with a copy of the flow test. I also installed a m30 Afm that was donated to me by another max member! Thanks clementine.
Since I could now fit a cone style filter I ordered KAMOTORS e30 intake kit. Suppose to be the best one. Honestly nothing beats the air box but I wanted the "cool" intake sound lol.
Attachment 115792
Attachment 115793
Attachment 115794
Attachment 115795



I sand blasted/painted/polished the intake mani, valve cover, throttle body, afm and other brackets in the engine bay.
Here are a few shots of the finished products.
Attachment 115775
Attachment 115776
Attachment 115777
Attachment 115778
Attachment 115779

So now that everything is ready lets put it back together.
Attachment 115780
Attachment 115781
Attachment 115782

Once everything was installed we started it up. Car sounded like a v8 lol. Turns out only 3 cylinders firing, 2-4-6. Nothing was coming out of 1-3-5. After some trial and error we realized that perhaps the injectors weren't getting energized. Checked them out and it turned out we had everything working. There was fuel, air, and spark. Finally we said, " maybe the injectors are faulty?", and sure enough, coincidently, injectors 1-3-5 were ceased. It was the last thing we ruled out because of the stupid flow test certificate they came with. Contacted the seller and after a few emails if him saying its not his fault he said it was probably shipping that damaged them. If I covered shipping he would send another 3. I said forget it and luckily Devon was able to hook me up with a few he had that he didn't need. Thanks man
Cleaned them up, tested all injectors and put them in once confirmed they were good.
Fired it up and we are all good. A bit of a rough idle but straighten up by dialing in the m30 Afm. Let it warm up and Took it for a few spins and noticed that it was burning a bit of oil. Pulled back into the shop and while I was going to back in the rpm shot to 4k for a few seconds. I put the clutch down and the revs went back to normal. Put it in reverse and backed the car in and shut it off. After that it never started again. My dad suspected that perhaps the belt slipped. It was kinda due for one. Checked the valves to see if any bent and everything visually checked out. Checked to see if the motor was still in time and all good.
All puzzled as to why it won't start we did a compression test. Pulled first spark plug and it was covered in oil. Pulled the rest and they were fine.
All cylinders had very low compression. Lowest was cylinder one with 30psi and highest was cylinder 4 with 85psi. The rest were around 50-60 psi. I am assuming that the already weak piston rings gave out. The car ran like a champ last year before I decided to open it up. Last winter I did a tune up consisting of new plugs, wires, rotor and cap, fuel filter etc etc; however, on a cold start it did burn a bit of oil.

I've kinda decided to put the car down this season. I don't really want to swap in another m20. I have a few motors at the shop that may be contenders but don't want to do a rushed swap. Ill take my time and build something up.

On the bright side, I bought an e34 540i/6 for my wife as a parts car. Body needs work but has a solid drivetrain. It's dumped on m pars so it will do for now haha.
Attachment 115788
Attachment 115789

I won't lie, the m60 looks and sounds really nice in an e30 lol.
Attachment 115790
Attachment 115791
__________________
Woofer is online now   Reply With Quote
Old 04-10-2013, 04:09 PM   #86
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,239
Damn iPhone app didn't up load the pics. Ill put them up later.
__________________
Woofer is online now   Reply With Quote
Old 04-10-2013, 04:53 PM   #87
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,239
Pics

Before and after power wash
ImageUploadedByTapatalk1365626218.916677.jpg
ImageUploadedByTapatalk1365626234.868726.jpg
ImageUploadedByTapatalk1365626280.350731.jpg
ImageUploadedByTapatalk1365626317.698509.jpg
ImageUploadedByTapatalk1365626348.532970.jpg

Parts removed
ImageUploadedByTapatalk1365626384.945532.jpg
ImageUploadedByTapatalk1365626404.946681.jpg
ImageUploadedByTapatalk1365626435.811808.jpg
ImageUploadedByTapatalk1365626460.113445.jpg
ImageUploadedByTapatalk1365626486.034309.jpg

Parts prepared for install
ImageUploadedByTapatalk1365626535.330531.jpg
ImageUploadedByTapatalk1365626581.817848.jpg
ImageUploadedByTapatalk1365626605.215236.jpg
ImageUploadedByTapatalk1365626625.841315.jpg
ImageUploadedByTapatalk1365626671.295463.jpg

Engine bay with parts installed
ImageUploadedByTapatalk1365626757.978402.jpg
ImageUploadedByTapatalk1365626774.345456.jpgImageUploadedByTapatalk1365626794.262032.jpg
ImageUploadedByTapatalk1365626814.006623.jpg
ImageUploadedByTapatalk1365626836.525516.jpg
ImageUploadedByTapatalk1365626874.761453.jpg

My 540i/6
ImageUploadedByTapatalk1365626961.498486.jpg
ImageUploadedByTapatalk1365626982.628577.jpg
ImageUploadedByTapatalk1365627003.526222.jpg

What I am contemplating, amongst another ideas lol.
ImageUploadedByTapatalk1365627067.863507.jpg
ImageUploadedByTapatalk1365627082.576626.jpg

In all her glory at DDT
ImageUploadedByTapatalk1365627113.875017.jpg
ImageUploadedByTapatalk1365627136.141454.jpgImageUploadedByTapatalk1365627198.581028.jpg
__________________
Woofer is online now   Reply With Quote
Old 04-21-2013, 02:36 PM   #88
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: Mississauga, ON
Posts: 1,565
Quote:
Originally Posted by Woofer View Post
What I am contemplating, amongst another ideas lol.
Attachment 115835
Attachment 115836
I like
__________________

cormier is online now   Reply With Quote
Old 04-24-2013, 07:29 AM   #89
AdrianL
Live from 42,000'
 
AdrianL's Avatar
 
Join Date: Apr 2011
Location: New Brunswick
Posts: 69
Awesome thread Alan, read through the entire thing. Next two weeks I'm really hoping to be back in town.
__________________
AdrianL is offline   Reply With Quote
Old 07-15-2013, 01:56 PM   #90
Woofer
6th Gear Member
 
Woofer's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 2,239
Thanks Adrian. Still waiting to see your turbo beast!

Here's a little teaser pic. She's been under the knife and almost done. A few hiccups along the way, but almost there.

Ill do a proper update soon.

On a side note, my brown coolant temp sensor(from my m20) will not fit in the head of my m52 as most people say it will. It's too big. My options are to retap the head, which I don't want too do. I can also make the threads smaller on my current m20 sensor OR I found this part number on R3V 1262171-0512 which is suppose to be the correct m20 coolant temp sensor that will screw right into the m52 head. Anyways, any input would e great!
Thanks!

Oh and yes the fender is Red but I was trying out plastidip. Didn't like the way it came out, but it's great for protecting the fenders while working on the car lol. ImageUploadedByTapatalk1373910965.464335.jpg
__________________
Woofer is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:08 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.