Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-24-2011, 03:29 PM   #1
E46Dude
Respect ur Parents.
 
Join Date: Apr 2009
Location: Burlington
Posts: 143
Transmission Warning/Chk Engine

So its been a shitty week so far...On Monday my coolant was leaking on the floor so I took my car to the shop and they found the radiator was gone.

We decided to install a new radiator...which was done yesterday. Now, as soon as the radiator was installed and the car came off the hoist, the Check Engine light came on and the ! mark inside the Transmission box (!P, !D) came on as well.

We tried unplugging the battery and plugged it back in - same thing. The car seems to be going through the gears, its shifting a little rough and the lights dont go away.

None of these lights were there before...and Ive had no issues with the transmission.....Im taking the car for as code read soon but Im wondering if anyone knows what this could be...?


Last edited by E46Dude; 08-24-2011 at 03:42 PM.
E46Dude is offline   Reply With Quote
Old 08-24-2011, 07:29 PM   #2
Jay22
Shadows.
 
Join Date: Apr 2010
Location: Missus-auga
Posts: 118
Did u try disconnecting the battery, then touching the positive and negative, leave it for 30 minutes then reconnect?

That should clear the trip..
Jay22 is offline   Reply With Quote
Old 08-25-2011, 08:38 AM   #3
E46Dude
Respect ur Parents.
 
Join Date: Apr 2009
Location: Burlington
Posts: 143
Nope..havent tried that...but will give it a shot...thanks.
E46Dude is offline   Reply With Quote
Old 08-25-2011, 11:06 AM   #4
Biggie
BMW Power
 
Biggie's Avatar
 
Join Date: Jun 2006
Location: GTA
Posts: 117
Was the car towed at all? Was it running on the hoist with the emergency brakes on by any chance?

Feel your pain. Ran into these issues with my E36 back in the day and nothing pisses me off more than warning lights!
Biggie is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.