Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-10-2011, 02:10 PM   #1
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,607
Need help identifying this 24v harness

See pic -- for use in my s52 swap..

I hate electrical and wires baffle me. This harness came with my s52, only thing is I don't see a diagnostics port-- is this an obd 1 harness?



__________________

cormier is online now   Reply With Quote
Old 08-10-2011, 02:14 PM   #2
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,169
Bigger pics would help. The big plug in the 2nd pic looks like the diag port.
__________________
BigD is offline   Reply With Quote
Old 08-10-2011, 02:18 PM   #3
El Gato Liso
6th Gear Member
 
El Gato Liso's Avatar
 
Join Date: May 2007
Location: Brampton
Posts: 3,124
ya that big one in the second pic is diag. port.

i cut that off my hardness thinking it was for the automatic tranny computer.....since my m50 came from an auto............oops
__________________
R.I.P. E30
El Gato Liso is offline   Reply With Quote
Old 08-10-2011, 02:25 PM   #4
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,607
Thanks for the help guy sorry I was looking for a GM-style plug --

I'm still confused mostly about DME stuff -- stupid question but is a red label 413 compatible with this obd2 motor without a full conversion?
__________________

cormier is online now   Reply With Quote
Old 08-10-2011, 02:40 PM   #5
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,169
Please post bigger pics of the harness, it still looks strange. There should be 3 relays on the fuse box side, and I only see one on the DME side.

The DME is almost fully compatible. The engine is fundamentally the same, just bigger displacement. The only catch is the injector size, so you'll need to get a conversion chip (I had one from Turner).

This is what the harness should look like:


















j/k

here:

__________________

Last edited by BigD; 08-10-2011 at 02:45 PM.
BigD is offline   Reply With Quote
Old 08-10-2011, 02:51 PM   #6
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,607
From photobucket -- sery may be huge lol






There is a triple relay set on the other side of the harness, 2 green 1 orange

Thanks for the DME info ya I'll get the 21.5# tune as long as it'll work
__________________

cormier is online now   Reply With Quote
Old 08-10-2011, 03:03 PM   #7
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,169
Hard to say, I'm tempted to say it's an OBD2 but it still looks odd... can you post a pic of the coil harness? That will tell the tale.

The reason I'm asking is I don't see coil wiring but I also don't see the coil bar. On the OBD2 harness, the coil harness is separate, like so:

__________________

Last edited by BigD; 08-10-2011 at 03:08 PM.
BigD is offline   Reply With Quote
Old 08-10-2011, 03:21 PM   #8
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,607
Ok more pictures:

Are these the relays you're talking about? They're on the other side of my harness but it looks in your picture like they may have been moved from there



The coil portion-- looks like it's attached to me :s



Your harness looks like a lot less than mine too lol I'm guessing it's had a lot removed for the e30... I haven't touched this one yet
__________________

cormier is online now   Reply With Quote
Old 08-10-2011, 03:27 PM   #9
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,169
That's the injector harness. It's an OBD2 harness unfortunately. I can now see the round plug for the coil harness by the DME connector.

The pic I posted is a generic M50 harness, that's how it should look.
__________________
BigD is offline   Reply With Quote
Old 08-10-2011, 03:29 PM   #10
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,607
I also just dug this up, which has obviously been cut... I think I just need a new harness I'm no good with this lol

__________________

cormier is online now   Reply With Quote
Old 08-10-2011, 03:32 PM   #11
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,169
Yeah, that's an OBD2 coil harness, with the plug chopped off for some bizarre reason.

Yeah get another harness. Keep those coils though.
__________________
BigD is offline   Reply With Quote
Old 08-10-2011, 03:33 PM   #12
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,607
Lol ya I think that's my best bet thanks for the info
__________________

cormier is online now   Reply With Quote
Old 08-10-2011, 03:37 PM   #13
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,169
You're welcome. What's your general plan of attack? There isn't much customizing that you need to do on this swap but there is some. If you get a harness adapter, you solve most of it. What's your plan for the temp sender, and tach signal? You know that you need OBD1 sensors right? (obd1 m50 cam, crank, temp for dme, m20 temp for cluster)
__________________
BigD is offline   Reply With Quote
Old 08-10-2011, 03:42 PM   #14
cormier
6th Gear Member
 
cormier's Avatar
 
Join Date: Feb 2008
Location: St. George, ON
Posts: 1,607
Ya I have most of the swap plan of attack finalized -- with the exception of the wiring which I'm just starting to get into ...

Was planning on my m10 temp sensor, and treehouse adapter -- I actually didn't know about the obd1 sensors, I have the ZA conversion cd also that goes into some detail about harness modification but I haven't gotten my head around all the bits yet
__________________

cormier is online now   Reply With Quote
Old 08-10-2011, 04:12 PM   #15
BigD
the misanthropist
 
BigD's Avatar
 
Join Date: May 2002
Location: a house
Posts: 6,169
When you say ZA CD, do you mean the OBDII->I CD, or the 24v swap CD? The swap CD is good but they do a bit too much. The other problem with it is that they do an M50 swap, you're doing an S52. Overall the OBDI conversion is pretty trivial but none of the sensors are compatible. The S52 even has the trigger wheel at the front, and a bracket for the OBDI crank sensor, but you do need to buy one. The cam sensor is different too. The knock sensors won't work, same with the temp sensor for the engine. The S52 has a single sensor which sends the temp signal to the computer and cluster. So the head only has one sensor hole. You need to get a DME temp sensor for the one hole, and either drill/tap a hole for the cluster, or use the Zionsville temp manifold (good, clean solution).
__________________
BigD is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:59 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014