Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-02-2009, 03:51 AM   #1
sparkybp
Tortures BMWs.
 
sparkybp's Avatar
 
Join Date: May 2009
Location: Kitchener, Ontario
Posts: 347
Check Coolant Level - See owner's manual

I am getting a Check Coolant Level on the OBC but it only seems to be there when i turn the car off and when i start it sometimes (to the best of my knowledge) I checked the level and it's at the -------- COLD level in the tank(of course checked when motor was cold. is it called a overflow tank? it's got the bleeder screw right beside it, standing in front of the car it's on the left side of the rad)....

Also today my temp needle started rising within seconds to about 3/4 way when i caught it and shut her down. Turned it back on after a few seconds as I couldn't believe my eyes and started driving just so i can pop the hood somewhere safer (200 meters farther) and as I was driving away the temp needle went back down to normal within 3-4 seconds? What the shit ?
sparkybp is offline   Reply With Quote
Old 10-17-2009, 11:18 AM   #2
sparkybp
Tortures BMWs.
 
sparkybp's Avatar
 
Join Date: May 2009
Location: Kitchener, Ontario
Posts: 347
turns out its my sensor inside the expansion tank i believe
sparkybp is offline   Reply With Quote
Old 10-17-2009, 12:41 PM   #3
craigIS
A.K.A. crossfire291
 
craigIS's Avatar
 
Join Date: Feb 2007
Location: Chatham
Posts: 2,044
Send a message via MSN to craigIS
not to highjack this thread, but a friend of mione who is also on this forum is getting the same message. i told him to check his coolant. he said he did and its fine. i dont think with my friends case its a sensor, because i can smell coolant.

my friend doesnt think there is a leak, so to humor him, what else could this be?
__________________


flickr
craigIS is offline   Reply With Quote
Old 10-17-2009, 12:47 PM   #4
sparkybp
Tortures BMWs.
 
sparkybp's Avatar
 
Join Date: May 2009
Location: Kitchener, Ontario
Posts: 347
you can smell coolant inside the cabin or outside when standing in front of the hood? any spotting under the car after its parked in the same spot for a while? does the car overheat? have you actually checked the coolent level in the overflow tank?
sparkybp is offline   Reply With Quote
Old 10-18-2009, 07:51 AM   #5
Guetzer
1st Gear Newbie
 
Guetzer's Avatar
 
Join Date: Jul 2008
Location: Cape Town
Posts: 1
Yeah man those sensors keep breaking after a while... mine is also broken, its quite annoying, not so expensive to replace though.
Guetzer is offline   Reply With Quote
Old 10-18-2009, 07:36 PM   #6
craigIS
A.K.A. crossfire291
 
craigIS's Avatar
 
Join Date: Feb 2007
Location: Chatham
Posts: 2,044
Send a message via MSN to craigIS
i dont know about any spots on the ground, but the smell is in the cabin, and i havent noticed a smell outside
__________________


flickr
craigIS is offline   Reply With Quote
Old 10-19-2009, 04:17 PM   #7
sparkybp
Tortures BMWs.
 
sparkybp's Avatar
 
Join Date: May 2009
Location: Kitchener, Ontario
Posts: 347
weird how you can smell coolant inside the car, again have you checked the coolant level in the tank? also take a flashlight and look very carefully for any pieces of orange plastic floating around the tank, if thats the case its your sensor has broken apart, also if at idle sometimes you see your temp needle shooting towards the red and it comes back to normal as you're driving its your sensor being broken in piece inside the expansion tank and blocking coolant from passing through, when you start moving it pumps more coolant and shoots the plastic debree out of the way and allows proper circulation once again!
sparkybp is offline   Reply With Quote
Old 10-19-2009, 07:40 PM   #8
taxi615
3rd Gear Member
 
Join Date: Sep 2005
Location: quebec
Posts: 486
Mine did the same and it was the sensor in the expension tank. worked out for me this way.
taxi615 is offline   Reply With Quote
Old 10-20-2009, 12:16 AM   #9
Dr. Flyview
Formerly Flav_cool
 
Dr. Flyview's Avatar
 
Join Date: May 2006
Location: Toronto
Posts: 4,365
Send a message via MSN to Dr. Flyview
Mine has been doing the same recently. 50% of the time I turn the car off now it will throw low coolant warning.
__________________

1998 BMW 328is - summer
1994 BMW 325i - daily
1992 BMW 325i - totaled
1988 Mercedes Benz 190E 2.3-8V -
sold

Dr. Flyview is offline   Reply With Quote
Old 10-20-2009, 06:54 AM   #10
328is
tire don't like me
 
328is's Avatar
 
Join Date: Jan 2008
Location: terrebonne
Posts: 209
same problem here. Mine started when i did my fan delete mod.
__________________
race car souldn't be restricted to race track !
328is is offline   Reply With Quote
Old 10-20-2009, 11:46 AM   #11
Dr. Flyview
Formerly Flav_cool
 
Dr. Flyview's Avatar
 
Join Date: May 2006
Location: Toronto
Posts: 4,365
Send a message via MSN to Dr. Flyview
^^ Hmm I have the fan delete as well. I wonder if the comp notices the aux fan is coming on more than usual and says low coolant? However, it was fine for almost 2 years with the fan delete mod...no low coolant level warning.
__________________

1998 BMW 328is - summer
1994 BMW 325i - daily
1992 BMW 325i - totaled
1988 Mercedes Benz 190E 2.3-8V -
sold

Dr. Flyview is offline   Reply With Quote
Old 10-20-2009, 12:19 PM   #12
craigIS
A.K.A. crossfire291
 
craigIS's Avatar
 
Join Date: Feb 2007
Location: Chatham
Posts: 2,044
Send a message via MSN to craigIS
my friends car also has fan delete done.

ill see if i can find out more info tonight
__________________


flickr

Last edited by craigIS; 10-20-2009 at 12:26 PM.
craigIS is offline   Reply With Quote
Old 10-20-2009, 02:34 PM   #13
sparkybp
Tortures BMWs.
 
sparkybp's Avatar
 
Join Date: May 2009
Location: Kitchener, Ontario
Posts: 347
Highly doubt it has anything with the fan delete, do yo guys see any real improvement with fan delete?
sparkybp is offline   Reply With Quote
Old 10-21-2009, 07:01 AM   #14
328is
tire don't like me
 
328is's Avatar
 
Join Date: Jan 2008
Location: terrebonne
Posts: 209
Quote:
Originally Posted by sparkybp View Post
Highly doubt it has anything with the fan delete, do yo guys see any real improvement with fan delete?
I know that E36 are very hard to bleed so it might be some air that is traped in the system who trigger the switch ?

And yes i did see a small improvement with the fan delete mod. At 120$, you don't have to expect a lot of power gain. I think it's 2-3 hp, but it's in the lower end.
__________________
race car souldn't be restricted to race track !
328is is offline   Reply With Quote
Old 10-21-2009, 02:27 PM   #15
BMXWill
2nd Gear Member
 
BMXWill's Avatar
 
Join Date: Sep 2008
Location: Burlington
Posts: 262
I don't think it has anything to do with the fan delete, I have this check light on when I start my car all the time and I've yet to remove my fan. My coolant level is fine and it's not running hot so I don't worry about it too much.
BMXWill is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:05 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.