Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name

Welcome to!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Thread Tools Rate Thread Display Modes
Old 08-07-2011, 11:55 PM   #31
3rd Gear Member
blakneto's Avatar
Join Date: Jun 2009
Location: Hamilton/Brampton/Toronto
Posts: 322

takes about $75 to fill my 2003 325i - on that i get anywhere between 500km to 700km. Depends on how I drive.... if you have a heavy foot or do alot of stop/go driving, it will eat gas like a MOFO! Oddly i do find i get better mileage with Shell or Petro-Canada.

If I am really "careless" I'll be lucky if I get to 500km. (usually on PAYDAY!) :p

***Has anyone noticed their car's gas mileage performs a 1000 times better after you change your serpentine belt?
blakneto is offline   Reply With Quote
Old 08-30-2011, 12:18 PM   #32
2nd Gear Member
JvzwetE36325's Avatar
Join Date: May 2010
Location: 7mins 30secs to mosports gate :O
Posts: 211
I drive a lot of highway, over the past 1000+ km's i haven't reset my consumption and i'm averaging 8.2L/100km with a small amount of traffic and city driving in brampton. Mine is a 2000 540i (vanos) and 6-speed. if i reset and just do my highway i'll get around 7.5-8L/100 at around 115km/h
JvzwetE36325 is offline   Reply With Quote
Old 12-25-2011, 02:17 AM   #33
Mike e39
1st Gear Newbie
Mike e39's Avatar
Join Date: Dec 2011
Location: Mississauga
Posts: 13
i have ~15 L/100 km fuel consumption, with 80% of city driving computer shows 14l/100km .
after i reset computer i had 20L/100km for about 10 days slowly going down to regular mileage.
i reset computer after o2 sensors replacement, so when i released what consumption i am getting i regret i've done o2 sensors... but it seems to be ok now, and i have much better (steady) idle and no o2 code on dash...

this suumer i took trip to lake Huron. i've made about 650 and i had still some fuel left. (on old sensors) that was just after i bought this car so i was more enjoying driving than counting fuel, so i don't have exact numbers...

BTW this is 1997 540 manual, with 145000
Mike e39 is offline   Reply With Quote
Old 12-25-2011, 01:03 PM   #34
3rd Gear Member
MLue1's Avatar
Join Date: May 2008
Location: Markham
Posts: 456
Welcome to the board Mike.
'99 E39 540iT
MLue1 is offline   Reply With Quote
Old 12-25-2011, 02:24 PM   #35
Mike e39
1st Gear Newbie
Mike e39's Avatar
Join Date: Dec 2011
Location: Mississauga
Posts: 13
Thanks ... I'm glad to be part of such a nice community...
Mike e39 is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -4. The time now is 12:02 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015