Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Multimedia > Rides
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-10-2011, 12:50 PM   #16
cdmbmw
5th year, J-Man BMW Tech
 
cdmbmw's Avatar
 
Join Date: Nov 2010
Location: Victoria, B.C.
Posts: 27
well documented. Subscribed
cdmbmw is offline   Reply With Quote
Old 05-02-2011, 05:35 PM   #17
SoloII36
1st Gear Newbie
 
SoloII36's Avatar
 
Join Date: Jan 2010
Location: East Coast
Posts: 18
Haven't had much progress here other than installing the control arm bushings, they seem to work as planned. I have to order tires and then it should be good to go for the summer.

__________________
SoloII36 is offline   Reply With Quote
Old 05-02-2012, 10:53 PM   #18
98bimmer
2nd Gear Member
 
Join Date: Apr 2008
Location: Etobicoke
Posts: 149
update?
98bimmer is offline   Reply With Quote
Old 05-12-2012, 09:56 AM   #19
SoloII36
1st Gear Newbie
 
SoloII36's Avatar
 
Join Date: Jan 2010
Location: East Coast
Posts: 18
Small update here, but still an update. School got in the way last year for my car plans but things are looking good for getting the car back out into the wild.

I have been finishing a few bushings and mounts over the past couple weeks. I made solid transmission mounts and rear control arm bushings.

The four bushings for the upper and lower arms were very similar with the upper being offset (not shown in this pic). Bushing material is white Delrin.



and the transmission mounts are a bolt-through design (for now) I would have liked to do something with the uhmw nylon being the only connection in the middle of the mount. Oh well, these will still work but the nylon won't be doing a whole lot.



Install pics coming soon...
__________________
SoloII36 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:57 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.