Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-12-2011, 06:12 PM   #1
525Inc
1st Gear Newbie
 
Join Date: Sep 2010
Location: Brampton
Posts: 40
e34 caliper!!!!! help!!

hey guys whats up!! well i have my e34 525i and i was wondering if you all know where i can get a left rear caliper mine just seized on the hwy anyways if ne one can help please let me know thanks
525Inc is offline   Reply With Quote
Old 03-12-2011, 06:36 PM   #2
DYMO
JDM soul
 
DYMO's Avatar
 
Join Date: Aug 2009
Location: Toronto
Posts: 423
a bit far for you, but midland calipers here in scarborough has cheap rebuilds if you trade in the core
DYMO is offline   Reply With Quote
Old 03-12-2011, 06:53 PM   #3
525Inc
1st Gear Newbie
 
Join Date: Sep 2010
Location: Brampton
Posts: 40
thanks its not a problem about distance lol its the pain of the noise haha thanks ill look into them thanks!
525Inc is offline   Reply With Quote
Old 03-12-2011, 10:32 PM   #4
MLue1
3rd Gear Member
 
MLue1's Avatar
 
Join Date: May 2008
Location: Markham
Posts: 451
I rebuilt the front right one on my E39 last fall. Once you've done one or seen it done it is really quite easy. The cause is usually a bit of rust on the piston just under the dust boot. Steel wool and some brake fluid will easily clean up the piston.
__________________
Mark
'99 E39 540iT

Last edited by MLue1; 03-12-2011 at 10:34 PM. Reason: adding more info
MLue1 is offline   Reply With Quote
Old 03-13-2011, 09:54 PM   #5
525Inc
1st Gear Newbie
 
Join Date: Sep 2010
Location: Brampton
Posts: 40
thanks i got it working again it was rusted to shit lol but i had a good convo with it me the c clamp and a hammer and well lets just say i got it to see my way haha ne ways thanks guys i appreciate you msg me!
525Inc is offline   Reply With Quote
Reply

Tags
e34 brakes

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:05 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.