Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-22-2011, 08:40 AM   #1
muxruk
2nd Gear Member
 
muxruk's Avatar
 
Join Date: Oct 2009
Location: Toronto
Posts: 55
Question E39 seats replaced caused airbag light on and heater not working .... HELP!!!

Ok, so I replaced yesterday seats on my e39 with basically the same one I had but in mint shape, so I have one small yellow conector under passenger side which doesn't connect to a new seat as there is no plug for it, I was wondering what is it for if someone know?
But the main issue is that my heated seats not working , u press the heated seat button it lights on and after automatically shuts off in few seconds, on both sides ...????
Also my airbag light stays on all the time now...
So swap ended up bringing not much happy feeling as was excpected ...
Fellows please help , any ideas ? I assume that's some eletronical issue... Ecu doesn't recognize new seats .... Is there some important sensor in seat maybe I need to take of my old seats and install on new ones....
I dunno.... (((((((((((
muxruk is offline   Reply With Quote
Old 02-22-2011, 11:21 AM   #2
BimmerGuys
2nd Gear Member
 
BimmerGuys's Avatar
 
Join Date: Aug 2010
Location: Toronto
Posts: 209
You need a scanner to reset airbag light, and you have a bad connection somewhere that's the reason why heated seats doesn't work,
BimmerGuys is offline   Reply With Quote
Old 02-22-2011, 12:22 PM   #3
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,882
Most likely you got the wrong seats for the car, as not all E39's are the same; they look identical but wiring is not! You also did the job without disconnecting the battery, this is why the airbag light is on (happens every time you unplug a safety device such as bag or seatbelt buckle).
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E34 E39 E60 E32 E38 E65 E66 X5 M3 M5


Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 02-22-2011, 12:43 PM   #4
muxruk
2nd Gear Member
 
muxruk's Avatar
 
Join Date: Oct 2009
Location: Toronto
Posts: 55
Yeah actually I didn't disconect the battery ....
I did disconect it overnight hoping the system gonna reset and everythig gonna work but it didn't...
So ok, I will reset the lights... What do I do with the seats heater... Is it possible to use maybe some wiring from my old seat ... Any ideas what exactly needs to be replaced
Cuz the conectors looked exactly the same and the power options work correct, I got the seats from 97 528i mine is 98 528i...
still wondering about that second small yellow conector under passenger seat
....


Thank you guys ! U r being very helpful !
muxruk is offline   Reply With Quote
Old 02-22-2011, 12:50 PM   #5
Quack
Wheelman
 
Quack's Avatar
 
Join Date: Jul 2002
Location: Toronto
Posts: 12,055
Send a message via MSN to Quack
yellow connectors normally mean SRS, it can be anything from airbags to seatbelts/buckles.
__________________

Maxbimmer Drama, You Gotta Love It
Quack is online now   Reply With Quote
Old 02-22-2011, 08:38 PM   #6
muxruk
2nd Gear Member
 
muxruk's Avatar
 
Join Date: Oct 2009
Location: Toronto
Posts: 55
ppl common,
someone knows how to fix this heated seats ?
muxruk is offline   Reply With Quote
Old 02-22-2011, 10:14 PM   #7
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,882
Quote:
Originally Posted by muxruk View Post
ppl common,
someone knows how to fix this heated seats ?
Yes, but it's a pain, and will cost 5x more then buying working seats!
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E34 E39 E60 E32 E38 E65 E66 X5 M3 M5


Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 02-23-2011, 12:48 AM   #8
MLue1
3rd Gear Member
 
MLue1's Avatar
 
Join Date: May 2008
Location: Markham
Posts: 451
Quote:
Originally Posted by muxruk View Post
ppl common,
someone knows how to fix this heated seats ?
I doubt many have ventured into this area. If it was me I would pull both seats and trace and compare the wiring and pins on the connectors. Even if someone were to tell you what to do you would still have to do alot of this work anyway to splice the connections or to change the pin configuration on the connector(s).
__________________
Mark
'99 E39 540iT

Last edited by MLue1; 02-23-2011 at 12:51 AM. Reason: more comment
MLue1 is offline   Reply With Quote
Old 02-27-2011, 10:49 AM   #9
daveyto
2nd Gear Member
 
daveyto's Avatar
 
Join Date: Apr 2009
Location: Toronto
Posts: 213
i haven't read the whole thread but i will reset the SRS light for you for for free.

Just send me a PM or call me fouronesixeightthreefourninefivenineeight

dave
daveyto is offline   Reply With Quote
Old 03-02-2011, 11:41 AM   #10
spencercat
1st Gear Newbie
 
Join Date: Mar 2011
Location: CT
Posts: 3
You'll need to reset the SRS code with a scanner. I got the CARSOFT software on the 'net and bought the connector on ebay to attach my laptop. I think the cables cost about $50, but I spent a few hours getting it to all work right. No time to get into it, but if you search bimmerforums you should find what you need.

You may also need to fool the car into thinking the passenger seat sensor is OK. My SRS light was triggered by a failed passenger seat sensor and I was able to reset it after wiring in a diode/rectifier/capacitor combo to the wiring harness. Search around for that solution if you find the seat sensor is kicking out the code and you can't get it to reset. HTH
spencercat is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:08 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.