Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Classifieds > Supporting Vendor Comments/Feedback > RMP Motors
User Name

Welcome to!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Thread Tools Rate Thread Display Modes
Old 02-16-2011, 10:09 PM   #1
3rd Gear Member
Join Date: Mar 2005
Location: toronto
Posts: 328
happy with service - again!

thanks Rocco!

had inspection II, replaced front thrust, sway bar, pads/rotors, and wiper blades done today. very satisfied, wagon runs very nicely now.
atm2000 is offline   Reply With Quote
Old 02-26-2011, 04:55 PM   #2
4th Gear Member
Join Date: Oct 2009
Location: St Catharines
Posts: 792
rocco see pm, didnt want to waste a thread so piggyback this one lol
4cyl autotragic woes...
tg07lq is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -4. The time now is 06:17 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015