Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-20-2010, 05:25 PM   #1
1minte46
2nd Gear Member
 
Join Date: Feb 2010
Location: Toronto
Posts: 58
Talking What is wrong with my car??!?

Alright guys here is the situation. I have already searched E46 Fanatics and a couple of other websites to see if i could find a solution but it seems that there are many possibilities, so I was looking for Maxbimmer members input into this. So basically here is what has been happening for the past 2 weeks or so my engine light has been coming on and turning off, I connected my OBDII reader to my car and happened to find the following codes.

P1343 Misfire cylinder 1 with fuel cutoff

P1352 Misfire during start cylinder 6

P1350 misfire during start cylinder 5

P0174 System to lean (bank 2)

P0171 System to lean (bank 1)

P1345 Misfire cylinder 2 with fuel cutoff

P0300 Random misfire detected

P1619 Map cooling thermostat control circuit signal low

P0300 Random misfire detected

P1083 Fuel control limit mixture too lean (bank 1, sensor 1)

In addition to this, the way that my car is acting is as follows, the idling is rough at times, when i accelerate the car tends to bog, its as if it's confused lol. Also last night was a little nippy outside, so i turned on the car to let it warm up, as I waited 2-3 minutes I noticed a red light come on , and basically it was my temperature gauge all the way to the right as if it was over heating, but yet when I had the heat on, no heat would come through what so ever, the air coming in wasn't hot or cold. So I decided to drive the car for a bit to see if it would make a difference in the heat coming in, and wouldn't you know it made a difference, heat started to come through the vents and and the temperature gauge went down to normal. Does anyone know what could possibly be happening, because this happens randomly like it will go away and then come back so on and so forth. One more thing that I would like to add is that, when I purchased the vehicle from the used dealership, the motor had to be replaced 24 hours after I had bought it, because the timing chain blew, so apparently they showed me a receipt and calimed they replaced my old motor with a newer one that had less mileage, do you guys think that they probably screwed up when putting the motor in, or the motor that they put is garbage. I wonder if my powertrain warranty will cover these problems.
1minte46 is offline   Reply With Quote
Old 09-20-2010, 07:37 PM   #2
Junaid
4th Gear Member
 
Join Date: Nov 2007
Location: Toronto
Posts: 670
temp gauge sounds like thermostat, and the other issues could be anything from maf to ignition coils to spark plugs. Im going to put my money on the maf, but i would get it read by a gt1 to find out exactly what it is.
__________________


Needs more mods
Junaid is offline   Reply With Quote
Old 09-20-2010, 11:49 PM   #3
1minte46
2nd Gear Member
 
Join Date: Feb 2010
Location: Toronto
Posts: 58
Yes, I thought it would have been the thermostat, so now should I be replacing the thermostat or the sensor isn't working properly. Secondly should I purchase my own gt1 or would it be cheaper just to go to a mechanic shop that might have one. The question once again applies to the MAF would i be replacing the whole thing or would it be the sensor. If it is any of the following would you happen to know if its better to get stock bmw or are there any good aftermarket ones that are good? Thank You,
1minte46 is offline   Reply With Quote
Old 09-21-2010, 12:25 AM   #4
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 15,064
Quote:
Originally Posted by 1minte46 View Post
Yes, I thought it would have been the thermostat, so now should I be replacing the thermostat or the sensor isn't working properly. Secondly should I purchase my own gt1 or would it be cheaper just to go to a mechanic shop that might have one. The question once again applies to the MAF would i be replacing the whole thing or would it be the sensor. If it is any of the following would you happen to know if its better to get stock bmw or are there any good aftermarket ones that are good? Thank You,
You should really check the price of a gt1 before asking!
The MAF is just one thing, nothing else to replace! Again, its all about price, new one is $600-700 OEM, but you might have some cheaper options.
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


Etobicoke location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is online now   Reply With Quote
Old 09-23-2010, 01:12 AM   #5
Junaid
4th Gear Member
 
Join Date: Nov 2007
Location: Toronto
Posts: 670
im not really sure how often your car breaks to justify buying a gt1 haha, but on ebay you can buy chinese version of a gt1 and i believe mark d has one not sure if he sells them or not. Like Filip said if you dont want brand new he sells them. If you unplug the maf and drive if it drives better then i believe for sure its gone bad.
__________________


Needs more mods
Junaid is offline   Reply With Quote
Old 09-23-2010, 01:32 PM   #6
Ahctuning
2nd Gear Member
 
Ahctuning's Avatar
 
Join Date: Aug 2002
Location: Torono
Posts: 288
Quote:
Originally Posted by Junaid View Post
im not really sure how often your car breaks to justify buying a gt1 haha, but on ebay you can buy chinese version of a gt1 and i believe mark d has one not sure if he sells them or not. Like Filip said if you dont want brand new he sells them. If you unplug the maf and drive if it drives better then i believe for sure its gone bad.
What if you unplug the maf and it got worst than worse? (worse meaning engine was already backfiring when revved, coughing)
Ahctuning is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:12 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014