Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Old 09-06-2010, 05:30 PM   #1
matty.dc
5th Gear Member
 
matty.dc's Avatar
 
Join Date: Feb 2008
Location: Hamilton
Posts: 1,108
Send a message via MSN to matty.dc
E30 m20 misfire

Update: Compression is good, timing is redone, impulse wire replaced, broken vacuum line to fpr fixed. The car is still missing at idle and throughout driving range. I changed afm's to see if it made a difference, but nothing.

Any ideas????? CPS??? Clogged injectors maybe ????

Thanks

Matt
__________________

1987 325is(Midnight Tuning Tuned OBD I S52) - Current Summer Car
2012 Hyundai Veloster Tech- Daily Driver
1985 318i - 1st Car (started it all)
matty.dc is offline   Reply With Quote
Old 09-06-2010, 05:43 PM   #2
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,384
carbon build up on the valves maybe.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is online now   Reply With Quote
Old 09-06-2010, 06:07 PM   #3
everlast
if I lived . I would be ~
 
everlast's Avatar
 
Join Date: Mar 2004
Location: Ottawa
Posts: 5,847
Pull each plug wire individually to see which cylinder is misfiring. If you find it, it will not sound any different. You could then try swapping plug wires around, pulling plugs and examining them, etc.

If you suspect carbon or fouled injectors, try running Seafoam through it. (The product, not the foamy pollution on Lake Ontario.)

I'd really focus on finding the offending cylinder, and examine the plugs. You will see if its missing fuel or spark that way, narrowing the troubleshooting process significantly.
__________________
everlast is offline   Reply With Quote
Old 09-06-2010, 09:09 PM   #4
matty.dc
5th Gear Member
 
matty.dc's Avatar
 
Join Date: Feb 2008
Location: Hamilton
Posts: 1,108
Send a message via MSN to matty.dc
cylinder 4 is the culprit, i checked spark before and it was good.
__________________

1987 325is(Midnight Tuning Tuned OBD I S52) - Current Summer Car
2012 Hyundai Veloster Tech- Daily Driver
1985 318i - 1st Car (started it all)
matty.dc is offline   Reply With Quote
Old 09-06-2010, 09:27 PM   #5
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,384
If you suspect carbon or fouled injectors, try running Seafoam through it. (The product, not the foamy pollution on Lake Ontario.)

Where does one get this "seafoam?" I need to decarbon my car.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is online now   Reply With Quote
Old 09-06-2010, 10:08 PM   #6
everlast
if I lived . I would be ~
 
everlast's Avatar
 
Join Date: Mar 2004
Location: Ottawa
Posts: 5,847
Napa carries it. Amazing stuff.

So you know its cylinder 4? Switch wires from 3 and 4 and see if the miss is still in 4. Then you've narrowed it to either the plug, injector or cylinder.

Change the plug, run seafoam or pull the injectors and have them ultrasonically cleaned, test compression / leak down on cylinder 4.
__________________
everlast is offline   Reply With Quote
Old 09-07-2010, 02:09 AM   #7
iignite
2nd Gear Member
 
Join Date: Jul 2008
Location: mississauga
Posts: 238
just under load? or when you're idling as well?
iignite is online now   Reply With Quote
Old 09-07-2010, 04:01 AM   #8
voluted
2nd Gear Member
 
voluted's Avatar
 
Join Date: May 2009
Location: Richmond Hill, Ontario
Posts: 233
When I first got my car it had been sitting in a driveway for around 6 years. The gas that was drained from it was brown and was filled with particles. I didn't think much of it at the time (new to cars) and cleaned the tank as best I could then filled it with gas and drove it for almost a year before my injectors were filled with extremely fine rust particles from the gas tank. If you suspect a fouled injector, take the pump out and look in the tank with a flashlight. If theres crap swimming around at the bottom there is a good possibility that some made it's way past the sock filter and the external fuel filter and clogged the filter in the injector.

My car was running on 3 cylinders much like yours is now and it happened within minutes it seemed. Although I wasn't getting white smoke from my exhaust. Different motor though (M42 then).
voluted is offline   Reply With Quote
Old 09-07-2010, 04:56 PM   #9
matty.dc
5th Gear Member
 
matty.dc's Avatar
 
Join Date: Feb 2008
Location: Hamilton
Posts: 1,108
Send a message via MSN to matty.dc
the white smoke is cured it was a broken vacuum line to the fpr.... and the car misses at all ranges and idle.
__________________

1987 325is(Midnight Tuning Tuned OBD I S52) - Current Summer Car
2012 Hyundai Veloster Tech- Daily Driver
1985 318i - 1st Car (started it all)
matty.dc is offline   Reply With Quote
Old 09-07-2010, 07:04 PM   #10
hosty
323i???
 
hosty's Avatar
 
Join Date: Nov 2009
Location: Burlington
Posts: 299
m50 swap? lol
hosty is offline   Reply With Quote
Old 09-07-2010, 09:27 PM   #11
matty.dc
5th Gear Member
 
matty.dc's Avatar
 
Join Date: Feb 2008
Location: Hamilton
Posts: 1,108
Send a message via MSN to matty.dc
haha ill go big or go home on that issue 5.0
__________________

1987 325is(Midnight Tuning Tuned OBD I S52) - Current Summer Car
2012 Hyundai Veloster Tech- Daily Driver
1985 318i - 1st Car (started it all)
matty.dc is offline   Reply With Quote
Old 09-07-2010, 09:44 PM   #12
MarkD
Banned
 
MarkD's Avatar
 
Join Date: Apr 2002
Location: In Your DME!
Posts: 2,414
Quote:
Originally Posted by everlast View Post
So you know its cylinder 4? Switch wires from 3 and 4 and see if the miss is still in 4. Then you've narrowed it to either the plug, injector or cylinder.
Some people may not follow that you mean swap the complete wire from the distributor cap to the spark plug. Thay may think it means swap wires from 3 and 4 at the spark plug end only.
MarkD is offline   Reply With Quote
Old 09-07-2010, 11:00 PM   #13
matty.dc
5th Gear Member
 
matty.dc's Avatar
 
Join Date: Feb 2008
Location: Hamilton
Posts: 1,108
Send a message via MSN to matty.dc
i changed the wire totally and same problem....could it be a bad motronic unit?
__________________

1987 325is(Midnight Tuning Tuned OBD I S52) - Current Summer Car
2012 Hyundai Veloster Tech- Daily Driver
1985 318i - 1st Car (started it all)
matty.dc is offline   Reply With Quote
Old 09-07-2010, 11:31 PM   #14
matty.dc
5th Gear Member
 
matty.dc's Avatar
 
Join Date: Feb 2008
Location: Hamilton
Posts: 1,108
Send a message via MSN to matty.dc
it threw a code 1222 when i did the stomp test.
__________________

1987 325is(Midnight Tuning Tuned OBD I S52) - Current Summer Car
2012 Hyundai Veloster Tech- Daily Driver
1985 318i - 1st Car (started it all)
matty.dc is offline   Reply With Quote
Old 09-08-2010, 12:57 AM   #15
Nick_V
6th Gear Member
 
Nick_V's Avatar
 
Join Date: Feb 2009
Location: Hamilton
Posts: 1,286
1222 means the DME senses a rich or lean condition for more than 10 seconds. If I'm reading correctly, you've isolated the problem to cylinder 4, verified that there's spark, and have good compression across the board. The only thing that really leaves is the injector or the electrical connection to it, I think.

That code is a bitch. I just got rid of it on my M42 after lots of trial-and-error. Turned out to be the FPR.
Nick_V is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014