Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-04-2010, 02:50 PM   #1
audi5000
2nd Gear Member
 
audi5000's Avatar
 
Join Date: Nov 2009
Location: ontario
Posts: 190
E30 tach not working

my tach decided to quit out on me a while back.
i did some research and was told it was the SI board batteries.
so i decided to get the 7K cluster to go with the I engine.

swapped in that cluster hoping the tach would work with the new board and its still not working?

is there anything else i should check?
what controls the tach?
audi5000 is offline   Reply With Quote
Old 06-04-2010, 02:54 PM   #2
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,212
Check the wiring going into the instr. pod from behind. The tach I believe is controlled by the dme.(main computer) make sure they are securely pressed in with the hold down clip in place.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is offline   Reply With Quote
Old 06-04-2010, 04:49 PM   #3
audi5000
2nd Gear Member
 
audi5000's Avatar
 
Join Date: Nov 2009
Location: ontario
Posts: 190
yeah it looks like its all in.
i do have a very small round plug with 2 wires on it?
smaller and an end of a pencil?
audi5000 is offline   Reply With Quote
Old 06-04-2010, 04:52 PM   #4
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,212
Quote:
Originally Posted by audi5000 View Post
yeah it looks like its all in.
i do have a very small round plug with 2 wires on it?
smaller and an end of a pencil?
those are the smaller dash lights I believe.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is offline   Reply With Quote
Old 06-04-2010, 04:55 PM   #5
audi5000
2nd Gear Member
 
audi5000's Avatar
 
Join Date: Nov 2009
Location: ontario
Posts: 190
ahh okay.
my temp gauge still works too.
i was told the tach and the temp usually go together?
audi5000 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:40 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.